Welcome! Log In Create A New Profile


Slic3r does not run on Linux Mint 18

Posted by cliffgi 
Slic3r does not run on Linux Mint 18
June 15, 2016 11:22AM
Bleeding edge Linus Mint 18 beta was released last week. Slic3r (v1.2.9) needs a prerequisite package libwxgtk2.8-dev, among others. All libwxgtk packages were upgraded to v3.0 in Mint 18. As a result, there does not appear to be any method for installing and running slic3r on Linux Mint 18. If this be true, it would really draw in some serious air. Any thoughts out there?
Re: Slic3r does not run on Linux Mint 18
June 15, 2016 07:09PM
wxWidgets 3 has been out for a while - I upgraded my own software to use it instead of 2.x more than two years ago. Hopefully slic3r will be upgraded to use wxWidgets 3 soon. In the mean time, can't you install wxWidgets 2.8?

Edited 1 time(s). Last edit at 06/15/2016 07:10PM by dc42.

Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Slic3r does not run on Linux Mint 18
June 16, 2016 01:46PM
Apparently I'm not able to down grade to wxWidgets 2.8. If it is possible, I don't know how to override Synaptic or apt-get defaults. Synaptic does not show as an available package, and apt-get fails with a package not found notice. I assume packages are filtered by OS version to ensure platform stability.
Re: Slic3r does not run on Linux Mint 18
June 17, 2016 10:55PM
If this has been a problem for 2 or more years, I guess I shouldn't hold my breath. Looks like more and more systems will become incompatible as folks upgrade their linux OS. I have not found any developer contact or feedback mechanism... never a good sign. Bummer!

Any recommendations on good slic3r alternatives?

Edited 1 time(s). Last edit at 06/17/2016 10:58PM by cliffgi.
Re: Slic3r does not run on Linux Mint 18
June 21, 2016 11:36PM
I am running libwxgtk 3 and slic3r 1.2.9 and 1.3 successfully. I assume you are using Synaptic or apt-get to install slic3r? If so I'm guessing the prerequisite is in your package manager, not slic3r
Re: Slic3r does not run on Linux Mint 18
June 24, 2016 05:16PM
Does not work for me. The Slic3r official site states in the instruction for Linux:

Extract the archive to a folder of your choosing. Either:

Start Slic3r directly by running the Slic3r executable, found in the bin directory, or

Install Slic3r by running the do-install executable, also found in the bin folder.

The archive file may then be deleted.

When I attempt to run Slic3r as stated above it yields a syntax man page, not the app. There is no "do-install" file in the bin directory, as claimed in the install instruction, only the Slic3r executable, which as I said, don't work.

Optionally, I attempted to compile from GitHub. The instruction there tells of the libwxgtk2.8 prereq, and gives the sudo cmd to install. The cut/paste command fails to install. Libwxgtk3.0 is already installed on Linux Mint 18 by default. Uninstalling it in an attempt to install 2.8 fails. The 2.8 package is not valid for Mint 18. Ignoring the error and proceeding on results in compile errors later on in the lengthy process. I guess I'm done with slicr3 until they come up with a deb package or fix problems in the current release. I installed 1.2.9 no problems in Ubuntu 14.04.

Absolutely hate having to dual-boot Win7 for slic3r but it is my only choice a present.

If anyone can provide a detailed install instruction for slic3r on libwxgtk3.0, I'd be forever your slave.
Re: Slic3r does not run on Linux Mint 18 -- solved
August 04, 2016 07:13PM
I got a lot of errors each step of the installation of slic3r!!!!!!
linux mint does not support it eventhough you can do a
sudo apt install slic3r from terminal, it does not run and does not open up a GUI..
it will put an icon and reference in your program menu under other
do a
sudo apt autoremove slic3r

please note:::::::::: if you receive any other error besides something that says disabled in the build(do not worry about these), post it here,
I could have left out a step, it took me 6 hours to install this, trial and error

here arte the install instructions:::
here are the requirements:::::::::
libwxgtk2.8, opengl (use mesa), there are a few others , see below.

use debian packages if mint ones are not available. 2 versions of a package can be installed causing no harm to your system, eg libwxgtk2.8 and libwxgtk3.0(default in mint 18)
libwxgtk2.8 can be downloaded here, [www.deb-multimedia.org] its a deb package, install in usually way
here are the commands for it::

install instructions from github: [github.com]
I used the debian jessie ones;;
Debian 8 (Jessie)

$ sudo apt-get install -y build-essential cpanminus liblocal-lib-perl
$ sudo apt-get build-dep slic3r
$ sudo apt-get install -y libxmu-dev freeglut3-dev libwxgtk-media2.8-dev
$ sudo apt-get install libboost-thread-dev libboost-system-dev libboost-filesystem-dev

I also done the following as I had lots of errors when installing:
sudo su
apt install gcc g++ libgtk2.0-dev libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev libglu1-mesa-dev libexpat1-dev libtiff4-dev libpng12-dev libjpeg-dev libcairo2-dev freeglut3-dev libxmu-dev
apt install freeglut3 freeglut3-dev libglew1.5 libglew1.5-dev libglu1-mesa libglu1-mesa-dev libgl1-mesa-glx libgl1-mesa-dev
apt install --reinstall libgl1-mesa-dev libxmu-dev
apt install binutils-gold g++ cmake libglew-dev g++ mesa-common-dev build-essential libglew1.5-dev libgim-dev libglut

grab slic3r::::::::::
Get Slic3r (stable)
$ git clone [github.com]
$ cd Slic3r
$ git checkout -b origin/stable

Update Slic3r
$ git pull

eval $(perl -Mlocal::lib)
export LDLOADLIBS=-lstdc++
I used Perlbrew tobuild :::::::::::
CPANM=~/perl5/perlbrew/bin/cpanm perl Build.PL
CPANM=~/perl5/perlbrew/bin/cpanm perl Build.PL --gui

I had no slic3r on my application menu;;;;;;
so done following
Create a file in your favorite text editor, call it slic3r and paste the following into it:
eval $(perl -Mlocal::lib)
cd ~/Downloads/Slic3r
perl ./slic3r.pl $*

save it to Desktop as slic3r( when double clicked - run in terminal)
note (I downloaded slic3r from github and unpacked it in Downloads folder) my slic3r folder is in downloads where I unpacked it , so need to add --> cd ~/Downloads/Slic3r
make it executable;;;;;;;;;;;;;;;;;
chmod +x slic3r

Make the slic3r.pl executable with

chmod +x ~/Downloads/Slic3r/slic3r.pl

double click on slic3r on your desktop and run in terminal

set the program up the way you like.

**** I also tried to install slic3r using sudo apt install slic3r,
this does not work, but puts a shortcut in menu --> Applications --> Other --> Slic3r
when slic3r is clicked from this menu, nothing happens, to change this
right click the Slic3r shortcut on Menu --> Applications --> Other --> Slic3r
left click on Edit Properties
click on browse
N.b. navigate to the directory that you installed Slic3r in and click on slic3r.pl (this file should already be executable)
in my case, ~/Downloads/Slic3r/slicer.pl

click close.

now click on the Menu --> Applications --> Other --> Slic3r

it should open slic3r and work!!!!!!!

Edited 1 time(s). Last edit at 08/06/2016 02:09PM by joogan.
open | download - Screenshot at 2016-08-04 19-12-39.png (47.6 KB)
Sorry, only registered users may post in this forum.

Click here to login