Welcome! Log In Create A New Profile


Support/Adaptive layers

Posted by frankvdh 
Support/Adaptive layers
April 04, 2018 01:00AM
I've just spent several days working out why this item, scaled 650%, wouldn't print. Part of the issueseems to be the way the support is generated by Slic3r when Adaptive Layering is enabled.

It seems that supports are always printed at the maximum layer height... this makes sense, since quality isn't critical in supports, and they're more or less vertical anyway. OTOH, it also means that during printing, the support height is usually out of step with the main object's height. So the main object might have layers at 0.3, 0.4, 0.55, 0.65, whereas support is at 0.3, 0.6, etc. Somehow this disparity in heights caused me adhesion problems in the support, including the first layer, followed by the nozzle dragging the unadhered support onto the main object, and pretty soon a big pile of spaghetti. sad smiley As soon as I turned off Adaptive Layering, it worked just fine.

Extending this idea... I'm guessing that if I print 2 objects of different shapes, different layer heights will apply to each object, depending on where the horizontal surfaces are in each of them. And further... if I have a model of (say) a wolf, does each of the 4 legs have a different set of layers depending on the geometry of each leg, and the layers unify when the legs get connected to each other? In these scenarios, I'd potentially be back to adhesion problems and spaghetti.

So... I'd like an option in Slic3r to turn off this behaviour, so that if Adaptive Layering is enabled, the same layer height and thickness applies to everything.

Edited 1 time(s). Last edit at 04/04/2018 01:01AM by frankvdh.
Re: Support/Adaptive layers
April 04, 2018 02:17AM
In my slicerPE there is an option in the support-menu called synchronize with object layers
I haven't tried it, but it sounds like the solution for your problem.

Edited 1 time(s). Last edit at 04/04/2018 02:18AM by o_lampe.
Re: Support/Adaptive layers
April 04, 2018 02:37AM
Thanks... it's not there in my v1.30-dev (Slic3r-1.3.0-dev-4db029c-x86_64). sad smiley
Sorry, only registered users may post in this forum.

Click here to login