Welcome! Log In Create A New Profile


[ArchLinux] Crash when using custom config files

Posted by tuxmain 
[ArchLinux] Crash when using custom config files
October 22, 2019 02:19PM

I am new to Slic3r, before I was using Cura but its package for ArchLinux got broken.

I installed Slic3r with the AUR package `slic3r-bin` (because `slic3r` gives errors).

It starts perfectly, but when I save config with the GUI button, it crashes. When I start it with the 3 config directories empty (filament, print, printer), it works fine. When there is a file in one of these folders, it gives an error:


free(): invalid pointer
Abandon (core dumped)

I tried different combinations, but nothing worked.

Is this a known bug, do you know how to fix it, or could you show me the content of your config files ?
Re: [ArchLinux] Crash when using custom config files
November 09, 2019 04:04AM
The problem seems to be fixed with the AUR package `slic3r-dev`, which is Slic3r 1.3.1 (instead of 1.3.0).

I hope this will be helpful for other ArchLinux users...
Sorry, only registered users may post in this forum.

Click here to login