Welcome! Log In Create A New Profile


SD Card upload menue

Posted by scuba 
SD Card upload menue
January 27, 2012 04:12AM
Lately I had an issue freezing the repetier host gui while uploading a file to my sdcard.
I'm using a resistor based sd card adapter and so I think its mainly a hardware related problem which isn't caught by the host. (For example I've noticed that my sdcard isn't allways mountable by repetier firmware)

reproducing the behavior:

- start Repetier Host
- power up mainboard
- connect host and mount sdcard
- power off Mainboard (leaving host in connected state)
- disconnect sdcard adapter
- power up mainboard (fw reports "sd init fail")
- sd menue still allows an upload and freezes after transfering the whole GCODE (seen in Log)

So it seems as if the sdcard menue isn't reinitiated after a firmware reset.
In my case i belive that sdcard communication might fail sometimes during the write process which leads to the same bahavior as if there were no sdcard present.
Re: SD Card upload menue
February 02, 2012 05:53AM
I bought a data logging sheild recently which has a SD card, I remember the bumph mentioned that voltage dividers
are not stable and a regulator is better, I assume this is what you mean by resistor based adaptor??.

if not ignore the above.

Random Precision
Re: SD Card upload menue
February 03, 2012 03:27AM
Hi John!

Yes ; I've built the board according to this schematic [img441.imageshack.us] .
I've allready switched to a 74HC4050 hex buffer/converter which seems to work real well.
Unfortunately my "stupid user scenario" produces the same behavior in repetier Host. I have'nt tried it in windows anymore so it might be only an issue on my linux.
Re: SD Card upload menue
February 03, 2012 01:10PM
I reliable level converter is really needed. The results of unreliable sdcard communication are unpredictable.

I tried your "stupid user scenario" with my windows box, but couldn't reproduce it. After disabling the firmware and reconnecting it, i had no connection also windows didn't signaled a disconnect. So no commands were send/received, but the host was still usable. After some disconnects to started working again. I remember the behavior was a bit different with my old Vista computer. Anyway, that is a scenario that shouldn't happen during normal operations, so I think we can live with it, until I see an explanation for this.

Repetier-Software - the home of Repetier-Host (Windows, Linux and Mac OS X) and Repetier-Firmware.
Repetier-Server - the solution to control your printer from everywhere.
Visit us on Facebook and Twitter!
Sorry, only registered users may post in this forum.

Click here to login