Welcome! Log In Create A New Profile


Can't connect after upgrade to V1.01 on Linux Ubuntu 14.04LTS

Posted by paynterf 
Can't connect after upgrade to V1.01 on Linux Ubuntu 14.04LTS
August 15, 2014 11:05PM
Everything was working fine on my Ubuntu 13.04 LTS system with Repetier V0.95. I upgraded my OS from 13LTS to 14.04LTS and then Repetier v0.95 started crashing as soon as I clicked the 'Connect' button. So, I upgraded to Repetier V1.01. Now Repetier comes up fine, but the Connect button does nothing.

I see 'Disconnected: printrbot' in the status window at the bottom
In Config/Printer Settings, I can select my previous 'printrbot' connection configuration which is:

Serial Connection
DTR high->low
Send emergency...

>groups shows my username is part of the 'dialout' group

logfile is enabled, but empty

Selecting the 'default' printer doesn't solve the problem.

About every third time I try to connect, Repetier crashes. Nothing in the log.

I launched Repetier from the command line using './repetierHost' and when I clicked on the Connect button I got an error message "couldn't set desired baud rate 128000. Forcing set baudrate failed". However, when I looked back at the printer settings, the connection rate now showed 128000.

Then I manually changed the baud rate back to 250000 and clicked on Connect again. This time I got an error "baud_base (1152000) does not allow setting custom baud rate"

So, I manually changed to 115200, and now the Connect icon changes to green, and the status line says "connected: printrbot", but I movement commands don't seem to work in manual mode

I see "XX Command Waiting" at the top of the manual window, where XX keeps growing as I try things on the manual panel.

If I disconnect and reconnect, I immediately get '7 Command Waiting' and then the number increments every time I try to send a command (like enabling the extruder heater)

I disconnected, then power cycled the printrbot. Then I clicked on Connect again, and this time I got a bunch of error messages on the command line as follows:

"Opening serial failed on second try: System.IO.IOException: Device or resource busy at System.IO.Ports.SerialPortStream.ThrowIOException()"
at System.IO.Ports.SerialPortStream..ctor(System.String portName, Int32 baudRate,Int32 databits, Parity parity, ....)
at System.IO.Ports. SerialPort.Open()
at RepetierHost.connector.SerialConnector.Connect

Unhandled Exception:
System.IO.IOException: Bad file descriptor
at System.IO.Ports.SerialPortStream.ThrowIOException()

Same behavior with the 'default' printer. I can get it to show 'Connected: default', but no commands make it through.

BTW, I noticed that the 'Printer Settings" selection is disabled under the 'Config' menu item when the printer is 'Connected', it IS NOT disabled under the 'Printer Settings' (gear icon) menu item on the far right-hand side of the main window. IOW, I can change connection settings WHILE THE PRINTER IS CONNECTED - oops!

To reiterate, I have been happily using V0.95 and Ubuntu 13.04LTS for some time now, but the combination of the upgrade to Ubuntu 14.04LTS and Repetier V1.0.1 has me dead in the water. Any help/clues would be appreciated.

Re: Can't connect after upgrade to V1.01 on Linux Ubuntu 14.04LTS
August 16, 2014 09:31AM
OK, came back this morning with some more brain cells firing and got it to work. After looking though some more RH documentation I found something that talked about comms problems and recommended that I disable
'Reset on Connect', and this seems to do the trick. I can now control my PrintrBot Simple Metal from the manual control panel using V1.0.1 - yay!!

Re: Can't connect after upgrade to V1.01 on Linux Ubuntu 14.04LTS
August 18, 2014 10:07PM
Never mind the connect. After upgrading to Linux Mint 17 KDE (Kubuntu 14.04 based) stl files that used to load under mint 13 / V0.95F failed to load (red X in right hand column on placement window). Other STLs that did load were scaled so huge they don't fit on the bed of the printer. And yes, I did check my printer configuration, it looked the same as it did under V0.95F. Of course the blame might not be on Repetier Host, but rather slic3r, which seems to barf under Perl V5.18 which is what now ships with the latest Linux.

In any case, Slic3r and Repetier host 1.01 are useless on the latest Linux, so for the time being I'm back on the old software for now. (Thankfully I installed everything on new disks and did not wipe the old ones! ) I will figure out how to have BOTH systems sitting side by side on the same computer with a grub time boot option so I can try to figure this problem out before upgrading the system.

BTW, the connection issue is due to the baud rate. There is a patch out there for mono to allow Linux to use 250,000 baud and I have installed that on my old system. Need to find it again for the new mono. Can't believe that they haven't fixed this yet! Ditto for python and pronterface BTW.

Edited 1 time(s). Last edit at 08/18/2014 10:08PM by kscharf.
Re: Can't connect after upgrade to V1.01 on Linux Ubuntu 14.04LTS
August 19, 2014 03:53AM
Can you provide such a stl that does not load any more. There should be no reason to fail with files previously working except that 1.0 uses a higher coordinate resolution internally (double instead of float). But if it is so, I'd like to fix that. Scaling on stl load is done according to set scaling factor in config. AT least if it the stl preview. Gcode preview is of course dependent on used slicer.

1.0 for linux has now a little trick to use non ansi baud rates. For me it only worked for ftdi based serial connection (ttyUSB0). Strangely the baud base for AVR based serial connections like on Arduino Mega seem to return a baud base that does not allow non ansi baud rates. The source for the baud changing script is included in source so if anyone knows why avr based boards don't return useful baud base values, let me know.

Repetier-Software - the home of Repetier-Host (Windows, Linux and Mac OS X) and Repetier-Firmware.
Repetier-Server - the solution to control your printer from everywhere.
Visit us on Facebook and Twitter!
Re: Can't connect after upgrade to V1.01 on Linux Ubuntu 14.04LTS
September 01, 2014 02:24PM
After a bit of head scratching I tried this again. I was updating my computer from Linux Mint 13 to Linux Mint 17. During this process I backed up my home directory and then installed the new OS on top of the old one (actually I used a new disk drive so I still had the old OS to fall back on), and I cloned the disk containing my old /home directory so that all my files were automatically exported into the new install. This left my old version of Repetier Host still on the machine when I upgraded to the new version. It didn't work.

So, I actually re-installed the OS all over again, but I first wiped out the old copies of Repetier Host, Pronterface, and Slic3r from my user space where they had been installed. After again installing Linux Mint 17 fresh, I then installed those same three programs again. (I saved my Slic3r config files from the previous install of Repetier Host). Success!

Bottom line, upgrading on Linux to the new RH requires upgrading Mono, which also means upgrading to a new version of the OS (unless back ported packages are available). But you also need to hid your old versions of the program and config files, or strange things may happen!

I'm going to have to get used to the new look and feel of Repetier Host. I've briefly tried running it side by side with Pronterface, there is no comparison which is better. I do have a few bones to pick though.
1: The platter view defaults to fitting the parts onto the platter, I prefer the old way of fitting the view to the printer, I like to see the entire build platform, not just the part containing the items. Sure, I can switch back and forth, but I'd like the printer centric view to be the default.

2: I had to integrate Slic3r into the program as it no longer comes pre-installed (maybe I'll try Cura eventually, but I'm familiar with setting up Slic3r and that's one less learning curve in getting my printer working!) After configuring RH to the locations of Slic3r's binary image and config files pressing the config button lands me in the 'home view' of slic3r, not the config page as it used to. Again, I know how to get there, it's just different now.

Finally, while I'm currently running Repetier Firmware on the printer I may give Marlin a try. I'm still feeling a bit uneasy about getting those custom thermistor tables into the firmware because of the size of the table constants not being reflected in the sketch size. (Not being able to force Arduino IDE to generate map files sucks). I assume that RH works just fine with Marlin (I think printerbot recommends that combination for their printerbot simple product).
Sorry, only registered users may post in this forum.

Click here to login