Welcome! Log In Create A New Profile


Repetier hangs at extruder heatup.

Posted by Gyvven 
Repetier hangs at extruder heatup.
March 10, 2015 12:08AM
I finished my new printer a month or so ago and have been happily printing away (number 3 in as many years). Then one day, for no apparent reason, after my HBP was heated and my extruder started heating everything froze solid. I couldn't kill it, I couldn't close the host program, I had to shut the printer power supply off in case of run away heating, and reboot the pc in order to stop it. A couple of times it would just pile up the commands but it still wouldn't let me kill it or close the program, or disconnect. Task Manager can't even end the task.

I was running 0.95F on Win 7 64-bit, so I upgraded to 1.0.6 and it does the same thing. I've uninstalled and re-installed the host, but I still can't get it to heat the extruder for more than a few seconds before it freezes. I can use dry run mode, move everything around, and heat the bed just fine but it locks up as soon as I try to heat the extruder. I'm only trying to heat it up to 200 for PLA but it only gets to about 60 before the freeze.

I've re-installed my firmware too, but I haven't gone through to double check the eeprom settings, yet.

Any ideas?
Re: Repetier hangs at extruder heatup.
March 10, 2015 04:46AM
Sounds pretty much liek a printer hardware problem. Have you tried using extruder without heated bed? Maybe the combination is just to much and some parts come near brown-out level. Especially communication chips seem to crash fast often with firmware still running happyly but not beeing able to communicate. If you have a lcd display you could check that as well.

Repetier-Software - the home of Repetier-Host (Windows, Linux and Mac OS X) and Repetier-Firmware.
Repetier-Server - the solution to control your printer from everywhere.
Visit us on Facebook and Twitter!
Re: Repetier hangs at extruder heatup.
March 10, 2015 10:36PM
It just seems odd that it would be working fine one day and the next not.

I know there was a windows update that occurred that day, so I tried going back to an old restore point, didn't help. I've also swapped out arduino boards. I don't have an LCD display hooked up at the moment, but I may have to try that.

I tried heating the extruder from a fresh startup and that worked fine. I heated the bed, and that worked. I hit start print and it homed and then locked up.

I'm going to try my old laptop and see if there might be an issue.
Re: Repetier hangs at extruder heatup.
March 10, 2015 10:51PM
So, on a whim I had exported my eeprom settings after I calibrated last time, I imported them and it seems to be working fine now. I don't know what the issue might have been, but it's fixed now. I'm going to open the config file and compare what I had uploaded with what seems to be working. I'm going to guess it's something to do with how I had the temp control set up, but that's just a guess. I'll report back later when I have a better idea of what may have happened.
Sorry, only registered users may post in this forum.

Click here to login