Welcome! Log In Create A New Profile


Can't get my Azteeg X5 mini board to move any of my steppers in Repetier Host

Posted by lornetw 
Can't get my Azteeg X5 mini board to move any of my steppers in Repetier Host
August 05, 2015 07:56PM
I am a teacher who teaches CNC programming and machining in a trade school in Montreal. I decided to make my own version of the Bukito, with a e3D-V6 extruder in a Bowden configuration and an Azteeg X5 mini for the controller. Mechanically speaking, it is finished. I am trying to get it to work with Repetier Host. I apologize if this post is long – my current problem is to be found in the section ‘Second problem’.

First problem (and the solution) : I had troubles after installing the Windows drivers (I have Windows 7 Home Premium – 64 bit, which is part of the problem).

After installation of the drivers, Windows said that the driver was correctly installed, but, upon plugging in the USB cable, Windows displayed an error message saying the driver was not properly installed. When I went to the Windows Device page it showed a yellow exclamation beside the Smoothie Serial driver and showed the following under Device Status : "This device is not configured correctly (code 1). A service installation section in this INF is invalid". However, when I went into Windows Explorer, I could see the SDcard listed as a drive and can see 3
files listed : Config.text, drive.id and FIRMWARE.CUR – at least this meant my computer was communicating with the X5 as a drive by the USB cable.

So I decided to re-install the Windows drivers, but I noticed when I went to re-download the firmware.bin file, the Github site showed a size of 334.64 kB, however, the size as downloaded was only 327 kB. Then I noticed that there was a md5sum file (I don't think I checked the firmware.bin with the checksum utility before) so I downloaded both the firmware.bin file and the firmware.bin.md5sum files. I then ran the winMd5Sum utility and it reported that there was a mismatch. On the Github of the Smoothie Board site I reported a bug - I don't know if they will get back to me.

Solution : I went onto the Smoothie board forum and looked through all the messages concerning Windows 7 – 64 bit and found the following link :


where they said : "Turns out the 1.1 driver inf file has a missing line in the vista 64 section as follows: "usbser.sys,,,0x20" : If you add this to the smoothiware.inf file the driver should install fine.". I added the line to the .INF file and manually re-installed the driver. It worked - now when I plug in the USB no error message comes up and when I started up Repetier-Host and pressed "Connect" it connected (on my computer it is COM12) - the icon turned green. So far so good (however, this solution, which permitted me to connect to the controller, does not address the problem of the checksum not being correct).

Second problem : Then I wanted to move the steppers manually to check which direction they are moving so I can arrange the approach direction for my Home movements, etc. However, when I went to the Manual Control tab in Repetier-Host and clicked on any of the manual arrows (X, Y or Z) a message appears at the top of the screen (a counter) "Command Waiting" but nothing moves. Is there something I have to do to get the steppers to move? Repetier-Host seems to be waiting. Is Repetier-Host expecting me to do a Home before allowing manual control of the steppers? My power supply is plugged in and all the wires to my steppers are connected.

I have done extensive searching in the Repetier Host Forum and I have tried the following (with the screen showing, for example ’10 Command Waiting’) with no results (i.e. I cannot manually move my steppers in either X, Y, Z or the extruder):

1) I tried each and every one of the different Baud rates (even though the Panucatt.com website says the X5 mini Smoothie board should work with any Baud rate) – no difference

2) I tried all the different combinations of ‘Reset on Connect’ (Disabled, etc) – no difference

3) In the ‘Manual Control’ tab : I turned on everything at the bottom (Echo, Info, Errors, etc) so as maybe get some feedback on what the machine was doing and clicked on OK – no movement of the steppers and the counter of the ‘Command Waiting’ did not change. Of course, now that I think about it, the log will not display any activity because no communication is working.

Can any one give me a way to fix this? Any help at all would be appreciated.

Lorne Wilkins
open | download - lorne wilkins-3.jpg (603.5 KB)
Sorry, only registered users may post in this forum.

Click here to login