Welcome! Log In Create A New Profile


'SD init fail' on Repetier 0.92.9

Posted by Mils24 
'SD init fail' on Repetier 0.92.9
June 25, 2017 11:34AM
Hello guys,

I have been wrecking my brain all weekend over this and cannot get my printer to work. I have just recently updated my firmware from a very old version (not sure of the number but it was complied in 2014) to the latest 0.92.9. My main reason for doing that was that I needed to configure a new thermistor type for my E3D V6 clone as my old firmware did not have the NTC 3950 100K option.

To populate the 0.92.9 version I used the online configuration tool and dropped in my old firmware configuration.h file. I only changed my thermistor and downloaded.

I have flashed my board and re calibrated. I was just about to hit print when I have now run into the 'SD init failed' error and my SD is displaying blank on the LCD controller.

Board is a Arduio Due with RADDS shield. Also using the RADDS LCD controller 40x20. SD Card is the same SD Card I have been using for years on that machine - 8GB SDHC, Formatted to FAT32. Also there are no other SD cards or Micro SD card plugged in to any of the other ports.

I have also tried re formatting the card tonight too but that did not make a difference.

I have googled this issue a lot tonight and there seems to be quite a few people with the same problem but I am yet to see a solution.

Please help!!
Re: 'SD init fail' on Repetier 0.92.9
June 28, 2017 04:52PM
- Solved -

There was a conflict between the pins.h values for SDSS and the ui.h values for SDSS.

Once both were aligned, compiled and flashed all worked fine.
Sorry, only registered users may post in this forum.

Click here to login