Welcome! Log In Create A New Profile


x axis ramdomly decides up is down

Posted by jonawald 
x axis ramdomly decides up is down
October 03, 2017 08:16PM
I am working with a homebuilt delta printer. Using ramps 1.4 on arduino mega for controls.

Here's the problem. Sometimes the x axis decides that to move the carriage up it needs to go down. I am using Repetier as a host program. I go to the manual panel and hit up. Y & Z do the normal thing X goes down pushing the effecter way off to the side in a hurry.

The crazy thing is, when I command the effector to go down, everything is normal. It goes down as needed. Sometimes with a complete power down of printer and a reset of the arduino I can correct this but it is not always successful.

Can anybody help out with this. Am getting very frustrated here. The problem began a few days ago. I thought something was just messed up with my firmware. I went back to Repetier and made a complete new firmware using the latest development edition. I flashed epprom and everything to fix the problem. It looked good for about a day then it started bugging out again. I have even tried reversing the plug on the ramps. This worked the first time I hit home. The axis went up as it should. Then it decided to be drunk again right away and function opposite of what it should.

Re: x axis ramdomly decides up is down
October 03, 2017 08:23PM
This is a printer that has been printing for a while already. Not a completely new setup. Although I just put on a new effector and changed the endstops and endstop wiring. I cleaned up a lot of stuff just before this happened. All the changes I made are far away from any stepper motors so it can't be crosstalk. The printer has a 450mmX450mm print area and the endstops and new wiring are at the top. The ramps is on a post halfway up.
Re: x axis ramdomly decides up is down
October 03, 2017 11:22PM
Just to add detail. The x axis does sometimes work. In fact, the last thing I did before I ran into the current balkiness was a G32. This worked perfectly though it took a long time because I had set the motions too slow. I left the printer for over an hour while it did the bed leveling routine. When I came back the effector was waiting aobut 30 mm above the last probe spot. Everything looked good so I hit home. X came screaming down. Y and Z raced up. Carriage runs off to the right till magnets pop out of the sockets and I have the effector on the table beside the printer and rods bouncing everywhere.

I tried resetting everything by unplugging 12v and USB from arduino/Ramps and pushing the reset button. I tried just hitting reset with everything powered up. I restarted repetier, I even rebooted my computer. Earlier today I was able to get it going again by unplugging ramps USB and 12V. Now it's more stubborn.

I might be lead to believe it has something to do with the bed leveling probe I added, but this problem showed up before I even set up the code for bed leveling.
Re: x axis ramdomly decides up is down
October 04, 2017 04:00AM
Probably a partially-blown driver. Try replacing the X driver. Another possibility is a bad crimp connection in the X motor cable.

Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: x axis ramdomly decides up is down
October 04, 2017 10:22AM
As DC said, it could be the driver, It sounds like an intermittent fault on the X DIR signal, this could also be faulty port on the mega.
You could try mapping the X driver to use the E2 pins as a test.
Re: x axis ramdomly decides up is down
October 04, 2017 11:22AM
Wasn't the driver I swapped with E2. I'll try the swapping the pins.

Yap. That was the problem. When I mapped X to e2 everything was OK again. I guess I can use it like this till I get a new board. Anybody want an Arduino/Ramps pair? CHEAP

Edited 1 time(s). Last edit at 10/04/2017 11:31AM by jonawald.
Re: x axis ramdomly decides up is down
October 04, 2017 11:44AM
Now it's gone really haywire. It somehow coupled the temp pins for the bed and the extruder. I switch on the extruder only and bed temperature climbs up with extruder temperature until everything is killed because "bed" exceeded temperature. I checked pins in configuration.h everything is as it should be.
Sorry, only registered users may post in this forum.

Click here to login