Welcome! Log In Create A New Profile

Advanced

M109 (set temp and wait) in G-Code but not in config

Posted by jon_bondy 
M109 (set temp and wait) in G-Code but not in config
February 02, 2019 05:15PM
I've been using Repetier Host and Slic3r for perhaps 5 years. For one set of configurations, the printer waits at the start of a print for the extruder temperature to be reached. This is no big deal except that I cannot find the M109 anywhere in the Slic3r configuration settings. It is not in Printer Settings, Custom G-Code, nor in Filament Settings, Custom G-Code. Is there somewhere else that I should be looking? I am using Repetier Host 2.1.3. Note that Slic3r PE was installed on this computer, also, and I have regretted mixing Slic3r PE and the Repetier Host Slic3r for quite a while. Perhaps the two Slic3rs are fighting each other.
Re: M109 (set temp and wait) in G-Code but not in config
February 03, 2019 02:39AM
Take a look at slicer printer settings|Custom G-Code
Start G-code
M104 S[first_layer_temperature] ; set extruder temp
M140 S[first_layer_bed_temperature] ; set bed temp
M190 S[first_layer_bed_temperature] ; wait for bed temp
M109 S[first_layer_temperature] ; wait for extruder temp

Slic3r and Slic3rPE should not interfere with each other... they store their configuration files is separate directories.

Edited 2 time(s). Last edit at 02/03/2019 02:53AM by Dust.
Re: M109 (set temp and wait) in G-Code but not in config
February 03, 2019 09:29AM
As I stated originally, there is no hint of what I find in the G-Code. Please see attached screen shots.
Attachments:
open | download - 20190203_091751a.jpg (304.3 KB)
open | download - 20190203_091803a.jpg (963.6 KB)
open | download - 20190203_091820a.jpg (945.4 KB)
Re: M109 (set temp and wait) in G-Code but not in config
February 04, 2019 08:33AM
If the slic3r 'start' gcode (1st image above)does not contain any entries for M104,M140,M109,M190 then slic3r (or cura) will add them to the start of your slice'd g-code automatically.
Re: M109 (set temp and wait) in G-Code but not in config
February 04, 2019 08:37AM
Quote
obewan
If the slic3r 'start' gcode (1st image above)does not contain any entries for M104,M140,M109,M190 then slic3r (or cura) will add them to the start of your slice'd g-code automatically.

This is very helpful information, although this "feature" is a bit annoying.

Thank you
Sorry, only registered users may post in this forum.

Click here to login