Plating with ProInterface
September 06, 2012 08:17PM
Ok, so I'm pretty much ready to print, I think I've got all my other problems worked out(with a few stupid questions to brad smiling smiley ) has anyone else had trouble getting the plater to put things in the centre of the build area? No matter where I place it in the plater, or just load the file and let it auto place, it ends up centred on 100,100. I changed the centre point in slic3r to 50,50, with no result. What little, important thing have I overlooked?

Jeff
Re: Plating with ProInterface
September 06, 2012 09:06PM
Have you loaded the Tantillus Slic3r configuration files?

[github.com]

I've been using the default 0.5mm and getting great results.

Hope it helps!
Re: Plating with ProInterface
September 06, 2012 09:27PM
I have no idea about using plater. If I want plates I make them first and then slice them with Slic3r. I don't actually use Pronterface for anything except sending gcode to my Prusa that does not have an SD or LCD. If I had to guess though I would say it is because it uses the sizes in Pronterfaces settings to make the plate.

Have you finished the calibration tutorials? Did the cube and pyramid turn out well?


FFF Settings Calculator Gcode post processors Geometric Object Deposition Tool Blog
Tantillus.org Mini Printable Lathe How NOT to install a Pololu driver
Re: Plating with ProInterface
September 07, 2012 12:01PM
You don't need to run slic3r from inside pronterface. You can load pre-sliced gcode directly into pronterface, this is my workflow and it's given me no issues.
Re: Plating with ProInterface
September 07, 2012 12:26PM
I can't actually print the cube test file, as it gets centred on the far corner(100,100) of the build area, so 3/4 of it is off the table. I have had the same problem running slicer independantly, then loading the gcode, not sure why. and yes, I have loaded the slic3r tantilus config files.

Jeff

Edit: Apparently slic3r no longer likes the config files, so this is probably it, it complains about a number of "unknown options" int he config file, including bed size, so that's probably it. It doesn't like:
Bed size at line 2
Duplicate at line 10
duplicate_grid at line 12
layer_gcode at line 33

Interesting.
Re: Plating with ProInterface
September 07, 2012 12:51PM
Probably because you're using a config file generated from a different version of slic3r than the version you are trying to use to process the STL.
Re: Plating with ProInterface
September 07, 2012 12:54PM
neptix Wrote:
-------------------------------------------------------
> Edit: Apparently slic3r no longer likes the config
> files, so this is probably it,

Sounds like you're running the wrong Slic3r version. You should be using 0.7.2b. Later versions changed the configuration files and aren't backwards compatible.


----------------
Lem Fugitt
3D Printing Dreams
Robots Dreams
"The map is not the territory."
Re: Plating with ProInterface
September 07, 2012 01:09PM
I was getting the same 'unknkown options' when loading slic3r via pronterface (maybe even just when pronterface was open).

I've started to not use pronterface and print from the SD. All works swimmingly now.
Re: Plating with ProInterface
September 08, 2012 12:47PM
Ok, so I had slic3r .71 for some reason. going to 0.72b fixed the problem, for about 10 minutes, now it's back. I cannot find a way to make it centre the prints anywhere other than 100,100. The graphic in prointerface indicates the print is in the centre of the bed, but when I print, it goes off the corner again. Any ideas?

Oh, other neat thing, when I access the card menu with the encoder, the print head moves in a random direction for a bit.

Edited 1 time(s). Last edit at 09/08/2012 12:56PM by neptix.
Re: Plating with ProInterface
September 08, 2012 09:13PM
Ok have you gone into pronterfaces settings and told it you are using a 100 x 100 bed?

You will need to load the Tantillus config every time you open slic3r. It does not remember the path to the config file and the default config is set at center being 100x100

And yes if you had been printing and the head is not at home because you aborted the print it will return to X0 Y0 as soon as you enter the SD menu.


FFF Settings Calculator Gcode post processors Geometric Object Deposition Tool Blog
Tantillus.org Mini Printable Lathe How NOT to install a Pololu driver
Re: Plating with ProInterface
September 09, 2012 12:49AM
I made the mistake of forgetting to load the tantillus config for a couple of my .stl to gcode files and they did similar stuff. Ended up in the wrong place on the platform.

Also they nozzle ended up moving back and forth and deposting big blobs and stuff.

I'm printing a cat right now... because I can smiling smiley ...but the first attempt didn't go to well until I remembered the config *facepalm*
Re: Plating with ProInterface
September 09, 2012 04:32PM
Well, i fixed the random motino thing by reflashing the firmware, and i think I've got slic3r plating properly now. Now i just need to get the filament to stick to the bed and I should be good....
Re: Plating with ProInterface
September 09, 2012 08:03PM
Glad to hear it. A few people have found that increasing the temperature for the first layer to 205 really helps.


FFF Settings Calculator Gcode post processors Geometric Object Deposition Tool Blog
Tantillus.org Mini Printable Lathe How NOT to install a Pololu driver
Sorry, only registered users may post in this forum.

Click here to login