Welcome! Log In Create A New Profile


Printer not responding after changing temps.

Posted by Gronkwena 
Printer not responding after changing temps.
April 19, 2013 05:36AM
Hi there,

My printer was assembled at the weekend and I have been printing all week without any issues. However, when I tried to initiate a print run last night, the printer stopped responding as it was heating up. I tried again, and again it stopped responding (this time during the 60 sec print countdown). Since then it seems to stop responding as soon as I try and change the temps on either the hot end or the bed.

I have tested the other components independently, and all seem to respond correctly - motors, fan, thermistors. Also the heaters do start heating correctly and the temperatures rise as normal on both hot end and bed, it is simply that once they have been set, the interface software simply gives the error
Can't write to printer (disconnected?).
Can't read from printer (disconnected?).
and I can't get anything out of the printer until it has been turned off and then back on.

I have tried the obvious fiddles such as changing usb port, updating firmware etc., and can see no loose wiring or anything that might have changed since the last successful print. Thought I would ask here to see if anyone can suggest what to try next.
Re: Printer not responding after changing temps.
April 19, 2013 06:21AM
Ok Fixed it.

The ground connection to the Melzi must have worked it's way loose during a previous print, and this must have caused a disruption in the USB connection when I turned on the heaters. Seems to work fine now, possibly need to resolder the ground wires so they fit into the connector better.
Re: Printer not responding after changing temps.
April 19, 2013 09:12AM
Yes you are about the fourth person to encounter this problem. I need to put something in manual. The symptoms are always the same, loss of USB connection when you start drawing current.

To make the soldered bundle fit better you can squeeze it with pliers in one direction and then shave bits off with cutters in the other direction to make a nice square cross section that fits.

It might be better to combine the wires and solder them to a short thick section of wire that fits the terminal. I am reluctant to add yet another vitamin though.

Re: Printer not responding after changing temps.
April 19, 2013 12:56PM
I've done as you've suggested and attacked the ground wire with pliers and it seems to fit a lot better now. I'll keep an eye on it, and if I think it is loosening again I can try your second suggestion and add another wire as an extension.

There is already a passing mention of this issue in the manual, where you explain why all 12 wires are needed for the ground. I saw some posts on the forums here discussing similar communication problems, which triggered my memory of that paragraph and helped me find the source of the problem straight away.
Re: Printer not responding after changing temps.
April 20, 2013 06:36AM
I used the same trick on the ground wires as on the headbed ribbon cable, twist bundles of three wires together and then twist those bundles together. That way i ended up with a nice small package wich fitted the screw terminal.
Re: Printer not responding after changing temps.
April 24, 2013 04:34PM
I combined all 12 wires then had some further better fitting gauge wire to that and then into the Connector. I have had no issue whatsoever with this method.

Soldering the small length of thick gauge to the 12 wires is the best solution in my opinion.

Time to play every day... Why be bored and old smiling smiley
Re: Printer not responding after changing temps.
May 02, 2013 04:52AM
My £0.02 in the hope that this helps ....

Although I print from SD card most of the time, I use a laptop to switch the fan on/off, adjust speeds (M220 Sxxx) and to monitor progress as and when needed. However, after six trouble free months of running, the "Cannot read/write... " errors started.

The ground connection on the MELZI - tight as it was when first commissioned but decided to rework the ground wire bundle anyway and things seemed to improve .... for a while. Now... I'd be the first to admit that I do not fully understanding these things but I gather that ground loop problems are common when using USB. (Two mains powered devices, both earthed - I think - and the earth wires effectively coupled together via a USB cable). What I tried next was to remove the power cable to my laptop so that it was running on battery only ..... and the problem disappeared. Plugged the power plug back into the laptop and immediately lost connection - RESULT!

Where to go from here? First will be to get the dodgy power connector fixed on the laptop - for some time, it has been more than a bit loose although fine and dandy when it comes to "normal" work. (It is a SONY VAIO which I believe is prone to this sort of thing). If that does not fix things, I guess I will take the route of purchasing a USB isolator - not cheap but they are designed to remove ground loop problems like these.


Edited 2 time(s). Last edit at 05/02/2013 05:29AM by Alzibiff.
Sorry, only registered users may post in this forum.

Click here to login