Welcome! Log In Create A New Profile


Setting up Mendel90 on OSX - step by step

Posted by QuackingPlums 
Setting up Mendel90 on OSX - step by step
May 15, 2013 07:31AM
Setting up in Windows is clearly described in Nophead's manual but OS X is just as simple, albeit not explained in any detail so I thought it might be useful to consolidate the information I found and/or worked out for myself.

Installing stuff
First you need to install the FTDI Virtual COM Port drivers for Mac OS X, as the following apps all use this to connect to the printer - I got mine from http://www.ftdichip.com/Drivers/VCP.htm

Next, as per the Windows instructions, grab the latest version of Pronterface for Mac (the Github project page always points to a location for pre-built binaries): https://github.com/kliment/Printrun

You will also need the Arduino IDE for Mac OS X to make the necessary changes to the firmware during calibration and to upload to the Melzi: http://arduino.cc/en/main/software

Pronterface works more or less exactly as it appears in the manual. If the FTDI drivers are installed correctly then you should see "/dev/tty.usbserial-XXXXXXXX" and "/dev/cu.usbserial-XXXXXXXX" in the list of available ports:

Select one (both worked for me though there's a lengthy discussion on which is better) and set the baud rate to 250000:

Next click "Connect" and after a short wait the printer should respond with the same output as stated in the manual:

You should now be able to setup and calibrate the printer exactly the same way as described for a Windows machine. When you get to the point where you need to make a change to configuration.h and update the Melzi firmware, make sure you have copied the Melzi hardware configuration from the SD card to the appropriate location in your Arduino hardware folder (you can create this at "/Users/[myUsername]/Documents/Arduino/hardware/" if it doesn't exist).

Whilst this is useful for anybody wanting to setup a Mendel90 but who only has a Mac, I actually find it useful to be able to print from both Windows and Mac OS computers. Setting up Repetier-Host is just as simple for Mac OS X; just make sure you setup the printer parameters before attempting to print or you might find the printer trying to overextend beyond its physical limits. To do this, go to the "Printer Settings" dialog where we are mainly interested in the "Connection" and "Dimension" tabs.
Select the port and baud rate as before:

Define the print area as follows:

NB - the Home Z position is at "z max"!:

I've got mine setup to share Slic3r configuration across all of my laptops/desktops (Windows and Mac) so I can print from any computer knowing that my configuration changes automatically replicate across every location. I do this using a combination of rsync and Dropbox, but it could easily be version-controlled via git or similar.

I hope this is useful for somebody! drinking smiley
open | download - Screen shot 2013-04-29 at 17.17.00.png (140.7 KB)
open | download - Screen shot 2013-04-29 at 17.16.34.png (23.6 KB)
open | download - Screen shot 2013-04-29 at 17.22.28.png (180.4 KB)
open | download - Screen shot 2013-04-29 at 17.23.20.png (84.6 KB)
open | download - Screen shot 2013-04-29 at 17.23.39.png (70.6 KB)
open | download - Screen shot 2013-05-15 at 11.48.23.png (9.5 KB)
Re: Setting up Mendel90 on OSX - step by step
July 29, 2013 01:51AM
I just finished building my mendel90 Dibond from kit (bought from nophead, everything was perfect!).
I tested with pronterface and It does work.
I am more familiar with repetier host, and so I followed your guide but the software does not connect on OSS and hangs. I tried v 0.56 and 0.53 but no luck.
Here's some fact:
  • MacBook Pro retina 15 with mountain lion latest version
  • Pronterface works
  • Repetier on windows on virtual box works
  • Arduino finds the board and I can upload firmware
  • When I try to connect repetier it hangs with 5 commands waiting to be sent
Any suggestion?
Re: Setting up Mendel90 on OSX - step by step
July 29, 2013 04:32AM
I was using a MBP 15" non-retina on Snow Leopard when I posted this and it worked fine for me. I'm guessing you already double-checked the printer connection settings in Repetier Host to make sure you have the right USB serial port and connection parameters selected as per the screenshot above?

I need to keep this one on Snow Leopard but I have another MBP coming soon which will have Mountain Lion so I'll check if there are any incompatibilities then. If it works fine in Virtual Box then I can't see why it won't work on the native OS.

I know that the "lengthy discussion" I refer to above isn't actually that lengthy, and is just talking about which serial port ("tty" vs. "cu") should be used for inbound/outbound connections. As we're not talking about a modem with inbound/outbound connections it shouldn't matter which we use but the "cu" connection is considered more friendly. From what I remember though, this isn't selectable in Repetier, only Pronterface, but I wonder if you have another connection open that is blocking Repetier from opening its line through to the Melzi...
Re: Setting up Mendel90 on OSX - step by step
July 29, 2013 08:22AM
Correct. Pronterface works and shows both the tty and the cu. repetier shows only 1 (I don't remember which one). Also, the arduino IDE works so it is not a hardware/driver related issue. It seems like it's some sort of software dependent issue, as I said, pronterface works great under osx. Also, repetier is working from a virtualbox VM, so I would say it's a osx version problem.
Re: Setting up Mendel90 on OSX - step by step
July 30, 2013 09:04AM
Actually, I checked yesterday evening and the v0.53 did connect and work. so i guess it still is a software problem but is limited to v0.56...
Re: Setting up Mendel90 on OSX - step by step
October 24, 2013 03:22PM
Thanks for this Guide ... very handy for me...

Best regards
Re: Setting up Mendel90 on OSX - step by step
May 25, 2015 02:26AM
Hi Im a little late on this form but i am trying to set up my mendel90 with my mac book and i keep getting this error in pronterface

Re: Setting up Mendel90 on OSX - step by step
May 25, 2015 02:27AM
not sure if the picture is clickable but it keeps saying

[ERROR] Could not connect to /dev/cu.usbserial-A5027KMJ at baudrate 250000:
IO error: [Errno 22] Invalid argument"

when i try and connect the printer after downloading the driver and pronterface
Re: Setting up Mendel90 on OSX - step by step
May 25, 2015 07:15AM
I don't know anything about OSX, but perhaps it doesn't support 250000 baud. Try 115200 and see if the error goes. In which case you will need to change the firmware to 115200, or find a patch for OSX.

Re: Setting up Mendel90 on OSX - step by step
May 25, 2015 02:42PM
alright thanks, i was playing around with the baud rate in pronterface but i didnt change it om the firmware, so that could be my issue. could you enlighten me on as how to go about changing the baud rate on the firmware?
Re: Setting up Mendel90 on OSX - step by step
May 25, 2015 06:06PM
Change this line: [github.com] and re-load the firmware using the Arduino IDE.

Re: Setting up Mendel90 on OSX - step by step
May 26, 2015 09:15AM
OSX has no problem with 250,000 baud for me - in fact you can see it connected in my screenshots above. That line in Marlin is set to 250,000 as per default on my firmware.

That Python error is usually thrown when a port isn't available or something has it locked. Have you got anything else running that could have snaffled the serial port?
Re: Setting up Mendel90 on OSX - step by step
June 11, 2015 08:50PM
sorry really late response but I've gotten the printer to print the test file accompanied with the mendel 90 however whenever i try and print anything using slicer and pronterface everything is off set and the print is halfway out of bounds. I've tried setting the center and have had no luck so far. any suggestions?
Re: Setting up Mendel90 on OSX - step by step
June 12, 2015 03:04AM
here are my settings for original nophead mendel 90 slic3r ...

hope it helps
open | download - Bildschirmfoto 2015-06-12 um 08.36.16.png (25.5 KB)
open | download - Bildschirmfoto 2015-06-12 um 08.36.53.png (70.5 KB)
Re: Setting up Mendel90 on OSX - step by step
June 12, 2015 07:45PM
Smuk3d is correct - I use Repetier Host to manage my Slic3r profiles, which passes in the parameters from its Dimensions tab when it launches Slic3r so I've never had to touch Slic3r's own "Printer Settings" tab.

If you copy Smuk3d's settings then Slic3r will have its own copy of your Mendel90 dimensions too (and the all-important "print center" location) so that it can slice correctly even when used independently of Repetier.
Re: Setting up Mendel90 on OSX - step by step
January 11, 2016 04:08PM
I am really struggling to get arduino to flash my melzi board on my macbook pro(elcappitan). I managed to get the Melzi W/ ATmega1284p 16mhz option to show up in boards by coping the contents of ../SD_CARD/MENDEL90/Windows/arduino-1.0.1/hardware/Melzi to /Users/kouvas/Documents/Arduino/hardware/Melzi/avr. The problem is when I load the firmware on arduino IDE and press verify I get this error.
After reading this page, regarding arduino's 3rd party software support for new boards I found out that 3 configuration files are needed for each architecture in order to work, "boards.txt, platform.txt and programmers.txt". While the "boards.txt" exists in /SD_CARD/MENDEL90/Windows/arduino-1.0.1/hardware/Melzi the other 2 are missing. My serial port is showing up fine and I am able to connect and work with printrun with no issues. If anyone has managed to get arduino to flash his melzi board on elcappitan I would really appreciate it if he could share with us how he did.
Re: Setting up Mendel90 on OSX - step by step
January 11, 2016 10:48PM
Don't use the newest version of Arduino. As you noted, it doesn't work with the old board configuration files that exist for the Melzi. Use 1.0.6 which is available for all OS platforms at this link:


Don't forget to copy the Melzi files to the new install for it to work.
Sorry, only registered users may post in this forum.

Click here to login