Welcome! Log In Create A New Profile


Weird bug with Pronterface

Posted by Nilez 
Weird bug with Pronterface
October 24, 2013 07:58AM
Hi all,

I'm having trouble with a very annoying thing with the custom buttons with Pronterface. I have to calibrate the printer again after having trouble with spinning nuts for the fan on the x-carriage. The way I prefer to level the bed this far is to install a dial gauge with the printed bracket and then use the BL/FL/BR/FR buttons in Pronterface to move to the four corners of the bed. But the thing is that after a couple of runs across the bed using these buttons result in those buttons disappearing from the screenconfused smiley. So then I have to restart pronterface, reconnect with the printer home the axes before the origin button works and the corner buttons work. So this is so annoying and time consuming. Otherwise I could have my bed level in a minute or two. Is there a way to fix this?
Re: Weird bug with Pronterface
October 24, 2013 11:54AM
The BL and BR turn the motors off to enable the Z motors to be turned by hand so it would be a pain without them. However, you should only need to level the bed once.

I don't understand why they would disappear, they work fine for me on XP and Win7, which OS do you use?

I have known the other buttons on Pronterface to become invisible sometimes but they reappear if you press where they should be. I think it only happens when the window is hidden by another and revealed again.

Re: Weird bug with Pronterface
October 24, 2013 01:27PM
Thanks Nop. I run it on Win7 ultimate 32 bit. I have one of those (cheap) dial gauges that warp the bed the further it get from the corners to the middle so I use the buttons to travel to exactly the same spot in each corner to tweak the bed. Is this an acceptable method btw? So I use the buttons quite a few times until the gauge tells me that every corner is the same. But most of the time the button menu "crashes" after the buttons have been pushed ten times or so. Can't get them to come back when they do. Like you said, you only have to level the bed once but I've had to move the printer a couple of times during the final building stage and calibration process lately so that's why I encountered this error every time.
Re: Weird bug with Pronterface
October 24, 2013 02:30PM
I tried pressing the buttons repeatedly and I can't make it crash. My Win7 is 64 bit but I also run it on XP32 without any problems.

If you happen to move the mouse during the click on the button it does try to drag it though. I wonder if that is when yours crashes?

It is Pronterface from about a year ago so you could brave the latest version. I am not sure if the config file will be compatible though. I haven't updated because I only use it for jogging and starting prints from SD and occasionally running them over the USB. Since all those things work fine for me I have never looked at a more recent version.

Re: Weird bug with Pronterface
October 24, 2013 03:12PM
Although I am running Linux, I am using the latest versions of all tools without any problems observed with configuration files.

For reference they are:
skeinforge-12.03.14 (the package maintainer has added the Comb fix and enhanced Cool plugin for me)

I have been levelling my bed today using a ToolZone MS083 Dial Gauge and the method you described without the loss of positioning buttons. I got the corners to within 0.01mm - is that a new record? smiling smiley

Neil Darlow

I try to write with consideration for all nationalities. Please let me know if something is unclear.
Printing with Mendel90 from fedora 25 using Cura, FreeCAD, MeshLab, OpenSCAD, Skeinforge and Slic3r tools.
Re: Weird bug with Pronterface
October 24, 2013 05:58PM
Oops I'm using the config file with the latest version, maybe that causes the problem. I'm goig to try the older version
Re: Weird bug with Pronterface
October 24, 2013 06:55PM
Yep I think that did it. I used the config file with the version of Pronterface on the sd card and the buttons don't seem to disappear. I will try to recreate the error by dragging the the buttons like you suggested Chris because since my mouse is a bit hard to reach when I was levelling the bed that could very well be the cause.
Sorry, only registered users may post in this forum.

Click here to login