Fan doesn't turn on after first layer [SOLVED]
October 29, 2013 10:00AM
Hi,

I've set the settings on the cool tab in Skeinforge to turn on the fan after the first layer but I can't get it to work.

I've used these settings:

Activate cool: (ticked)
Full fan speed 255
Turn on fan at beginning (unticked)
Do not use fan before layer: 2
Force fan on bridge layers: (unticked)
Max layer time for fan use: 40 (was already set)
Full fan speed below layer time 40 (the same, as per Nophead's suggestion in another post regarding cool settings)

If I set turn on fan at beginning the fan does work from the start (but of course keeps running) so I don't think the fan malfunctions

Any ideas?

Edited 1 time(s). Last edit at 10/29/2013 01:15PM by Nilez.
Re: Fan doesn't turn on after first layer
October 29, 2013 10:14AM
Does the fan turn on at all?

First troubleshooting stage would be to open your GCode using a text editor and do a search for M106.
The M106 code switches the fan ON and M107 switches it off.

If M106 DOES appear in the GCode then the fan will come on at some point. If it doesn't might be worth coming back and attaching your GCode file.

Alan

Edited 1 time(s). Last edit at 10/29/2013 10:15AM by Alzibiff.
Re: Fan doesn't turn on after first layer
October 29, 2013 10:45AM
Thanks Alan,

I find the "M106 S255" code everywhere in the gcode for which I turned the fan off for the first layer. I've attached a piece of the gcode file which ends where I find the first instance of the m106 command. (BTW The fan does work when I tell skeinforge to turn it on at the beginning and then generate a gcode from that settings)
Attachments:
open | download - dial gauge clamp.txt (152.6 KB)
Re: Fan doesn't turn on after first layer
October 29, 2013 11:08AM
What the heck?!...it turned on eventually indeed! I thought the first layer was when the printer had done the perimeters and then fill in one "cutsection"? Guess it takes a little longer?
Re: Fan doesn't turn on after first layer
October 29, 2013 11:26AM
If we start counting layers at 1 rather than 0, it appears that the "Fan ON" code, M106, first appears at the end ('end' being an assumption as the attached file does not go beyond M106) of layer 5. That is once the nozzle finishes the layer at a height of 1mm. (You are working with a layer height of 0.2mm).

What happens if you change the number in the "Do not use fan before layer" box to '1' from its current value of '2'?

Not sure I can give you any positive help though as the fan seems to be coming on much later than your value of '2' would suggest.

Do you have any old versions of SF sitting on your system? I only ask as I had a problem with the cool plugin which was solved once I had obliterated previous versions of SF which may have been getting jealous that I was using a newer version. smiling smiley

Alan
Re: Fan doesn't turn on after first layer
October 29, 2013 11:45AM
Hey Alan, haha I might have some of those jealous versions LOL. I'm going to remove everything skeinforge-ish, jealous or not and install the 50plus version from Nopheads' repository and then do another slice. Must say Skeinforge did a beautifull job for the dial gauge clamp I've just printed though!
Re: Fan doesn't turn on after first layer
October 29, 2013 12:27PM
The first layer is layer zero so to have it come on at the start of the second layer you set the parameter to 1.


[www.hydraraptor.blogspot.com]
Re: Fan doesn't turn on after first layer
October 29, 2013 01:13PM
Hi Chris,

Yeah, I set the paramter to 1 like you and Alan suggested, removed older versions of Skeinforge and now the fan turns on nicely after layer zero has been laid down. So everything is working fine now. Thanks guys!
Sorry, only registered users may post in this forum.

Click here to login