Welcome! Log In Create A New Profile


SainSmart Melzi

Posted by WOOK111 
SainSmart Melzi
May 08, 2014 10:40PM
I have just recieved my sainsmart melzi board. i have yet to connect it to ANYTHING ie. stepper motors/hot end/heated bed

i have however

Switched the jumper to usb
attached the cable

i had also got usb drivers which recognize it as a com port now.

however my led flashes at a consistent rate is this normal?

also when following the steps mentioned in the mendel pdf it says to use arduino 1.0.5 included. i have done that i have all the files and have got to the part where i assume i upload firmware to it ( pardon if i am using the incorrect term) it included me opening marlin.ino

which i did. also to set the board type to melzi 1/atmega 1284p

now i get this error in orange when i click the upload button avrdude: stk500_getsync(): not in sync: resp=0x00

What is going on here do the steppers etc need to be connected?
Re: SainSmart Melzi
May 09, 2014 05:07AM

If there is an Arduino-compatible bootloader installed then you need to check that the Arduino IDE is showing the correct comport (Tools|Serial Port) as what has been detected by your OS.

Finally, sometimes the sketch does not upload at the first attempt. Click the Upload button again and it may work for you.

Neil Darlow

I try to write with consideration for all nationalities. Please let me know if something is unclear.
Printing with Mendel90 from fedora 25 using Cura, FreeCAD, MeshLab, OpenSCAD, Skeinforge and Slic3r tools.
Re: SainSmart Melzi
May 09, 2014 12:22PM
yeah it shows as com3 and everything seems to be ok port wise. its just no matter how many times i click upload i get the same error. the light DOES momentarily stop and then it keeps flashing. almost like it got a request or something.
Re: SainSmart Melzi
May 09, 2014 02:18PM
Somebody contacted me with this problem. I suggested it might have a bootstrap working at a lower baud rate and to try halving it by editing boards.txt but he gave up and used an ISP programmer.

Re: SainSmart Melzi
May 09, 2014 04:11PM
well i wont give up perhaps you and i nop can work on this together smiling smiley this is my first time EVER doing any of this arduino stuff
Re: SainSmart Melzi
May 09, 2014 05:11PM
As you bought it from Sainsmart it should be they who provide the support.

Re: SainSmart Melzi
May 09, 2014 05:31PM
was just asking for some help. i was under the assumption that a melzi is a melzi is a melzi regardless of whom soldered the chips on.

there is a large language barrier between myself and sainsmart.

i am just starting in this 3d printer endevour and i have chosen to use your plans and have thusfar followed the software portion to see if there is life in this board

all i have done is have it connected to usb with the jumper switched to usb. there are no other items connected. there is an SD card in the slot.and all it does is blink.

i assume i should be able to connect to it using pronterface. but i cant.

do i need to provide it 12v power as well as usb?
Re: SainSmart Melzi
May 09, 2014 08:45PM
Unfortunately not all Melzis are the same: -

Some have ATmega644p instead of ATmega1280p. Some have the wrong MOSFETS and burn out. Some have the wrong thermistor bias resistors. Some have different connectors (should be screw terminals, not plugs and sockets). Some microstep correctly, some don't. Some have no microstep jumpers fitted. Some have no bootstrap installed and need an ISP.

The sainsmart one may or may not have a bootstrap. I think only they can tell you unless somebody else here has managed to get one working.

To connect with Arduino all you should need is the power jumper set to USB and the auto reset jumper fitted. Select the correct USB port and the board type and off you go. If it doesn't connect then there is something wrong with it. I think it either has no bootstrap, or one with a different baud rate.

Re: SainSmart Melzi
May 09, 2014 09:02PM
ok that makes sense to me. i DO know that in the block by the reset jumper where i see most boards have pins mine doesnt but it has tyhe holes and silkscreened on is ISP and EXT. is it hard to put a bootstrap on it? what is involved etc etc. just got this after having to pay a stupid amount of duty. if i have it sent back ill be out 40 bucks plus if they ship it back ill get dinged with MORE duty charges
Re: SainSmart Melzi
May 10, 2014 12:45AM
I am pretty sure this is the generic message you get when there is a timing error while uploading a sketch to almost any Arduino board. If you google stk500_getsync(): not in sync: resp=0x00 you will find thousands of threads about it and solution is to press the reset button and release it right before the sketch finishes compiling and starts to upload to the board.

Edited 1 time(s). Last edit at 05/10/2014 02:39AM by Sublime.

FFF Settings Calculator Gcode post processors Geometric Object Deposition Tool Blog
Tantillus.org Mini Printable Lathe How NOT to install a Pololu driver
Re: SainSmart Melzi
May 10, 2014 01:22AM
i wish it were that. i saw that before in some other peoples symptoms and had tried it for over an hr to no avail.

i really hope these reviews on amazon arent true!


Most Helpful Customer Reviews
1 of 1 people found the following review helpful
No support, doesn't work, defective connectors
By Joseph Turner on February 16, 2014
Verified Purchase
O bought this Melzi to upgrade the electronics on my Makerbot Cupcake so I could use a MBE v9 extruder with it.

It was selected over other Melzi's because it came built with RAMPs style screw terminal sockets. You can screw the wires in and still unplug the connector later if needed. Pretty useful to me since the Cupcake's stepper motors are not wired RepRap style and thus I needed to cut the stepper motor connectors off anyway.

Unfortunately 3 of the screws on the stepper motor connectors were defective. You would turn the screw counter clockwise and the metal piece inside wouldn't move.

The larger issue though is the board comes loaded with test software that moves the X Y Z axis around and I have been unable to reprogram it with Marlin. When powered, either USB or 12V (moving the jumper), the red LED blinks. When it is blinking the unit is maniacally moving X Y and Z. When I set the reset jumper, it keeps running the test program. When I attempt to use Arduino IDE to reprogram it I get an STK500v1 error. Manually pushing the reset button during upload attempts yields no results either.

All I can guess at this point is the test program is loaded as the boot loader leaving anyone buying one to need to flash the boot loader to install 3D printer software. In addition the ISP header is not soldered in so flashing the boot loader would require soldering the board with no guarantee I'd be able to fix it even then.

I've looked around for support and found nothing.

Definitely planning a return of the board if Sain Smart doesn't respond to this review.
Comment Was this review helpful to you? Yes No
No bootlader or damaged, need an ISP flash
By The_ccm on April 26, 2014
I can confirm review above, the melzi from Saintsmart comes with a test program, which just blink the led on the board. I tried to get it work with many arduino IDE, 1.01 , 1.05 and even 0022 0023 with custom folders but none worked. I think the boot loader is just missing. The fix :
- solder header on the ISP via on the PCB. It does not require high soldering skills as there is no component next to the ISP holes so you have place to do it.
- get latest arduino IDE (1.05) and get the Maniacbug boot loader on GitHub, based on optiboot (mighty-1284p folder)
- get an ISP programmer such as avrisp programmer for 10$, and burn the boot loader.
- the board is ready now, you can flash the board with Marlin firmware or other one you like.

if this were true it would be a real bummer as i do not know how to write a bootloader. but it would make sense as it acts as if the commands from the usb arent there. but the computer recognizes a usb device IS there. and i have everything in Arduino 1.0.5 set correctly com port and board type so i really am lost.
Re: SainSmart Melzi
May 10, 2014 04:14AM
With the auto reset jumper fitted it isn't necessary to press the reset switch on a Melzi. That advice is for other types of board.

One of the main reasons I picked it is because it has screw terminals which are the only reliable connectors for a 3D printer. Having push fit connectors with screw terminals in the plug defeats that objective. See [plus.google.com] for what happens with this type of connector.

To load a bootstrap you attach an ISP programmer, select it as the programmer in arduino IDE and then use the menu option to burn the bootstrap. I recommend the bootstrap I include in the Melzi folder as again not all bootstraps and fuse settings are equal.

Re: SainSmart Melzi
May 10, 2014 04:35AM
I recommend the bootstrap I include in the Melzi folder as again not all bootstraps and fuse settings are equal.

Well said. I am not sure that the official Marlin Sanguino setup is correct. I do not believe the bootloader size fuse settings are correct and their boards.txt does not even account for the bootloader, giving the user the impression he has the full 128k available for code.

Neil Darlow

I try to write with consideration for all nationalities. Please let me know if something is unclear.
Printing with Mendel90 from fedora 25 using Cura, FreeCAD, MeshLab, OpenSCAD, Skeinforge and Slic3r tools.
Sorry, only registered users may post in this forum.

Click here to login