Welcome! Log In Create A New Profile


Melzi upload not stored

Posted by hsbontop 
Melzi upload not stored
June 29, 2016 04:03PM
After a month or so of inactivity I started my printer and had to adjust the height and the E-steps due to switch of filament.
The upload proceeded as normal (without errors) but when running M503 no values had changed?!?
Tried a bunch of times with various usb ports and approaches, no error messages during upload but nothing changes. The same applies for
any other parameter I tried.
When changing a parameter manually via Pronterface like M92 E170 and then running M500 the value is successfully stored in the
eeprom and it is not overwritten in the upload.

What could be wrong here?
Re: Melzi upload not stored
June 29, 2016 04:28PM
Uploading Marlin firmware doesn't change anything in the EEPROM. You need to do a M502 followed by a M500 to update the EEPROM every time.

Repetier firmware can if you change the EEPROM set number for each upload.
Re: Melzi upload not stored
June 29, 2016 04:42PM
Not sure what you are referring to, I would like for the arduino upload to store the settings permanently.
Anyhow, problem solved... had forgot to disable eeprom support in the Marlin firmware.
Sorry, only registered users may post in this forum.

Click here to login