Welcome! Log In Create A New Profile


Mendel 90 and Cura 3.x+

Posted by Arakon 
Mendel 90 and Cura 3.x+
July 19, 2019 01:13AM

I was going to try Cura after a very long time (I usually use Slic3r).
However, it seems that in Cura, the Z-Axis for the Mendel90 is inverted.. i.e. it will print at the top and at the end of the print, lower the extruder to the bed.
I found absolutely no settings for this. Weirdly, Cura even has a preset for the Mendel90, but the values there are all wrong. It worked fine in a very, very old Cura version, if I recall right (14.xxx), but not since the complete rework of the program.

Anyone have any idea on how to fix this?
Re: Mendel 90 and Cura 3.x+
July 19, 2019 04:47AM
No Idea but AFAIK all slicers have Z=0 to mean nozzle on the bed and go upwards from that. The firmware maps that to physical locations. I don't know of any machines where the axis is inverted. Obviously some move the nozzle up and others move the bed down but the gcode should be the same with Z increasing from 0.

What do the first few Z values in the gcode look like?

Re: Mendel 90 and Cura 3.x+
July 19, 2019 04:54AM
I'll have to tell you the values when I am back home.
The printer basically starts printing while the Z-axis is still all the way at the top. When I use Slic3r, instead, the extruder moves down to the bed and then starts printing.
I even copied the start and end gcodes from Slic3r over, but it still happens.
Edit #2: Okay, got it.

The files both use positive Z values, but Cura uses G0, while Slic3r uses G1.
First "Z" Gcode in Slic3r ist "G1Z0.05", first Z Gcode in Cura is "G1 Z0.05"

Edited 2 time(s). Last edit at 07/19/2019 05:56AM by Arakon.
Re: Mendel 90 and Cura 3.x+
July 19, 2019 06:37AM
There is no difference between G0 and G1 in the version of Marlin I use. Both should move to the bottom.

In standard G code G0 is a travel move to get there as fast as possible and G1 is a coordinated move where the axes are kept in sync for cutting. I think in CNC G code they each maintain a separate feed rate.

What firmware are you using?

Re: Mendel 90 and Cura 3.x+
July 20, 2019 09:00AM
To report back:
It works now. I honestly have no idea why it didn't at first, the only explanation I have is that the first times I tried, when homing, the limit switch didn't trigger, which caused the Z-axis to refuse moving (this seems to be a safety setting in the firmware).
After coming back home yesterday and doing some more adjustments, the printer now prints fine in Cura as well as Slic3r, and I'll be replacing the endstop switch just to be on the safe side.
Sorry, only registered users may post in this forum.

Click here to login