Welcome! Log In Create A New Profile


recuring windows message openscad.exe has stopped working

Posted by deckingman 
recuring windows message openscad.exe has stopped working
July 11, 2016 04:46PM
I really hope someone can help me with this. For the last few days I can no longer use OpenScad. It's really weird but after about 1 or 2 minutes I get a window pop up to say that OpenScad.exe has stopped working. Windows is checking for a solution etc.... It doesn't matter what file I open or even if I don't open any file at all. I can just press the start menu, and select OpenScad and leave it at the welcome screen and after about 2 minutes, I'll get the message that OpenScad.exe has stopped working. It's been fine for about 10 months. I've uninstalled it and re-installed it (although in control panel it says "remove only" but I don't know what that means). I'm running Windows 7 Home Premium. The problem is co-incidental with me uninstalling an inkjet printer and installing a laser jet but I can't think why that would have any bearing.
Re: recuring windows message openscad.exe has stopped working
July 12, 2016 07:20AM
If you load a simple scad file & hit F6 before it goes wrong, does it render OK? If not, you might get a more informative error message.

It is quite possible that installing a printer updated one of the libraries that OpenScad uses, maybe OpenGL. You could try restoring your Windows system to a previous state from a time you know that OpenScad was working. Also try right-clicking on OpenScad and "run as administrator" in case it is tripping up on access rights. Maybe see if the fault still occurs if you unplug your network - if not it indicates a network based issue. Other things to try is to uninstall your new printer, install a file activity logging application and see whether the issue occurs after an attempt to access a particular file, run OpenScad in compatibility mode and boot your system to "safe" mode and see whether it is OK in that mode.

You should also use task manager to monitor your system while you open OpenScad to see whether it is gobbling memory or CPU time while apparently idle.

Re: recuring windows message openscad.exe has stopped working
July 14, 2016 05:59AM
Hi Dave,

Thanks very much for taking the time. While I was awaiting a response on these forums, I managed to register at OpenScad.org and post the same question there. Someone who's user name is Marius ask me to look at Windows Event Viewer and also post details from Library Info which I managed to do (after much "Googling"). His response to the information I provided was as follows:


I’m not sure what’s going on. Here’s the story so far:
o It crashes in the AMD OpenGL drivers
o You do have the latest stable drivers from AMD

An OpenGL driver should never crash. This is almost always a bug in the drivers, and the solution is usually to update the drivers. This doesn’t really help you though.

If you’re willing to dig deeper, here are some suggestions, in order of increasing disruptiveness:
1) Test a development snapshot of OpenSCAD (currently 2016.05.12): [www.openscad.org]
2) Test using the “Crimson” edition of the AMD drivers: [support.amd.com]
3) Do a clean reinstall of any graphics- or motherboard-related software on your computer.
4) A clean Windows reinstall might also help, but that’s a bit disruptive


........End of quote.

So, that seems to stack up with what you were saying about the new printer screwing up OpenGL.

Now what's really weird is that yesterday, I ran into another seemingly unrelated problem which I have put right and thus far today, OpenScad is behaving itself. When I tried to boot my PC yesterday morning, I had nothing but a black screen with a flashing cursor. I eventually found that for some reason, the Bios settings had changed and the HDD which had priority was a USB that I use for backup and not my main SSD. I've changed the Bios to what it should be so that the PC boots without me having to do F12 to get the boot menu up. Since doing that, I've had OpenScad running for about 2 hours so far today whereas before, it would crash after 2 minutes eve when it was idle. I've tried rendering some really large files and it's still working fine. I've tried it with 3 files open at the same time and still it won't crash. This is really weird.

Which leaves me with many unanswered questions. How did the Bios get screwed? Has changing the first boot device in Bios fixed the problem? If so why? I guess I'll have to chnage the Bios back to how it was when Open Scad wouldn't work and see if the problem is reproducible .
Re: recuring windows message openscad.exe has stopped working
July 14, 2016 08:08AM
Some printer driver installation applications make pretty intrusive changes to your system. Some printer drivers/applications that have scanner functionality in particular will make changes to graphics related settings. An installer that changes BIOS settings is naughty because BIOS settings are not standard from motherboard to motherboard. It's quite possible that whatever changed your boot order also changed other "invisible" BIOS settings that are not meant to be user changeable for that motherboard make & model. Invoking the BIOS menu to restore your boot order also resulted in the BIOS settings program automatically restoring the default values to non-user settings, and maybe performing other "sanity checks" before saving your new settings. So don't be surprised if changing the boot order back to the incorrect setting does not bring back the problem.

One setting that may or may not appear in your particular BIOS, but which can upset many applications that use complex graphics routines is the setting that turns on or off video RAM shadowing.


Edited 2 time(s). Last edit at 07/14/2016 08:15AM by dmould.
Re: recuring windows message openscad.exe has stopped working
July 14, 2016 05:11PM
Hi Dave,

Well OpenScad has been behaving itself all day now so I'm reasonably confident that whatever the cause, it's now fixed. For info, the printer I uninstalled was a Canon MG 5500 inkjet multi function (scanner/copier/printer) and the one I installed is a Samsung CLX 6260ND colour laser jet, also multi function scanner/copier/printer. I guess either one could have been the culprit. I'll think I'll just leave well alone for now. Many thanks for the advice and for taking the time though. Much appreciated.
Sorry, only registered users may post in this forum.

Click here to login