Re: P3D Drucker (Hilfe)
14. May 2014 09:31
Blöde Antwortfrage:
Die Jumper unter den Treibern sind alle gesteckt?
Re: P3D Drucker (Hilfe)
14. May 2014 10:04
Jap sind alle drin sad smiley

Gruß Gordon
Re: P3D Drucker (Hilfe)
14. May 2014 10:34
Schon die Treiber mal getauscht zum testen?
Re: P3D Drucker (Hilfe)
14. May 2014 11:30
Hi

Also bei mir am RAMPS Modul sind die Motoranschlüsse beschriftet, von links nach rechts 1A 2A 1B 2B .. A ist jeweils eine Spule, B ist jeweils eine Spule. Blöd dass deine motoren direkt so Kabel dranhaben, die Steckerbelegung von den normalen 6 pol Anschlüssen die eigentlich gängig sind wüsste ich im Kopf.

nimm ein Multimeter und miss dir erstmal am Motor die beiden Spulen aus, dann kann man da schonmal sicher sein. Welcher nun A und welcher B ist ist erstmal egal, kann dann nur links oder eben rechtsrum drehen. Wichtig ist die Polung der Spulen, machste da was falsch brummen die auch nur rum.

Also A und B anschließen, wenns nicht geht, eine Spule umpolen, dann muss es definitiv schonmal was tun. Wenn dann noch immer nix geht naja dann Schrittmotortreiber oder eben Strom zu hoch oder zu niedrig eingestellt (das kleine Poti auf den Treibern)

Grüße,
Martin
Re: P3D Drucker (Hilfe)
14. May 2014 11:35
So also....

1. Motortreiber habe ich mal getauscht = Selbes Problem ( Nur die Y Achse geht )
2. Polung hab ich gemessen = 1 Spule = Rot, Blau / 2 Spule = Grün, Schwarz ! Habe diese auch Richtig auf dem Board gesteckt.
3. Jumper sind auch drin unter den Treibern
4. Gemessen habe ich auch schon. Strom kommt auch an den Motortreibern an.

Ich lässt sich zum verrecken nicht die X oder Z Achse ansteuern. Und ich kann mir das nicht erklären sad smiley Kein Brummen oder ähnliches

Gruß Gordon

1-mal bearbeitet. Zuletzt am 14.05.14 11:37.
Re: P3D Drucker (Hilfe)
14. May 2014 12:15
Hier gibts einen Button wenn du ne Nachricht schreibst, da kann man Bilder hochladen und direkt einfügen.
Ich schau mir die Bilder auf so nem Hoster garnicht erst an...und damit bin ich sicher nicht allein.

Und fals die Bilder mal nicht mehr dort liegen sind die Links tot und das Thema hier völlig nutzlos.

Gruß Sven
Re: P3D Drucker (Hilfe)
14. May 2014 12:26
Sorry jetzt wo du es Sagst sehe ich die Funktion auch hier.

Ich Bearbeite mal meine Ganzen Bilder und dann Lade ich Sie nochmal Hoch hier. (Meine Bilder sind zu Groß um Sie so hier Hochzuladen)
Vielleicht kann mir dann jemand Helfen smiling smiley

Gruß Gordon
Re: P3D Drucker (Hilfe)
14. May 2014 12:29
IrfanView.......Image......rezize....usw.

Gruß Sven
Re: P3D Drucker (Hilfe)
14. May 2014 12:39
Danke Sven das Programm ist Sehr Gut smiling smiley Ich glaube ich habe das Problem gefunden... Habe alles am Motortreiber nochmal durchgemessen... spannung kommt an am Motortreiber aber am Motor kommt nichts an. Ich denke mal das ich mir 2 Motortreiber geschossen habe.... vielleicht zu schlecht gelötet oder so sad smiley .

Im Anhand sind ein paar Bilder.

Gruß Gordon

2-mal bearbeitet. Zuletzt am 14.05.14 14:05.
Anhänge:
Öffnen | Download - SDC11729.jpg (427.5 KB)
Öffnen | Download - SDC11731.jpg (323.6 KB)
Öffnen | Download - SDC11733.jpg (520.3 KB)
Re: P3D Drucker (Hilfe)
14. May 2014 14:17
Hi

Hast du keine Kühlkörper für die Motortreiber?

Ohne kühli machen dies nich lange
Re: P3D Drucker (Hilfe)
15. May 2014 03:29
Hay,

Ne habe mir jetzt nochmal ein Set aus 5 Treibern + Kühlkörper bestellt weil beim ersten set keine dabei waren und ich es nicht wusste. Denke mal deswegen sind die auch Kaputt und wegen der Lötpunkte vielleicht.

Gruß Gordon
Re: P3D Drucker (Hilfe)
19. May 2014 14:27
Hallo smiling smiley

So die 5 x Motortreiber + Kühlkörper + Zahnräder sind angekommen.... alle falsch.... Verkäufer hatte Angeblich nicht mehr die Bestellten vorrätig und hat mir dafür andere Gesendet.... Die 4 x Zahnräder (5mm Innendurchmesser) für die Motoren sind auch Falsch... Jetzt muss ich nach langem Warten den ganzen mist wieder zurücksenden sad smiley In der Zwischenzeit habe ich die Komplette Verkabelung am Drucker fertig gemacht. Bilder kommen Später auch noch hier. Nächste Woche kommen dann auch die Alu Profile an für den 2. Druckeraufbau (Stabiler) Einen Aufbau muss ich mir noch Überlegen. Jetzt muss ich nochmal gucken wo ich am Besten die Fehlenden Teile herbekomme.

So noch ein kleines Bilder Update

Gruß Gordon

1-mal bearbeitet. Zuletzt am 20.05.14 03:04.
Anhänge:
Öffnen | Download - 1.jpg (452.8 KB)
Öffnen | Download - 2.jpg (537.2 KB)
Öffnen | Download - 3.jpg (569 KB)
Re: P3D Drucker (Hilfe)
22. May 2014 08:27
Hallo smiling smiley

So alle Teile sind angekommen smiling smiley Zahnräder passen , Motortreiber passen smiling smiley Wollte gerade den ersten Test machen und schon reist mein alter Zahnriemen.... hat jemand zufällig einen Zahnriemen über den er mir Verkaufen kann ? Sollte mind. 60 cm Umfang haben und nicht breiter als 7mm sein.

Gruß Gordon
Re: P3D Drucker (Hilfe)
31. May 2014 11:51
Hallo Zusammen.

Nach längerer Ruhephase bin ich wieder da. Drucker ist soweit alles zusammengebaut. Jetzt zu meinem Problem.

- Extruder Funktioniert (Motor + Heizung)
- Y Achse Funktioniert
- X Achse keine Funktion (Auch kein widerstand zu spüren am Motor)
- Z Achse Funktioniert nicht (Motoren drehen nicht, nur brummen oder ein widerstand)

Ich habe verschiedene Firmware getestet aber keine Funktioniert. Schrittmotortreiber alle Neu und auch gewechselt. Jumper sind drin. Motoren sind auch richtig angeschlossen.
Ich weis nicht weiter und verzweifel bald... ich möchte gerne mein erstes kleines Objekt Drucken smiling smiley Aber ich finden den blöden Fehler nicht. Ist meine Hardware Defekt? Ramps 1.4 oder das Mega Board ? Was ich aber nicht glaube ;(

Bitte um Hilfe. Oder sollte ich doch lieber einen Fertigen Drucker Kaufen ? Ich weis momentan echt nicht weiter....

Gruß Gordon
Re: P3D Drucker (Hilfe)
31. May 2014 12:02
und wer soll jetzt die Glaskugel anwerfen....???

Mach Bilder....viele....stell die hier ein. Poste deine Config usw.

Schreibe genau auf was geht und was nicht, messe Spannungen überall wo sie relevant sind. Heizbett, Hotend, usw.

und dann schreib nochmal nen Post.

Und hast du alle Motoren mal ohne Drucker getestet, bevor du die eingebaut hast. Also ist denn mal ein Programm ohne die Druckerhardware gelaufen? Ich hab das probiert und nicht jeder Stepper läuft gleich gut bei identisch eingestellten Treibern.

Sven
Re: P3D Drucker (Hilfe)
31. May 2014 12:20
Hay,

- Extruder Funktioniert (Motor + Heizung)
- Y Achse Funktioniert
- X Achse keine Funktion (Auch kein widerstand mit der Hand zu spüren am Motor)
- Z Achse Funktioniert teilweise (Motor dreht nicht, entweder brummen oder ein leichten widerstand)


config. von der Repetier Firmware

/*
    This file is part of Repetier-Firmware.

    Repetier-Firmware is free software: you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation, either version 3 of the License, or
    (at your option) any later version.

    Repetier-Firmware is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    GNU General Public License for more details.

    You should have received a copy of the GNU General Public License
    along with Repetier-Firmware.  If not, see [www.gnu.org].

*/

#ifndef CONFIGURATION_H
#define CONFIGURATION_H

/**************** READ FIRST ************************

   This configuration file was created with the configuration tool. For that
   reason, it does not contain the same informations as the original Configuration.h file.
   It misses the comments and unused parts. Open this file file in the config tool
   to see and change the data. You can also upload it to newer/older versions. The system
   will silently add new options, so compilation continues to work.

   This file is optimized for version 0.91
   generator: [www.repetier.com]

   If you are in doubt which named functions use which pins on your board, please check the
   pins.h for the used name->pin assignments and your board documentation to verify it is
   as you expect.

*/

#define NUM_EXTRUDER 1
#define MOTHERBOARD 33

#include "pins.h"

// ################## EDIT THESE SETTINGS MANUALLY ################
// ################ END MANUAL SETTINGS ##########################

#define FAN_PIN -1
#define FAN_BOARD_PIN -1
#define X_MIN_PIN -1
#define Y_MIN_PIN -1
#define Z_MIN_PIN -1
#define X_MAX_PIN -1
#define Y_MAX_PIN -1
#define Z_MAX_PIN -1

//#define EXTERNALSERIAL  use Arduino serial library instead of build in. Requires more ram, has only 63 byte input buffer.
// Uncomment the following line if you are using arduino compatible firmware made for Arduino version earlier then 1.0
// If it is incompatible you will get compiler errors about write functions not beeing compatible!
//#define COMPAT_PRE1


#define DRIVE_SYSTEM 0
#define XAXIS_STEPS_PER_MM 80
#define YAXIS_STEPS_PER_MM 80
#define ZAXIS_STEPS_PER_MM 80
#define EXTRUDER_FAN_COOL_TEMP 50
#define EXT0_X_OFFSET 0
#define EXT0_Y_OFFSET 0
#define EXT0_STEPS_PER_MM 370
#define EXT0_TEMPSENSOR_TYPE 1
#define EXT0_TEMPSENSOR_PIN TEMP_0_PIN
#define EXT0_HEATER_PIN HEATER_0_PIN
#define EXT0_STEP_PIN ORIG_E0_STEP_PIN
#define EXT0_DIR_PIN ORIG_E0_DIR_PIN
#define EXT0_INVERSE 0
#define EXT0_ENABLE_PIN E0_ENABLE_PIN
#define EXT0_ENABLE_ON 0
#define EXT0_MAX_FEEDRATE 50
#define EXT0_MAX_START_FEEDRATE 20
#define EXT0_MAX_ACCELERATION 5000
#define EXT0_HEAT_MANAGER 3
#define EXT0_WATCHPERIOD 1
#define EXT0_PID_INTEGRAL_DRIVE_MAX 230
#define EXT0_PID_INTEGRAL_DRIVE_MIN 40
#define EXT0_PID_P 7
#define EXT0_PID_I 2
#define EXT0_PID_D 40
#define EXT0_PID_MAX 255
#define EXT0_ADVANCE_K 0
#define EXT0_ADVANCE_L 0
#define EXT0_ADVANCE_BACKLASH_STEPS 0
#define EXT0_WAIT_RETRACT_TEMP 150
#define EXT0_WAIT_RETRACT_UNITS 0
#define EXT0_SELECT_COMMANDS ""
#define EXT0_DESELECT_COMMANDS ""
#define EXT0_EXTRUDER_COOLER_PIN -1
#define EXT0_EXTRUDER_COOLER_SPEED 255
#define RETRACT_DURING_HEATUP true
#define PID_CONTROL_RANGE 20
#define SKIP_M109_IF_WITHIN 2
#define SCALE_PID_TO_MAX 0
#define TEMP_HYSTERESIS 0
#define EXTRUDE_MAXLENGTH 160
#define NUM_TEMPS_USERTHERMISTOR0 0
#define USER_THERMISTORTABLE0 {}
#define NUM_TEMPS_USERTHERMISTOR1 0
#define USER_THERMISTORTABLE1 {}
#define NUM_TEMPS_USERTHERMISTOR2 0
#define USER_THERMISTORTABLE2 {}
#define GENERIC_THERM_VREF 5
#define GENERIC_THERM_NUM_ENTRIES 33
#define HEATER_PWM_SPEED 0

// ############# Heated bed configuration ########################

#define HAVE_HEATED_BED 0
#define HEATED_BED_MAX_TEMP 120
#define SKIP_M190_IF_WITHIN 3
#define HEATED_BED_SENSOR_TYPE 1
#define HEATED_BED_SENSOR_PIN TEMP_1_PIN
#define HEATED_BED_HEATER_PIN HEATER_1_PIN
#define HEATED_BED_SET_INTERVAL 5000
#define HEATED_BED_HEAT_MANAGER 0
#define HEATED_BED_PID_INTEGRAL_DRIVE_MAX 255
#define HEATED_BED_PID_INTEGRAL_DRIVE_MIN 80
#define HEATED_BED_PID_PGAIN   196
#define HEATED_BED_PID_IGAIN   33
#define HEATED_BED_PID_DGAIN 290
#define HEATED_BED_PID_MAX 255
#define MIN_EXTRUDER_TEMP 150
#define MAXTEMP 275
#define MIN_DEFECT_TEMPERATURE -10
#define MAX_DEFECT_TEMPERATURE 290

// ################ Endstop configuration #####################

#define ENDSTOP_PULLUP_X_MIN true
#define ENDSTOP_X_MIN_INVERTING false
#define MIN_HARDWARE_ENDSTOP_X false
#define ENDSTOP_PULLUP_Y_MIN true
#define ENDSTOP_Y_MIN_INVERTING false
#define MIN_HARDWARE_ENDSTOP_Y false
#define ENDSTOP_PULLUP_Z_MIN true
#define ENDSTOP_Z_MIN_INVERTING false
#define MIN_HARDWARE_ENDSTOP_Z false
#define ENDSTOP_PULLUP_X_MAX true
#define ENDSTOP_X_MAX_INVERTING false
#define MAX_HARDWARE_ENDSTOP_X false
#define ENDSTOP_PULLUP_Y_MAX true
#define ENDSTOP_Y_MAX_INVERTING false
#define MAX_HARDWARE_ENDSTOP_Y false
#define ENDSTOP_PULLUP_Z_MAX true
#define ENDSTOP_Z_MAX_INVERTING false
#define MAX_HARDWARE_ENDSTOP_Z false
#define max_software_endstop_r true

#define min_software_endstop_x false
#define min_software_endstop_y false
#define min_software_endstop_z false
#define max_software_endstop_x false
#define max_software_endstop_y false
#define max_software_endstop_z false
#define ENDSTOP_X_BACK_MOVE 5
#define ENDSTOP_Y_BACK_MOVE 5
#define ENDSTOP_Z_BACK_MOVE 2
#define ENDSTOP_X_RETEST_REDUCTION_FACTOR 3
#define ENDSTOP_Y_RETEST_REDUCTION_FACTOR 3
#define ENDSTOP_Z_RETEST_REDUCTION_FACTOR 3
#define ENDSTOP_X_BACK_ON_HOME 1
#define ENDSTOP_Y_BACK_ON_HOME 1
#define ENDSTOP_Z_BACK_ON_HOME 0
#define ALWAYS_CHECK_ENDSTOPS 1

// ################# XYZ movements ###################

#define X_ENABLE_ON 0
#define Y_ENABLE_ON 0
#define Z_ENABLE_ON 0
#define DISABLE_X 0
#define DISABLE_Y 0
#define DISABLE_Z 0
#define DISABLE_E 0
#define INVERT_X_DIR 0
#define INVERT_Y_DIR 0
#define INVERT_Z_DIR 0
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1
#define X_MAX_LENGTH 200
#define Y_MAX_LENGTH 200
#define Z_MAX_LENGTH 180
#define X_MIN_POS 0
#define Y_MIN_POS 0
#define Z_MIN_POS 0

// ##########################################################################################
// ##                           Movement settings                                          ##
// ##########################################################################################

#define FEATURE_BABYSTEPPING 1
#define BABYSTEP_MULTIPLICATOR 1

#define DELTA_SEGMENTS_PER_SECOND_PRINT 180 // Move accurate setting for print moves
#define DELTA_SEGMENTS_PER_SECOND_MOVE 70 // Less accurate setting for other moves

// Delta settings
#define DELTA_HOME_ON_POWER 0

#define MAX_DELTA_SEGMENTS_PER_LINE 24
#define STEPPER_INACTIVE_TIME 360L
#define MAX_INACTIVE_TIME 0L
#define MAX_FEEDRATE_X 200
#define MAX_FEEDRATE_Y 200
#define MAX_FEEDRATE_Z 2
#define HOMING_FEEDRATE_X 40
#define HOMING_FEEDRATE_Y 40
#define HOMING_FEEDRATE_Z 2
#define HOMING_ORDER HOME_ORDER_ZXY
#define ENABLE_BACKLASH_COMPENSATION 0
#define X_BACKLASH 0
#define Y_BACKLASH 0
#define Z_BACKLASH 0
#define RAMP_ACCELERATION 1
#define STEPPER_HIGH_DELAY 0
#define STEP_DOUBLER_FREQUENCY 12000
#define ALLOW_QUADSTEPPING 1
#define DOUBLE_STEP_DELAY 1 // time in microseconds
#define MAX_HALFSTEP_INTERVAL 1999
#define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_X 1000
#define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_Y 1000
#define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_Z 100
#define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_X 1000
#define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_Y 1000
#define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_Z 100
#define MAX_JERK 20
#define MAX_ZJERK 0.3
#define MOVE_CACHE_SIZE 16
#define MOVE_CACHE_LOW 10
#define LOW_TICKS_PER_MOVE 250000
#define FEATURE_TWO_XSTEPPER 0
#define X2_STEP_PIN   ORIG_E1_STEP_PIN
#define X2_DIR_PIN    ORIG_E1_DIR_PIN
#define X2_ENABLE_PIN E1_ENABLE_PIN
#define FEATURE_TWO_YSTEPPER 0
#define Y2_STEP_PIN   ORIG_E1_STEP_PIN
#define Y2_DIR_PIN    ORIG_E1_DIR_PIN
#define Y2_ENABLE_PIN E1_ENABLE_PIN
#define FEATURE_TWO_ZSTEPPER 0
#define Z2_STEP_PIN   ORIG_E1_STEP_PIN
#define Z2_DIR_PIN    ORIG_E1_DIR_PIN
#define Z2_ENABLE_PIN E1_ENABLE_PIN
#define FEATURE_DITTO_PRINTING 0


// ################# Misc. settings ##################

#define BAUDRATE 115200
#define ENABLE_POWER_ON_STARTUP
#define POWER_INVERTING 0
#define KILL_METHOD 1
#define GCODE_BUFFER_SIZE 2
#define ACK_WITH_LINENUMBER
#define WAITING_IDENTIFIER "wait"
#define ECHO_ON_EXECUTE
#define EEPROM_MODE 1

/* ======== Servos =======
Control the servos with
M340 P S   / ServoID = 0..3  pulseInUs = 500..2500
Servos are controlled by a pulse width normally between 500 and 2500 with 1500ms in center position. 0 turns servo off.
WARNING: Servos can draw a considerable amount of current. Make sure your system can handle this or you may risk your hardware!
*/
#define FEATURE_SERVO 0
#define SERVO0_PIN 11
#define SERVO1_PIN -1
#define SERVO2_PIN -1
#define SERVO3_PIN -1
#define FEATURE_WATCHDOG 0

// #################### Z-Probing #####################

#define FEATURE_Z_PROBE 0
#define Z_PROBE_BED_DISTANCE 10
#define Z_PROBE_PIN -1
#define Z_PROBE_PULLUP 0
#define Z_PROBE_ON_HIGH 0
#define Z_PROBE_X_OFFSET 0
#define Z_PROBE_Y_OFFSET 0
#define Z_PROBE_WAIT_BEFORE_TEST 0
#define Z_PROBE_SPEED 2
#define Z_PROBE_XY_SPEED 150
#define Z_PROBE_SWITCHING_DISTANCE 1
#define Z_PROBE_REPETITIONS 1
#define Z_PROBE_HEIGHT 40
#define Z_PROBE_START_SCRIPT ""
#define Z_PROBE_FINISHED_SCRIPT ""
#define FEATURE_AUTOLEVEL 1
#define Z_PROBE_X1 20
#define Z_PROBE_Y1 20
#define Z_PROBE_X2 160
#define Z_PROBE_Y2 20
#define Z_PROBE_X3 100
#define Z_PROBE_Y3 160

#ifndef SDSUPPORT  // Some boards have sd support on board. These define the values already in pins.h
#define SDSUPPORT 0
#define SDCARDDETECT -1
#define SDCARDDETECTINVERTED 0
#endif
#define SD_EXTENDED_DIR 1 /** Show extended directory including file length. Don't use this with Pronterface! */
#define ARC_SUPPORT 1
#define FEATURE_MEMORY_POSITION 1
#define FEATURE_CHECKSUM_FORCED 0
#define FEATURE_FAN_CONTROL 0
#define FEATURE_CONTROLLER 0
#define UI_LANGUAGE 0
#define UI_PRINTER_NAME "RepRap"
#define UI_PRINTER_COMPANY "Home made"
#define UI_PAGES_DURATION 4000
#define UI_ANIMATION 1
#define UI_SPEEDDEPENDENT_POSITIONING 0
#define UI_DISABLE_AUTO_PAGESWITCH 1
#define UI_AUTORETURN_TO_MENU_AFTER 30000
#define FEATURE_UI_KEYS 0
#define UI_ENCODER_SPEED 1
#define UI_KEY_BOUNCETIME 10
#define UI_KEY_FIRST_REPEAT 500
#define UI_KEY_REDUCE_REPEAT 50
#define UI_KEY_MIN_REPEAT 50
#define FEATURE_BEEPER 0
#define CASE_LIGHTS_PIN -1
#define CASE_LIGHT_DEFAULT_ON 1
#define UI_START_SCREEN_DELAY 1000
/**
Beeper sound definitions for short beeps during key actions
and longer beeps for important actions.
Parameter is delay in microseconds and the secons is the number of repetitions.
Values must be in range 1..255
*/
#define BEEPER_SHORT_SEQUENCE 2,2
#define BEEPER_LONG_SEQUENCE 8,8
#define UI_SET_PRESET_HEATED_BED_TEMP_PLA 60
#define UI_SET_PRESET_EXTRUDER_TEMP_PLA   190
#define UI_SET_PRESET_HEATED_BED_TEMP_ABS 110
#define UI_SET_PRESET_EXTRUDER_TEMP_ABS   240
#define UI_SET_MIN_HEATED_BED_TEMP  30
#define UI_SET_MAX_HEATED_BED_TEMP 120
#define UI_SET_MIN_EXTRUDER_TEMP   170
#define UI_SET_MAX_EXTRUDER_TEMP   260
#define UI_SET_EXTRUDER_FEEDRATE 2
#define UI_SET_EXTRUDER_RETRACT_DISTANCE 3

#endif


Ich hoffe das hilft ein wenig.
Anhänge:
Öffnen | Download - g.jpg (496 KB)
Öffnen | Download - gg.jpg (454 KB)
Öffnen | Download - ggg.jpg (414.3 KB)
Öffnen | Download - HadronEndstops.png (111.5 KB)
Re: P3D Drucker (Hilfe)
31. May 2014 13:27
Bin ich jetzt zu doof es zu sehen...???

Wo wird denn deine Z Achse geführt....??? Ich seh nur Gewindestangen.
Sind deine Treiber eingestellt?

Ohne Lüfter in meinem Lüfterhalter am HE killst du übrigens dein Hotend samt Extruder....nur so am Rande erwähnt....
Re: P3D Drucker (Hilfe)
31. May 2014 13:33
Ja die Treiber sind eingestellt. Die Führung der Achse kommt noch dran, sollte aber für den Motortest nicht relevant sein. Am Hotend kommt der Lüfter noch dran, der wird vorher auch nicht voll in Betrieb genommen.
Re: P3D Drucker (Hilfe)
31. May 2014 13:38
Na wenn du das sagst.....

betreibe doch bitte deine 2 Motoren für Z bitte ohne deine Druckermechanik und berichte. Wie sind die zwei Z Stepper auf dem Board angeschlossen? Ich sehe da nur vier Treiber?

Sven
Re: P3D Drucker (Hilfe)
31. May 2014 13:40
Habe das Ramps 1.4.3! soweit ich weis laufen die beiden Z Motoren über einen Treiber, da direkt an dem Treiber auch 2 Motoranschlüsse sind.

Gruß Gordon
Re: P3D Drucker (Hilfe)
31. May 2014 13:45
Teste das doch trotzdem mal ohne die Mechanik. Wenn die ohne Last auch nicht gehen...dann dreh den Strom etwas höher...

Ich teste immer alles ohne Last...um einfach Fehlerquellen auszuschließen.
Re: P3D Drucker (Hilfe)
31. May 2014 13:50
So habe jetzt mal ohne last die Motoren getestet. die Z Achse macht wieder nichts. Beim ansteuern passiert nichts, erhöht man den Strom fangen nur beide Motoren irgendwann an zu Brummen und zu Stottern aber machen keine Umdrehung. Die X Achse geht gar nicht. Y Achse Funktioniert Perfekt. Extruder Motor geht auch Perfekt. So langsam weis ich nicht weiter sad smiley
Re: P3D Drucker (Hilfe)
31. May 2014 13:53
Motoren mal untereinander getauscht?
Treiber mal umgesteckt?
alles kontrolliert?

bitte vorher Spannung weg...

1-mal bearbeitet. Zuletzt am 31.05.14 13:54.
Re: P3D Drucker (Hilfe)
31. May 2014 13:56
So ich glaube ich habe den Fehler gefunden Sven smiling smiley . Es sind Zwar 2 Anschlüsse dort die auch für 2 Motoren sind aber die Funktionieren nicht zu 100% bzw machen Fehler. Ich habe jetzt mal einen abgezogen von der Z Achse und schon lassen sich auch alle anderen Motoren Perfekt Steuern. Ich muss also die beiden Z Achsen Motoren Zusammenlöten und dann in einen Motoranschluss an dem Z steckplatz stecken. Jetzt lässt sich auch die Z Achse steuern ^^ zwar nur eine Achse aber wenn ich die Motoren zusammenlöte und dann in einen Anschluss stecke muss ich ja nur den Strom auf dem Treiber erhöhen oder? Synchron laufen die ja dann wenn die über einen Z Achsen Treiber laufen.

gruß Gordon
Re: P3D Drucker (Hilfe)
31. May 2014 14:03
quatsch....die laufen so synchron...wie die Takt/ Richtungssignal an den Treibern ankommen(Streuung der TreiberIC Qualität mal außen vor).
Steck doch einfach noch nen 5ten Treiber drauf und schreib die Pins um. Ist doch wesentlich sicherer und sinnvoller.

Ich kenn mich mit Repetier nicht genug aus...aber da gibts sicher ne Option.

Ich bin mir fast sicher...du hast die beiden Motoren nicht gleich verkabelt. Egal....nimm lieber den freien Steckplatz.

Sven

grad gesehen....
[www.repetier.com]

hier hast du doch die Possibility to mirror every Axis to a free socket.....smiling smiley

1-mal bearbeitet. Zuletzt am 31.05.14 14:08.
Re: P3D Drucker (Hilfe)
07. June 2014 02:26
Hey Gordon:
Du hast ne PM
Grüße
Re: P3D Drucker (Hilfe)
13. June 2014 02:06
Keine Lust mehr?
Grüße
Re: P3D Drucker (Hilfe)
22. June 2014 12:24
Hallo Zusammen,

JA, man hört auch wieder von mir smiling smiley

Drucker ist soweit alles Fertig zusammengebaut und die ersten Testdrucke sind auch Fertig. Leider wird mein Mosfet zum Heizen des Hotends extrem Heiß! Woran kann es liegen?
Ich Teste jetzt am Drucker nichts mehr weil es mir zu Heiß wird. Hatte Jemand schon mal so ein Problem? Ich habe schon google usw benutzt aber ich komm nicht weiter bei dem Problem.

Bilder vom Drucker habe ich auch ein neues Hochgeladen. Und ein Video mit einem Testdruck der Fehler macht! Ich nehme an wegen dem Heißen Mosfet!

[www.youtube.com]



Gruß Gordon
Anhänge:
Öffnen | Download - 10405275_659362610811627_4228225793164316090_n.jpg (89.1 KB)
Re: P3D Drucker (Hilfe)
22. June 2014 14:23
Hi

Also so ein Fehler kann nicht vom Mosfet an sich kommen, das kann ich mir nicht vorstellen. Mal mit ner anderen Datei getestet? Kommt das Problem dann auch?

Bei der 12V 30Watt Patrone sollte der Widerstandswert so ca 4,8 Ohm betragen. Dazu muss der RDS On des Mosfets berücksichtigt werden. Daraus errechnet man in der Regel die Schaltverluste. Der RDS On bei so standard allerwelts Mosfets liegt so um die 0,2 Ohm, kann aber im Datenblatt nachgelesen werden. Wenn ich wüsste was bei dir verbaut wurde. Der Spannungsabfall durch diesen RDS On bewirkt eben die Wärmeabgabe am Mosfet selber. Es fallen am Mosfet in meinem Beispiel ca 0,5v ab. Bei den 2,4A die in der Schaltung fließen ergibt sich also eine wahnsinnige Wärmeabgabe von 1,2Watt am Mosfet. Und der Fall würde auch nur eintreten, wenn der Arduino dauerhaft den Mosfet angeschalten lassen würde.. 1,2W ohne kühlkörper nur beim To220 Gehäuse (Dieses hat einen Wert von ca 80K/W), bedeuteten also 100Grad oberhalb Umgebungstemparatur.. Klar dass der dann brüllend heiß ist, gesetzt dem Fall der wäre immer an und die Heizpatrone würde dauernd heizen wie bekloppt. Selbst bei 50% Duty wärens noch so rund 50Grad+ Umgebungstemparatur.. Dranfassen is also nicht grad schlau. Da bei einem Mosfet in der Regel der RDS on mit steigender Temparatur auch steigt, wird er wenn er heißer wird zwangsläufig noch heißer, da durch den steigenden Widerstand auch mehr Wärme verbraten wird.. Irgendwann geht er dann eben kaputt.

Ich vermute mal, du hast den PID Wert in der Firmware nicht angepasst, dadurch wird der Mosfet geregelt. Diese Werte sollten durch den M303 Befehl vorher gemessen werden und in die firmware eingetragen werden.

[reprap.org]

Ansonsten kann die Firmware die temparatur nicht richtig regeln und im ungünstigen Fall schaltet der dann wild hin und her.. Mein oberes Beispiel ist zwar komplett aus der Luft gegriffen, aber so in etwa wirds sich verhalten.

Grüße,
Martin
Re: P3D Drucker (Hilfe)
22. June 2014 14:37
Hi,

Habe diese Werte bekommen

Infotongue sticking out smileyID Autotune start
bias: 129 d: 125 min: 148.05 max: 151.82
bias: 124 d: 124 min: 148.78 max: 151.53
bias: 118 d: 118 min: 148.93 max: 151.31
Ku: 63.13 Tu: 26.93
Classic PID
Kp: 37.88
Ki: 2.81
Kd: 127.49
bias: 121 d: 121 min: 148.88 max: 151.19
Ku: 66.55 Tu: 27.15
Classic PID
Kp: 39.93
Ki: 2.94
Kd: 135.49
bias: 119 d: 119 min: 149.02 max: 151.14
Ku: 71.74 Tu: 25.71
Classic PID
Kp: 43.04
Ki: 3.35
Kd: 138.36
Infotongue sticking out smileyID Autotune finished ! Place the Kp, Ki and Kd constants in the Configuration.h or EEPROM
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen