Neuer User neuer Drucker
19. April 2016 07:03
Hallo liebe Leute,
nach langem hin und her, läuft nun mein Velleman K8200.
Allerdings nur eine Weile.
Der Druck fäng einwandfrei an. ca. 5-10 min. Dann plötzlich verschiebt / versetzt sich der Druck um 2-3cm und muss den Vorgang natürlich abbrechen. Dies geschieht im selben Layer noch.

Nach dem Abbruchvorgang fährt die Platte wieder zum Nullpunkt. Dieser ist allerdings dann auch verschoben und nicht mehr an der Position wie vor dem Druck. Somit kann man ja eigentlich fast ein Softwarefehler ect ausschließen oder?
Vermutlich eher mechanisch?
Ist mein erster 3d Drucker und somit unerfahren confused smiley.

Danke
Viele Grüße
Southi
Re: Neuer User neuer Drucker
19. April 2016 07:36
Ein Bild wäre sehr hilfreich - wie sieht es aus als du abbrechen musste?


Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Neuer User neuer Drucker
19. April 2016 07:43
Du musst genau beobachten was zu dem Zeitpunkt passiert. Hört sich der Drucker anders an, wenn er den Layer versetzt. Mann kann viel vermuten, aber einschätzen kannst du das nur vor Ort selbst.
Btw: Ich hätte das Thema eher in der Rubrik "Allgemeines" reingestellt und nicht unter Projekte. Denn der Fehler soll sich ja nicht als großes Projekt entwickeln, oder???grinning smiley


Gruß
Stefan
Re: Neuer User neuer Drucker
19. April 2016 08:59
Quote
Grinch74
Du musst genau beobachten was zu dem Zeitpunkt passiert. Hört sich der Drucker anders an, wenn er den Layer versetzt. Mann kann viel vermuten, aber einschätzen kannst du das nur vor Ort selbst.
Btw: Ich hätte das Thema eher in der Rubrik "Allgemeines" reingestellt und nicht unter Projekte. Denn der Fehler soll sich ja nicht als großes Projekt entwickeln, oder???grinning smiley

Ne anders anhören tut er sich nicht. Werde heute aber nochmals genau hinhören. Und nein, es sollte sich natürlich nicht zu einem Projekt entwickeln grinning smiley.

Falls es mir heute heute abend noch reicht, mache ich mal ein paar Bilder. Vielleicht hilft es weiter.

Ich habe in der Software auch "Bewegung anzeigen" eingeschaltet. Da sieht man auch ganz deutlich das er nach ein paar Minuten plötzlich eine Bewegung zur Mitte hin hat obwohl laut Software der Kopf weiter rechts sein müsste und ab da an der Versatz drin ist.

Viele Grüße
Re: Neuer User neuer Drucker
19. April 2016 09:14
Quote
Southi
Ich habe in der Software auch "Bewegung anzeigen" eingeschaltet. Da sieht man auch ganz deutlich das er nach ein paar Minuten plötzlich eine Bewegung zur Mitte hin hat obwohl laut Software der Kopf weiter rechts sein müsste und ab da an der Versatz drin ist.

Wie er zeigt die falsche Bewegung in der Software an. Das ist eigentlich nur möglich, wenn ein Fehler im Slicer/G-Code vorliegt. Da die Software nur die Werte aus diesem interpretiert. Das ist kein 1zu1 Bild deines Druckers. Wenn er dort eine falsche Bewegung anzeigt, liegt es am G-Code des Modells. Hast du einen fertigen G-Code verwendet oder hast du das Modell über Repetier etc. als G-Code erstellt?
Probier's mal mit einem anderen Objekt in ähnlicher Höhe aus. Wenn's bei dem auch bei der gleichen Höhe passiert liegt es höchstwahrscheinlich am Drucker. Wenn nicht am Modell / G-Code.

1-mal bearbeitet. Zuletzt am 19.04.16 09:15.


Gruß
Stefan
Re: Neuer User neuer Drucker
19. April 2016 10:29
Quote
Grinch74
Wie er zeigt die falsche Bewegung in der Software an. Das ist eigentlich nur möglich, wenn ein Fehler im Slicer/G-Code vorliegt. Da die Software nur die Werte aus diesem interpretiert. Das ist kein 1zu1 Bild deines Druckers. Wenn er dort eine falsche Bewegung anzeigt, liegt es am G-Code des Modells. Hast du einen fertigen G-Code verwendet oder hast du das Modell über Repetier etc. als G-Code erstellt?
Probier's mal mit einem anderen Objekt in ähnlicher Höhe aus. Wenn's bei dem auch bei der gleichen Höhe passiert liegt es höchstwahrscheinlich am Drucker. Wenn nicht am Modell / G-Code.

Ich probier mal ein anderes Modell. Habe den G-Code über Repetier erstellt. Im Slicer kann man ja nicht viel falsch einstellen oder? confused smiley hot smiley
Habe es laut Anleitung gemacht.
Habe noch ein bisschen überlegt und mir ist grad eingefallen, dass ich die Cachegröße nicht wie in der Anleitung vorgegeben geändert habe, sondern so belassen wie es Standardmäßig eingestellt war. Kann es daran liegen?

Jedoch wundert mich es trotzdem warum der nach Nullpunkt nach Jobabbruch nicht mehr stimmt.

Aber bevor es hin und her geht, ich mache noch ein paar Versuche. Werde mich melden.

Viele Grüße
Southi
Re: Neuer User neuer Drucker
19. April 2016 20:19
Hallo Southi,

das klingt nach Schrittfehlern der Schrittmotoren. Hintergrund ist, daß die Treiber im Betrieb heiß werden und dann kein sauberes Signal mehr erzeugen können. Dadurch laufen die Motoren bei leichter Überhitzung "unrund" und bei starker Überhitzung bewirkt dies Schrittfehler.

Abhilfe:

1. Kurzfristig: Die Referenzspannung Vref der Treiber reduzieren. Das drosselt den Motorstrom und damit die Leistung. [reprap.org]
[www.pololu.com]

In der Velleman-Anleitung werden 0,425V empfohlen. Nochmal überprüfen ggf. weiter reduzieren. Dadurch sinkt allerdings auch das max. Drehmoment der Motoren. Wenn zu sehr reduziert wird können dadurch wieder Schritfehler entstehen. Außerdem die Mechanik überprüfen: Läuft der Wagen leichtgängig? Wenn z.B. die Zahnriemen nicht gut ausgerichtet sind erzeugen sie zuviel Reibung und damit Motorlast und Treiberwärme. Ebenso zu hohe Zahnriemenvorspannung.

2. Mittelfristig: Bessere Kühlung durch Kühlkörper und noch besser zusätzlich ein Lüfter. Ich verwende dieses Gehäuse, das einen Flansch für einen Lüfter hat: [www.thingiverse.com]
Vorteil des Gehäuses ist, daß der Lüfter oben sitzt und so der Luftstrom gut die Treiber umströmt.
Re: Neuer User neuer Drucker
20. April 2016 02:57
Quote
vokars
Hallo Southi,

das klingt nach Schrittfehlern der Schrittmotoren. Hintergrund ist, daß die Treiber im Betrieb heiß werden und dann kein sauberes Signal mehr erzeugen können. Dadurch laufen die Motoren bei leichter Überhitzung "unrund" und bei starker Überhitzung bewirkt dies Schrittfehler.

Abhilfe:

1. Kurzfristig: Die Referenzspannung Vref der Treiber reduzieren. Das drosselt den Motorstrom und damit die Leistung. [reprap.org]
[www.pololu.com]

In der Velleman-Anleitung werden 0,425V empfohlen. Nochmal überprüfen ggf. weiter reduzieren. Dadurch sinkt allerdings auch das max. Drehmoment der Motoren. Wenn zu sehr reduziert wird können dadurch wieder Schrittfehler entstehen. Außerdem die Mechanik überprüfen: Läuft der Wagen leichtgängig? Wenn z.B. die Zahnriemen nicht gut ausgerichtet sind erzeugen sie zu viel Reibung und damit Motorlast und Treiberwärme. Ebenso zu hohe Zahnriemenvorspannung.

2. Mittelfristig: Bessere Kühlung durch Kühlkörper und noch besser zusätzlich ein Lüfter. Ich verwende dieses Gehäuse, das einen Flansch für einen Lüfter hat: [www.thingiverse.com]
Vorteil des Gehäuses ist, daß der Lüfter oben sitzt und so der Luftstrom gut die Treiber umströmt.

OK Danke,
leider kam ich gestern später von der Arbeit heim. Konnte keine Tests mehr durchführen. Wird erst heute erledigt. Werde die Spannungen prüfen als auch die Mechanik. Vielleicht habe ich die Riemen auch zu sehr gespannt. Leichtgängig ist ja relativ oder? Ich meine im "AUS" Zustand habe ich ja beim hin und her schieben trotzdem eine leichte Reibung / Widerstand durch die Motoren / Riemen, oder nicht?

Danke

1-mal bearbeitet. Zuletzt am 20.04.16 02:58.
Re: Neuer User neuer Drucker
20. April 2016 06:25
Hallo Southi,

"Leichtgängig ist ja relativ oder?"

Riemen-Vorspannung: Die Zahnriemen-Vorspannung muß mindestens so hoch sein, daß der Riemen bei max. Drehzahl nicht abspringt. Beim 3D Druck hat eine zu niedrige Vorspannung den Nachteil, daß bei Richtungs-Wechsel die rücklaufende Riemenseite jedesmal etwas nachgespannt wird und somit Schlupf bzw. Umkehrspiel erzeugt. Dickere und breitere Riemen sind steifer und haben mehr Reibung und Umkehrspiel. Hier hat sich meine Umstellung auf die kleineren GT2-Riemen sehr positiv ausgewirkt.

Zahnriemen-Reibung entsteht aber vor allem, wenn der Zahnriemen sich seitlich verbiegen muß, weil Riemenbefestigungen, Zahnscheibe(n), Umlenkrolle nicht fluchten also seitlich versetzt sind.

Ich teste das einfach manuell, indem ich beim Einstellen, den Wagen per Hand bewege. Umkehrspiel durch Nachspannen der rücklaufenden Riemenseite bei Richtungswechsel kann man sehen.

Reibung ist übrigens auch nicht nur böse. Gleitreibung dämpft z.B. Schwingungen, welche man u.a. auf der Druck-Oberfläche als vertikale Rillen sehen kann. Deswegen habe ich z.B. Motor-Dämpfer eingebaut. Auch bei Führungen kann eine leichte Spannung eine durchaus gewünschte Gleitreibung haben.

Das bedeutet: Das Ausmaß der Gleitreibung so hoch einstellen, daß Schwingungen max. gedämpft werden aber andererseits die Motoren nicht überlastet werden und bei hohen Beschleunigungen Schrittfehler erzeugen bzw. wie in Deinem Fall zuviel Leistung verbrauchen und so die Treiber zu stark erhitzen, sodaß durch die Erwärmung Schrittfehler mit einer typ. Verzögerung von 5-10 min einsetzen.

Aus dem ganzen ergibt sich natürlich, daß die benötigte Leistung/erzeugte Verlustwärme durch verringerte Beschleunigung und Druckgeschwindigkeit (kann im Slicer eingestellt werden) verringert werden kann.
Re: Neuer User neuer Drucker
21. April 2016 04:30
2 Dinge:

1. Mehr Strom auf die Motoren, solange sie nicht Heiss werden oder laut fiepen ist alles vertretbar, die Steuerungsplatine kühlen
2. Beschleunigung und abbremsen in der Firmware begutachten, das ist in den meisten vorkonfigurierten Firmware Versionen utopisch.


Prusa Air 2
Merlin Hotend (passiv und verlängert)

Eigenbau X300 Y500 mit verlängertem Merlin Hotend
BIQU Magician
JGAURORA A5
Anycubic Photon
--------
Eine Kiwi am Tag deckt den menschlichen Tagesbedarf an Kiwis
Re: Neuer User neuer Drucker
21. April 2016 05:18
Sodele,
also gestern Abend hab ich erst mal die Mechanik komplett nochmals überprüft, bisschen angepasst und Das Modell hatte nach ein paar Minuten wieder das selbe Problem. Anderes Modell ausprobiert, dasselbe Problem.
Dann hab ich den gesamten Controller mit einem Ventiltor gekühlt und was soll ich sagen, der druckt ohne Schrittfehler grinning smiley thumbs up.
Hab mir Lüfter bestellt und werde diese, bis ich mein Gehäuse gedruckt habe provisorisch anbringen. Danke erst mal an alle. Ihr habt das kleine Kind in mir glücklich gemacht grinning smiley

Nur die Heizplatte ist nicht 100% parallel zum Extender. Muss ich heute noch penibel justieren, das war gestern das einzige Problem welches sich beim Druck ab und an bemerkbar gemacht hatte.

Bis zum nächsten Problem irgendwann smileys with beer

Merci
Southi
Re: Neuer User neuer Drucker
21. April 2016 06:01
Kurz gefragt: Hast du das Vref mal gecheckt an den Treibern?
Wenn die irgendwie irgendwo mal falsch eingestellt wurden und jetzt auf einer utopischen Zahl fahren, wird er dir bei langen Drucken auch tierisch hochheizen - da bringt dir auch der Lüfter nichts. Und es verringert auch die Lebensdauer der Treiber ungemein.

Prinzipiell schön, dass es nun klappt. Das ist aber wie mit Krankheiten - Du hast nur das Symptom behandelt, aber ggf nicht die Krankheit an sich ^^ Wobei Lüfter an der Elektronik eh pflicht sein sollten.


Alle Angaben ohne Gewähr grinning smiley
Re: Neuer User neuer Drucker
21. April 2016 06:14
Hallo Southi,

Schön, daß die Ursache jetzt geklärt ist. Kleiner Nachtrag zu dem Gehäuse, das ich empfohlen habe. Ich mußte bei den Kabel-Zuführungsöffnungen leicht nachfräsen, damit die Kabel durchgingen. Mich hat das nicht gestört. Nur daß Du ggf. darauf vorbereitet bist. Ansonsten ist das Gehäuse aus meiner Sicht besser als die anderen, die ich gefunden habe.

Zum Lüfter: 15V Spannung auf einen 12V Lüfter. Viele nehmen da noch einen Spannungsregler dazwischen, damit die Spezifikation des Lüfters eingehalten wird und er nicht zu laut ist . Gibt im www viele Anleitungen dazu.
Re: Neuer User neuer Drucker
23. April 2016 04:50
Hallöle,

ja die Spannung wollte ich noch prüfen aber irgendwie bin ich mir nicht ganz sicher. Ich hab zwar im Internet und Anleitungen gesehen wo ungefähr ich "hinlangen" muss, aber so ganz genau sieht man es auch nicht welchen Pin ich beim Treiber zu Prüfung berühren muss. Nicht das ich einen Kurzen verursache. Deswegen hab ich es lieber gelassen. Habt Ihr irgendwo ein Bild zufällig wo ich es genau sehen kann?

Danke
Viele Grüße
Southi
Re: Neuer User neuer Drucker
23. April 2016 08:47
Hallo Southi,

Ja bei Kurzschluß muß man aufpassen. Allerdings mußt Du keine Sorge haben, einen Kurzschluß zu erzeugen, wenn du an einem falschen Punkt mißt, weil ein Spannungsmesser einen hohen Innenwiderstand hat. Gefährlich könnte es nur werden, wenn Du abrutscht und mit der Messspitze eine leitende Verbindung zwischen zwei leitfähigen Punkten der Leiterplatte erzeugst oder versehentlich eine Strommessung (kleiner Innenwiderstand) durchführst sad smiley .

Ich befestige bei den Messungen einen Pol des Spannungsmessers mit einer Krokodilklemme direkt am Schraubenzieher . Dann brauchst Du den Messpunkt nicht und kannst während des Einstellens direkt die Spannung ablesen. Diese Methode ist in o.g. Pololu-Video erklärt.

Der separate Messpunkt ist z.B. hier markiert: [www.shapeoko.com]

Im o.g. Pololu-Video ist der Vorgang ab 3:08 erklärt. Der Referenzpunkt wird da leider für einen anderen Treiber gezeigt, aber man kann gut erkennen, wie der Messpunkt grundsätzlich aussieht.
Re: Neuer User neuer Drucker
23. April 2016 09:34
Super,
vielen Dank. werde ich mal später messen.

Hätte noch eine andere Frage, ich bin bzw möchte noch ein bisschen mit der Temperatur spielen auch wegen Wrapping ect.
Nun habe ich aber das Problem, das die Temp Einstellungen von Slic3r für den ersten und restlichen Layer irgendwie nicht übernommen werden.
Im G Code stehen immer die 190°C. sad smiley
Ist das ein BUG oder mach ich was falsch?

Ist mir schon fast unangenehm wenn ich immer so viele Fragen stelle.

Danke mol
Southi
Re: Neuer User neuer Drucker
23. April 2016 12:07
Hallo Southi,

"Nun habe ich aber das Problem, das die Temp Einstellungen von Slic3r für den ersten und restlichen Layer irgendwie nicht übernommen werden.
Im G Code stehen immer die 190°C."

Da kann ich nur Vermutungen anstellen. Möglichkeiten könnten sein: Slic3r-Profil nicht gespeichert oder im Repetierhost in der Slicer-Registerlasche ein anderes Profil ausgewählt. So grundsätzlich Dinge überprüfen wie Slic3r Konfigurationsverzeichnis-Pfad, usw.. Anders herum: Welche Parameter werden überhaupt übernommen?

Man kann im Repetierhost auch eine Maximal-Temperatur unter Druckereinstellungen angeben. Vermute aber, daß das nicht den G-Code ändert.
Re: Neuer User neuer Drucker
23. April 2016 12:45
Quote
vokars
Hallo Southi,

"Nun habe ich aber das Problem, das die Temp Einstellungen von Slic3r für den ersten und restlichen Layer irgendwie nicht übernommen werden.
Im G Code stehen immer die 190°C."

Da kann ich nur Vermutungen anstellen. Möglichkeiten könnten sein: Slic3r-Profil nicht gespeichert oder im Repetierhost in der Slicer-Registerlasche ein anderes Profil ausgewählt. So grundsätzlich Dinge überprüfen wie Slic3r Konfigurationsverzeichnis-Pfad, usw.. Anders herum: Welche Parameter werden überhaupt übernommen?

Man kann im Repetierhost auch eine Maximal-Temperatur unter Druckereinstellungen angeben. Vermute aber, daß das nicht den G-Code ändert.

Profil hab ich extra unter einem anderen Namen gesichert und ausgewählt. Gestern habe ich mit der Geschwindigkeit gespielt und diese hatte er übernommen. Hab mal direkt mit slic3r ein gcode erstellt, welches ich dann in Repetier reingeladen habe. Da wurden die Temperaturen korrekt übernommen. ist halt umständlicher. Dachte ist vielleicht ein bekanntes Problem. Hab Repetier auch als Administrator ausgeführt. Auch keine Besserung.

Werde noch ein wenig rum experimentieren.

Bis denne
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen