Welcome! Log In Create A New Profile

Advanced

SD Card not working

Posted by droftarts 
Re: SD Card not working
December 28, 2013 07:51PM
Wolf1130: Sorry you had trouble with your SD card. It is not uncommon... However, we are testing a firmware update that addresses this problem.

What number kit do you have? Below 220? See: [forums.reprap.org]
Otherwise, power the board from the PSU, by putting a jumper on JP9 (5V_EN). This should help your 5V problem.

It sounds like you have a nozzle blockage. See advice I gave here (this thread is about SD cards): [forums.reprap.org]

Ian
RepRapPro tech support

Edited 1 time(s). Last edit at 12/28/2013 08:09PM by droftarts.
Re: SD Card not working
May 03, 2014 10:59AM
Hello,
I having an issue with my Duet reading the SD card I am getting an "Can't open 0:/sys/config.g to read from. Error code: 12
Configuration file not found" error.

I have a red Ormerod I will have to dig out the paper work to see if its below 220

Things I have tried.

1: Updating the firmware to "FIRMWARE_NAME:RepRapFirmware FIRMWARE_VERSION:0.57a ELECTRONICSgrinning smileyuet DATE:2014-01-16"
2: Trying two other SD cards (4gb Kingston, 4gb scandisk) formatted using the SDformatter as recommended
3. I was getting 4.3V on the 5v feed with USB only so I connected the JP9 jumper and using the ATX PSU now getting 4.95V
4. Check the solder joints on the SD card (looks to be ok)
5. Tried putting a peace of card in with the SD card for a better connection.
6. Pressing the reset button shortly after turning the Duet on.

Is there anything else I should try before sending the Duet board back as faulty?

Thanks in advance for any help
Tom
Re: SD Card not working
May 03, 2014 12:25PM
Tombishop85, check the speed of your SD card. The capacity does not matter, its the speed that does. Anything slower than HIGH speed sd card will not work with the duet.



Also, a helpfull link on how to determine the speed of your SD card - SD CARD SPEED CLASS

Edited 1 time(s). Last edit at 05/03/2014 12:26PM by Sardi.
Re: SD Card not working
May 03, 2014 01:40PM
Thanks for this! they're both 4 speed, I will order one today.
Re: SD Card not working
May 03, 2014 02:06PM
The class 4 works fine for me, my problem is a couple of the pins are a fraction low, so I have to wedge something in with the card. (but as you have tried that, it's not your problem)

You have probably read it already, but there is a SD card troubleshooting guide here.


Regards,

Les


Pointy's Things
Pointy's Blog
Re: SD Card not working
August 28, 2014 10:19AM
Hi all,

My ormerod was working with an SD card that I supplied, but it seems that the SD card holder/reader was not soldered down correctly and is now broken. Now even with new firmware and the same card I cannot get config.g to read. The card holder has now been damaged. Where can I get a replacement micro USB reader for my duet board? (I am in South Africa so an RS link or something will be best for me)
Re: SD Card not working
August 28, 2014 11:49AM
Hi, I'm not sure which is the exact replacement but here is a link to some of the adapters at RS. micro sd adapter. (I'm also from SAsmiling bouncing smiley )
Re: SD Card not working
August 29, 2014 04:29AM
Hi tracyb

I thought you had contacted us already, and we sent you a new Duet? But I may be mistaken... If not, send me an email, with your name, address, RS order number and description of the problem, to support@reprappro.com and we'll sort out a replacement.

Ian
RepRapPro tech support
Sorry, only registered users may post in this forum.

Click here to login