Welcome! Log In Create A New Profile


Slic3r Ormerod Woes

Posted by Carnivalius 
Slic3r Ormerod Woes
December 17, 2013 04:13PM

So I've had the problem that using Slic3r I can't get the prints to work. I load the "ormerod.ini" file found in the printer presets listed in the "printing" part of the documenttation, but my prints turn out pants. By that, I mean that it seems to raise the z-axis before printing so it's printing in air (this is despite homing z manually beforehand).

To try and stop all the scrappy lengths of thin plastic as the extruder moves from one line to the next (between extruding), I did try to turn on the retract the feed by 1mm, but it seems to over retract, so that no material comes out for a long while after (this is despite again calibrating the extruder). I didn't know if there was something basic I was missing as I'm finding it frustrating to try to print something as simple as the snowman using my own gcode file (I've attached it).

Edited 1 time(s). Last edit at 12/17/2013 04:16PM by Carnivalius.
Re: Slic3r Ormerod Woes
December 17, 2013 07:21PM
What's an Omerod? (what sort of printer is this?)

The .g file attached to your post does not seem to open.

The first thing the gcode generated by Slic3r likely does is an automatic home X,Y,Z. It then goes to what ever the Z offset you gave in in the config settings.

Does your printer properly home on each axis? (Do your end stop switches work?)

Is your bed level compared to the bottom of your hot end?

Does your Z axis slip?
Re: Slic3r Ormerod Woes
December 17, 2013 07:35PM
First off, the Ormerod is the new printer from RepRapPro. See: [www.reprappro.com]

Second, that gcode file opens just fine. Open it in any text editor.

Third, this topic is best for the Ormerod forum. Moving it there now...

Help improve the RepRap wiki!
Just click "Edit" in the top-right corner of the page and start typing.
Anyone can edit the wiki!
Re: Slic3r Ormerod Woes
December 18, 2013 01:40AM

I have the same problems with slic3r. The print is starting way too high. Though I'm a 3D noob I think one has to check the generated gcode (what I will do next).
I also guess there might be some trouble how pronterface interprets the gcode.


Edited 2 time(s). Last edit at 12/18/2013 02:26AM by markbee.

XBee & electronics blog: [lookmanowire.blogspot.com]
Re: Slic3r Ormerod Woes
December 18, 2013 02:22AM
I posted this yesterday related to X,Y issues and homing, but this is a 'better place'!
I to have the same issues regarding slic3r............

previous post:
Further observations of the 'home' procedure and a problem I experienced.

When I home X it homes reliably to the silver foil on the tab.
When I home Y the plate stops with the extruder nozzle about 5mm or so off the plate edge.

But to home Z, I then need to move X about +55mm to get the sensor centralised with the reflective film and then move Y 10mm to allow the sensor to be over the reflective tape and allow the Z axis to be homed.
The above is not a problem, but can I set this X,Y,Z location as the reference point?

I created my first layer file using slic-3r..... and this has a 'home all axis' command near the beginning:


M104 S185 ; set temperature
G28 ; home all axes
G1 Z5 F5000 ; lift nozzle
M109 S185 ; wait for temperature to be reached

This 'home all axis' command appears to take the head off the plate and tries to home over the z axis drive gears.
It then crashes into the plate and rips the Kapton tape....... sad smiley
Prior to this, I had the nozzle nicely set at a good X,Y point and had set the Z axis.
Should I remove 'home' commands?

I have not yet examined the lift nozzle G code, but that did not do enough, the temperatures were all up to the set point at this stage so there was not any follow up 'wait for temperature'.

I think this has been mentioned elsewhere, but the sensor position does not have to be the 'home' position (as is nicely demonstrated by the X axis), so would it not be better if home all axis, raised Z a fixed amount, moved to the X sensor and then centralised itself in line with the foil area which then becomes Home X.
Similarly Y goes to its sensor and then positions itself over the foil for the Home Y location.
Finally Z is homed which is now safely over the foil.
This sequence would make 'home all axis' work safely, rather than what appears to happen.

If I have missed a setting in PronterFace or the Slic3r program please let me know.

EDIT just to confirm there is also an error with the extruder feed which does some large 'reverses'! This results in it trying to build the whole model with the same 30mm of PLA!!!
I got round the home and height problems by manually editing out two lines:
;G28 ; home all axes
;G1 Z5 F5000 ; lift nozzle

At least it try to position after this.
Now to look at the feed issue.......

Edited 1 time(s). Last edit at 12/18/2013 03:49AM by Treth.
Re: Slic3r Ormerod Woes
December 18, 2013 09:41AM
Haven't had much time to progress, but on the printer settings you can disable the 'home' code or insert your own:

I could not get the advanced mode to turn on.

Also as a warning where you select the "G code flavor" the mouse wheel keeps this active and toggles through the options, i.e. you cant click to deactivate the selection, so if you twist the wheel even with the '...... flavor' off screen you may select something else!
Re: Slic3r Ormerod Woes
December 18, 2013 10:35AM
I think it will help to use our profiles; Adrian has written these so the start gcode is correct. I think you are using the Slic3r defaults, which may give poor results.

To use our profiles with Slic3r, the contents of the 'Slic3r-settings' folder that is in our github repository here [github.com] needs to replace the contents of the default Slic3r profiles folder. The location of this folder depends on which operating system you are using.

You need to run Slic3r once, so it creates the 'Slic3r' folder that holds the profiles.

On Windows 7/8, the profiles are stored in folders under c:\Users\{username}\AppData\Roaming\Slic3r

On Ubuntu, the profiles are stored in an invisible .Slic3r folder, in /home/{User}/.Slic3r

On Mac, the profiles are stored in /Users/{username}/Library/Application Support/Slic3r
This is a hidden folder, but you can get to it by going to the main menu option 'Go' then 'Go to Folder...' and typing '~/Library/Application Support/'

After replacing these files, when you open Slic3r the next time, there should be three 'Ormerod-0.5' (for Print settings, Filament and Printer) options at the bottom of the Slic3r application window.

Then slicing should generate more 'Ormerod-friendly' gcode.

If people could let me know if this works for them, I'll update the instructions. Also, if anyone can find where the folder is on Windows XP, let me know! It may be the same as Windows 7, but I'm not sure, and don't have a Windows XP PC or virtual machine to try it on.

(For our Huxley and Mendel printers, we use Pronterface to define the folder that Slic3r is to use for profiles, but we can't do that with the Ormerod, as most people will slice a model in Slic3r, copy it to SD Card, and send it to print via the web interface, so not use Pronterface.)

RepRapPro tech support
Re: Slic3r Ormerod Woes
December 18, 2013 11:27AM
Unfortunately I have to stop now, but on my Windows 7 system I do not seem to be able to find

On Windows 7/8, the profiles are stored in folders under c:\Users\{username}\AppData\Roaming\Slic3r
I have hidden folder set to visible, but still cannot find it.

I'll try again later, but thanks Ian, I'm sure this will solve this issue.
Re: Slic3r Ormerod Woes
December 18, 2013 03:32PM
That is incredibly helpful! I didn't know where to load the settings (last time I checked the build documents didn't say where), so assumed it was a case of inport in the slic3r menu. I now have ormerod-0.5 settings in slic3r. I shall attempt to make a print and report back!
Re: Slic3r Ormerod Woes
December 18, 2013 03:38PM

What operating system are you on? Was the folder where I said it would be? Anything else special you had to do?
If anyone else replying to this could do the same, that would be ace.

RepRapPro tech support
Re: Slic3r Ormerod Woes
December 18, 2013 03:49PM
The first print I gave still had the issues of homing the Z axis too high then printing in air.

I have since changed my setbed.g to only contain the bed and axis corrections (it did have extruder correction and z height in there), it seems more stable now, but I did have to manually adjust the z height down after it printed slightly too high still.

Edited 1 time(s). Last edit at 12/18/2013 04:02PM by Carnivalius.
Re: Slic3r Ormerod Woes
December 18, 2013 03:53PM
Does it home too high - which would be a problem with homing - or does it home the correct height, then move upwards - which is a slicing problem, as others have reported?
It may be homing Z in the wrong place.

RepRapPro tech support

Edited 1 time(s). Last edit at 12/18/2013 03:53PM by droftarts.
Re: Slic3r Ormerod Woes
December 18, 2013 04:12PM
I homed it first, then as I print it starts printing about 5-10 mm above the bed. So I then rehomed it manually with a paper sheet, it still printed about 0.3mm high and G92 Z0 wouldn't zero it lower than that (ie it always read that value whichever value of z I was at), so I lowered it 0.3 and rehomed, so it would be at the correct height. It's now printing fine.
Re: Slic3r Ormerod Woes
December 18, 2013 04:25PM
See my earlier posts.
I believe Slic3r is wrongly inserting into the g-code
G1 Z5 F5000 ; lift nozzle
which is causing the problem.
I manually commented this and the home out of the code and it appears to plot from my home settings, but it look as if it can just be deleted for future g-codebuilds?

I still get problems with extruder feed 'reversing' and then there is no material to print!

BUT I haven't got the correct configuration set up yet as detailed by Ian. WIP.
Re: Slic3r Ormerod Woes
December 18, 2013 05:36PM
I've tried it a second time and it now seems to work. I think getting the Ormerod settings into Slic3r helps to solve a lot of these issues. I'm now testing it with support material as the only change to basic settings.
Re: Slic3r Ormerod Woes
December 18, 2013 05:50PM
What operating system are you on? Was the folder where I said it would be? Anything else special you had to do?

I'm on Windows 7 and I just had to show the hidden folders (under the view tab of "Folder and Search options") in order to get into AppData, I deleted the contents and replaced it with the one from the github link. When I then loaded Slic3r it had "ormerod-0.5" listed instead of "my printer" (I think?) as it had said before. So far the prints seem a lot better

The old print that I was able to muddle through with Slic3r is on the right (it needed plenty of plastic whiskers removing) and the new one is on the left (no changes)
Sorry, only registered users may post in this forum.

Click here to login