Welcome! Log In Create A New Profile


Cant reload firmware

Posted by MikeL 
Cant reload firmware
December 18, 2013 01:40AM
Hi Folks
I am having trouble commissioning my Ormerod.
I have installed the driver (COM6) and can run Pronterface, but when I try to connect (USB cable and SD card fitted) I only get "Connecting..."
I can run Arduino 1.5.5 and connect to COM6, but get no response when I send M305 or the like.
What I have read seems to indicate that I have lost the built in firmware, so I tried to use bossac to reload. The command screen response was ...
C:\ReprapPro>bossac --port=COM6 -U true -e -w -v -b RepRapFirmware.bin -R
No device found on COM6

Both bossac.exe and RepRapFirmware.bin are in the same folder.

I.m not sure how to proceed from here and would welcome any advice form the forum.

Mike Leggett

Edited 1 time(s). Last edit at 12/18/2013 01:41AM by MikeL.
Re: Cant reload firmware
December 18, 2013 01:44AM
Hi Mike,

did you double ckeck you are really on COM6?

Also verify you are using M503 for reading the sd card.

If you are flashing be sure that RepRapFirmware.bin is in the same folder where you started bossac or the path to it is correct.


XBee & electronics blog: [lookmanowire.blogspot.com]
Re: Cant reload firmware
December 18, 2013 02:28AM
did you double ckeck you are really on COM6?

Yes this is the most likely issue. I found my PC moved the Ormerod around between Com3 and com5 apparently randomly, but I think it was after a reset or unplugging the Ormerod which will do this.
There is a PC 'fix' that stops the PC reassigning com ports, but I need to search that out.
Re: Cant reload firmware
December 18, 2013 08:52AM
also, when you erase and reset, the duet appears as a bossa port (not a due anymore) - on my (xp) machine, I right click "my computer" choose "manage" tehn select device manager-> ports to check which COM port has been allocated this time around. After the flash is successful, it reappears as a due, generally on the port it had before the reset.

I downloaded bossa [sourceforge.net] earlier for my mac (to save having to fire up the pc for flashing, and because I hate command lines), but it couldn't find the port - next time I need to flash I'll try installing bossa on the pc and feed back how it goes - anyone had experience of it ? (bossac as used in Arduino IDE is the command line interface part of the bossa package)

Re: Cant reload firmware
December 18, 2013 05:50PM
Thanks for the replies.
I have confirmed COM6 (though I did see the driver allocated to COM7 very early on), and that RepRapFirmware.bin is in the same folder where I started bossac.
Yes - I should have said M503 was the code sent via Arduino.
I should also mention that any time I try to download Arduino 1.5.5 I only get 512kb of the specified 66.3Mb download. So I installed Arduino 1.0.5 and then copied the 1.5.5 files over the top - not sure how kosher that is but it appears to work.
It appears that while Pronterface and Arduino are happy with my COM6 allocation, there is no response from the Duet board or no data is being sent.

I read somewhere that when the RESET button is pressed and released, one of the LEDs should flash to indicate the presence of firmware - that doesn't happen.
There Ethernet port has only the green LED flickering. The orange LED stays off at all times.

Thanks again for your assistance.
Re: Cant reload firmware
December 18, 2013 07:45PM
Got it going!

Turns out that when the erase button is pressed, the USB port reverts to COM7 (on my PC).
I ran bossac through COM7 and had successful upload. When the CPU auto resets, the port changes back to COM6.

I can now communicate through Pronterface and Arduino.
Now to complete commissioning.

Thanks very much for your help.

Sorry, only registered users may post in this forum.

Click here to login