Welcome! Log In Create A New Profile


Motors not running

Posted by chriscain 
Motors not running
December 18, 2013 02:43PM
Have completed the build Ormeron #261
All seemed to go well, was impressed by the quality of the printed parts in the kit.

Conected to USB/Power/network and all looked good
Flash card would not read in Ormerod and looked blank on a PC

Downloaded latest firmware 040-17-12-2013
Successfully updated Duet, created a new SD Card by formatting a new one and copying the contents of
SD-Image to it.

Updated the config.g just to change the IP Address.

Web interface works, pronterface works over USB, can list the contents of the SD-CARD
Bed + Hot end heater + thermistors work.

BUT NONE of the steppers work.
They are not even 'energising' when power is turned on, just remain the same as with no power
move commands from the web interface or pronterface nothing happens.

Double checked all the positions of the motor cables to the duet
checked PSU input 12.1 volts

As all 4 (x,y,z and extruder) are acting the same I am guessing it is something dumb I have done or not done
but cannot work out what !

Any ideas why none of the steppers would work ?

Re: Motors not running
December 18, 2013 05:11PM
Hi Chris,

Does the fan come on when you power up the atx? Do the heaters work? All of these rely on the 12V , and might help reprap diagnose quicker.
Just in case- might be worth checking you have negative coming in on the upper cable and positive on the lower one (dum b suggestion but cheap to check)

Re: Motors not running
December 18, 2013 07:20PM
Fan works, - and is running correct direction.
heaters (both bed and hot end) work

12 volts is good and correct way round

Limit light on X limit works
Z height detector works and gives good readings (moving the Z axis by hand)

In fact everything seems to be working fine, except the motors are not powered !!

Re: Motors not running
December 18, 2013 09:28PM
Hi Chriscain

If you touch the stepper driver chips (the four chips nearest the four motor connections), are they warm/hot?
Are you sure the motor connectors are on the correct pins?
It would be odd that all 4 fail at once.

RepRapPro tech support
Re: Motors not running
December 19, 2013 06:54AM
None of the chips are even warm
Cables are connected as per the diagram in the instructions

Seems very strange that all would be dead, and there is not a lot common between them
I have checked the voltage at the vref (stepper current set points) and it is 0.5 volts which
seems correct to set the 800ma stepper drive current, checked this as the main common point
for the 4 steppers was the reference current set electronic pot.

Will trace through one of the drivers and work out where it is failing
because it was all 4 I thought there may have been some software button I didn't press
or similar thing but it sounds like this is not the case.

Re: Motors not running - solved
December 19, 2013 08:28AM
Dis-connected everything except the extruder drive stepper
and started checking the voltages around the extruder stepper chip

The only questionable one was that the 3.3 volts was low - only 2.9 volts

Bridged JP9 to use the on board regulator instead of the USB voltage to drive it
and the extruder motor started to run :-)

Reconected everything, all working fine.

A bit of investigation it looks like my USB Hub is not providing a full 5V out on the USB
and the reduced voltage was just enough to drive everything except the stepper driver chips.

Connecting it direct to the PC without the hub and it all works with or without JP9

So happy, and off to do the commissioning next.

Re: Motors not running
December 19, 2013 08:41AM
chriscain - excellent! Good diagnosis skills. Glad you were able to get it working. Was the hub independently powered from the mains, or was it powered from the computer USB port? We've found if they are not powered from the mains, the voltage can be on the low side.

3 different voltages are used on the board: 12V for motors, fans and heaters, 5V is used to drive the MOSFETs, and most other parts (ARM chip, thermistors, stepper drivers, proximity sensor, SD card, USB, Ethernet) run at 3.3V.

I have moved some of the documentation around, so you have probably already done most of the Commissioning page.

RepRapPro tech support
Re: Motors not running
December 19, 2013 01:51PM
The hub was powered from the PC, always been ok with stuff so far but only used for mice/keyboard etc so not much of a challenge.

Interestingly the web/network interface also seemed a bit intermittent before I swapped over and is now 100% so I guess the voltage was right on the edge of being able to run even the network or CPU on the board.

All now working well and it is just in the process of printing the test axis set which is about half complete and looks very good so far.

Re: Motors not running
December 20, 2013 03:16PM
Hmm... that's interesting. I wonder if the network and SD card problems some people are reporting may be because they are running from USB power only, and they aren't getting enough from the attached USB device.

RepRapPro tech support
Re: Motors not running
December 20, 2013 03:52PM
Hmm... [forums.reprap.org] it's almost certain that if the 5V in is less than 5V, that the +5V net will be too low to allow the 3.3V regulator to provide the full 3.3V (the dropout of 1.2 at 800mA is for a bigger beast than the one used on the board I think) . The diodes that isolate the USB and the ATX 5V in both drop more than half a volt, making the net be 4.45 at best (if the USB is 5.0) - if the USB is say 4.55, then the +5V net will be 4.00, and even under low load, the 3.3V regulator would be pushed to provide it's promised 3.3 from that input. The only input that doesn't have a protection diode separating it from the +5V net is the switch mode that's enabled using jumper 9 - so it's the only way of having the +5V net actually be 5V.

I'll have a go at checking whether the ethernet connection on my t3p3 duet disappears when I run just off usb asap (but not tonight!smiling smiley)


Re: Motors not running
December 20, 2013 03:52PM
I had not thought about the SD card problems.

My SD card did not work and I swapped it for a different one that did, I will retry the orig now I have fixed the PSU issue and see if it works.
It could be that the cards supplied have less of a voltage tolerance than some other brands and hence the problems being seen.

Re: Motors not running
December 20, 2013 04:12PM
Thanks guys. Solving this issue would be great!
It's possibly why we haven't seen this issue in-house; I use a desktop system when connecting to Duet boards by USB only, which probably has more consistent voltage than other sources. Other test boards are hooked up to ATX power, so voltage is supplied by the 5V regulator.

Please let me know if this helps!
*crosses fingers*

RepRapPro tech support
Re: Motors not running
December 21, 2013 09:48AM
No, unfortunately not.

At least in my case the SD card issue is NOT related to low voltage.
However Steppers not running correctly, and Network connection are.

I connected a variable 5V PSU instead of the USB Power to test more accurately.
The 3.3 volt supply is generated from the 5 volt supply (either on board or UScool smiley via a LM1117 Low drop out regulator
drop out for this regulator is about 1 volt. So needs at least 4.3 volts in on the USB... but there is a protection Diode in
series on the USB Supply, this takes about 0.4 volt.
So expectations are if the USB Supply is < 4.7 volts the 3.3 volt supply will start to drop.

Testing with the variable PSU it does exactly as expected,
In Volts 3.3 Reg
5.0 3.32
4.8 3.32
4.7 3.31
4.5 3.23
4.4 3.12
4.2 2.95

So what breaks when the 3.3 volt supply drops !
on my board the Stepper motors stop turning at 2.95 volts (USB input voltage 4.2)

Network still pings, USB Still talks to the CPU but the web page only works about 1 time in 3 refreshes

at 2.8 volts (USB Voltage 4.0) the network stops working at all (no pings, or web, prontiface is still happily talking to the printer
and the new SD card i put in (Transend 2GB card) still works fine.

The supplied unbranded SD card works fine in my PC but will not read at all in the Duet
even with full 5volts on the USB or when running from the 5volt buck regulator (I have a > #220 Duet with the 5v reg working).

This even after a full reformat on the PC using the SD Card standards formatter with a full erase.

Maybe the Duet is trying to run the card too fast ?
I suspect that the Duet SD card code just "assumes" all SD cards can run at say 4MHZ clock
without actually reading the params and finding out these can't.

Re: Motors not running
December 21, 2013 01:20PM
My SD card problem (failing to run config.g at power on) did not appear to be related to low voltage either. I measured 4.97V on the 5V rail.
Sorry, only registered users may post in this forum.

Click here to login