Network problem after Firmware update
January 09, 2014 04:46AM
Hi guys,

Yesterday I picked up a new board (my USB connector was broken) from RepRap and met with Ian. It was very interesting and I would like to thank Ian for his time.
I wired the new board in and for the first time managed to connect via the ethernet, great!
After checking the Firmware version (dating mid-december) I decided to update the firmware to the latest version (06/01);

Now I cannot connect via Ethernet anymore;

It turns out that the SD card is not read as I get the default IP 192.168.1.10 rather than what is on the SD card (192.168.0.14);
HOWEVER the SD card is working because when I query the config file from Pronterface (via UScool smiley I can clearly see that the I have the correct config.g settings (and indeed 192.168.0.14);

Despite all this the Ethernet connection identifies itself with the default IP 192.168.1.10;

Any idea?
Re: Network problem after Firmware update
January 09, 2014 04:54AM
Note that I reflashed with Firmware from 23/12 and it is doing the same.
I am pretty sure the Firmware version that was on the replacement board was even older, perhaps 14/12?
Where can I find older versions of the Firmware to see if I can get Ethernet working again?

Ian are you able to check the Firmware version in the boards you had by your desk in the cardboard box?
Re: Network problem after Firmware update
January 09, 2014 05:36AM
Lots of us have this problem when using the original SD card supplied with the kit. So I suggest you get another SD card. A 4Gb Class 10 SDHC card from Maplin solved it for me.



Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Network problem after Firmware update
January 09, 2014 05:53AM
no it is not an SD card problem, I have long binned the supplied SD card and replaced with a good SD card. Have also tried other SD cards.

this is a new problem for me.

previously with my old board the (same) SD card was working fine. I could change the IP address at will and the router would see the changes.

so I would say the SD card is fine. the new board worked for a few moments with old firmware and now is doesn't anymore.

i think the duet design (HW, SW or both) is just unfit for purpose, that is all.
Re: Network problem after Firmware update
January 09, 2014 05:58AM
Have you tried using the serial monitor to reset the IP address to the one you want, and then connecting via Ethernet? I appreciate this isn't a fix, but it might reveal something.

Also, do you get the same problem both at power-up and after pressing the reset button?

Edited 1 time(s). Last edit at 01/09/2014 05:59AM by dc42.



Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Network problem after Firmware update
January 09, 2014 06:05AM
yes power up or reset
have not tried using the serial monitor to change IP, will try
Re: Network problem after Firmware update
January 09, 2014 06:22AM
now it works again, until next time it doesn't
don't ask me why...

let us know when you get your way dc42 with your firmware proposal, it may bring some much needed stability.

and with some luck the fan won't get on my nerves so much when I troubleshoot!!!
Re: Network problem after Firmware update
January 09, 2014 06:36AM
on the plus side, if anyone is interested, I have also tried, successfully, to run the duet on Ethernet using this:

[www.amazon.co.uk]

that I bought originally for my dvd player;

I do not know how stable it is compared to a normal LAN so don't go buying one just yet, I will report on reliablity soon, it is however handy if you don't like wires everywhere;
Re: Network problem after Firmware update
January 09, 2014 06:44AM
Hi arnaud31, sorry you're having problems. Nothing much has changed in the networking part of the firmware, so I would tend not to think it's a firmware issue (I appreciate that's a very broad statement!)

Try powering on, then resetting. This 'usually' reliably kicks the SD card into life, and load config.g. I can't remember if I did that with the card yesterday, but I might have. I might also have got muddled up with the Duets I had on my desk, and given you a returned card! Sorry...

Ian
RepRapPro tech support
Re: Network problem after Firmware update
January 09, 2014 06:55AM
Hello arnaud31

Quote
arnaud31
on the plus side, if anyone is interested, I have also tried, successfully, to run the duet on Ethernet using this:

[www.amazon.co.uk]

that I bought originally for my dvd player;

I do not know how stable it is compared to a normal LAN so don't go buying one just yet, I will report on reliablity soon, it is however handy if you don't like wires everywhere;

You may want to be carful of those due to they create loads of noise over the mains and may cause issues with the printer.
This also add loads of noise to the Amateur radio band as we found out, so be aware.

Paul.


RS Ormerod No 436
Sorry, only registered users may post in this forum.

Click here to login