Connection problem
June 08, 2014 02:49PM

There is a problem, and I have suffered severe by finding out what is wrong.
I was starting a print from remot, (I was not near my printer) I used DC software 059e I think and web interface.
After a while, I was looking to the printer, but It was stopped after heating up sad smiley
The webinterface was still online, but temperature was not updated. It was possible to send command to the printer (move x and y axis).
So I removed power and connected it again.
I write the ip adresss of the printer, and I only see a blank white screen sad smiley
I checked network connection, but all was okay, then I upgraded to version 065e and webinterface 0.90.
Now I cannot connect at all.
I try to connect using pronterface, but I cannot connect, but when I start it write:

RepRapFirmware is up and running.
T:2000.0 B:2639.4
T:147.1 B:97.6
Starting network
Network up, IP=
T:147.0 B:97.6
T:147.1 B:97.6
T:147.2 B:97.5
T:147.2 B:97.5
T:147.2 B:97.5

But my IP adress is set in the config.g to

What is wrong ?

Re: Connection problem
June 08, 2014 03:29PM
It sounds like your settings are not being read from config.g at startup. This explains why the IP address is wrong, and why Pronterface can't connect. Things to try:

* Are you still using the original SD card? If so, ditch it and get a better one.

* After power up, press the reset button. Then see if you can connect. This sometimes works if the SD card is marginal.

* Check whether you can read the SD card and config.g if you remove the SD card from the Duet and plug it into the PC.

* Connect using Arduino serial monitor, send M503 and see what comes back. This will show whether the Duet can read the SD card at all.

* Connect using Arduino serial monitor and send the same M552 and M555 commands as found in config.g. Then either disconnect Arduino monitor and connect using Pronterface, or press reset and connect using the web interface (this bit will only work if you are using dc42 firmware, which stores the IP address in flash memory).

Large delta printer [], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [].
Re: Connection problem
June 08, 2014 04:11PM
Thanks for help - David. And I appreciate all of your changes smiling smiley

* No it's not the original card. I am using a SanDisk 8GB card, and it has worked until now.
* I have tried 3 other SD card, but all report in Arduino serial monitor : Can't open 0:/sys/config.g to read from. Error code: 3 Configuration file not found.
* All card works fine in my PC
* I set the IP address from Auduino using M552-M555, and now I can connect with Pronterface smiling smiley
* I can now again see the white page, when I connect with WebInterface, I think it because it did not read the html files from SD card.

I will try some other sd cards.
Can it be the SD card HW interface? Or is it the SW?
Are there any way to debug, to see about it is HW or SW problem ?


Re: Connection problem
June 08, 2014 04:20PM
Hi Per,

It sounds to me that you have a hardware problem with the SD card reader on the Duet. I don't think you are the first, I've seen other posts reporting similar. AFAIR, one user has to wedge a piece of paper in with the SD card to get good connections. You could check that the soldered connections (including the ground connections) between the SD card socket and the Duet PCB look OK.

I presume you are using 0.65e-dc42 firmware, in which case I guess you should retry with RRP 0.65e firmware, and if the problem persists, request a warranty replacement Duet from RRP. Note that my 0.90 web interface will not work with RRP 0.65e, so either use their version of reprap.htm (which loads all the other files it needs from the Internet), or Pronterface.

Edited 3 time(s). Last edit at 06/08/2014 04:23PM by dc42.

Large delta printer [], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [].
Re: Connection problem
June 12, 2014 04:09AM
Thanks smiling smiley

I have now tried with RRP firmware 0.65e and still can not read my SD card.
I also tried with 2 other SD cards and still can not read, so it's probably the HW interface.

I will ask RRP for a warranty replacement.

Thanks for helping

Sorry, only registered users may post in this forum.

Click here to login