Welcome! Log In Create A New Profile


problem with Z probe after firmware update

Posted by Tailzer 
problem with Z probe after firmware update
May 15, 2015 01:49PM
I seem to have developed a problem with the Z sensor after I upgraded the firmware. Been away from the printer for a while so decided it was time to upgrade. Upgraded to 1.09 as I wasnt sure if DC42's was only for his Zprobe and I'm still on the original. Flashed ok, got caught by the sending T0 first problem but sorted after reading the forum a bit. Had a couple problems doing the X home as it would start from wherever the hot was left and go positive to end stops. finally got it to X0 and then started on the Z (after a Y home). Thought I'd try and get a really level bed this time round rather than keep compensating for it. Ran the Z probe readings and I get high 800's even when 20/30mm off the bed. Tried with lights out in case Im getting too much ambient IR from the strip lights in the office but all the same. it does go higher when close to the bed but never really goes lower than 800.
Any ideas? Could I have broken something in the inbetween time and the firmware just is a red herring?
Thanks as always!
Re: problem with Z probe after firmware update
May 15, 2015 03:07PM
The input pin on the Duet board that the Z-probe connects to was changed quite a while ago - maybe you still have it connected to the original pin? The later firmware requires the probe to be connected to the 6th pin from the right rather than the 9th pin from the right as was the case previously. See [reprappro.com]

DC42's firmware supports all probe types, so you can safely use it with the original probe - however the probe type and a few other things will need to be set in your config file, so download the sample config and homing files and use a text editor to modify them to suit your printer (the same is true when upgrading to the latest RRP firmware).

Re: problem with Z probe after firmware update
May 17, 2015 01:09PM
Ah thank you. That has to be it. I'll check as soon as I'm in work but hasn't changed any wiring since I built a year ago, bit of RTFM on my part.

Will upgrade to DC42s firmware now then as well. Going to order the ally bed support as well to try and get a more even base setting.

Thanks for the speedy response.

Re: problem with Z probe after firmware update
May 18, 2015 06:32PM
Yep worked perfectly once I moved the pin.
Sorry, only registered users may post in this forum.

Click here to login