Welcome! Log In Create A New Profile

Advanced

Random temperature spikes

Posted by goature 
Random temperature spikes
July 20, 2015 04:16AM
Hello all!

My RepRapPro Ormerod has been giving me some strange temperature spikes on the hot end temperature measurement. Here are some notes about the problem:
  • The spikes seem to appear randomly
  • I've tried changing the thermistor
  • I've tried wiggeling the wires, to see if there is a short/open-circuit somewhere
  • I've updated the firmware, same thing happens
I've attached a picture of a spike.

How do you think i can solve this problem? Thank you! smiling smiley

Edit: The spikes appear even if the hot-end has been standing still for a while.

Edited 2 time(s). Last edit at 07/20/2015 05:22AM by goature.
Attachments:
open | download - Spikes.png (7.3 KB)
Re: Random temperature spikes
July 20, 2015 06:23AM
also to mee it look a termistor fail but you have do all the check...

Edited 2 time(s). Last edit at 07/20/2015 06:25AM by Zonzo.
Re: Random temperature spikes
July 20, 2015 06:26AM
the connection to the duet is ok?
Re: Random temperature spikes
July 20, 2015 06:35AM
Positive going temperature spikes suggest a short, either between the thermistor wires, or between a thermistor wire and ground. If it is an Ormerod 2, it could also be caused by the back of the Duet shorting against the metal enclosure.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Random temperature spikes
July 20, 2015 08:38AM
I changed the whole hot-end loom. I have yet to see a spike. I'll keep you updated thumbs up. Might have been a short in the cable, as you said dc42.

Edited 3 time(s). Last edit at 07/20/2015 12:34PM by goature.
Re: Random temperature spikes
July 20, 2015 12:35PM
It happened again, even after changing the wire loom. Might there be something wrong with the board?

Edited 1 time(s). Last edit at 07/20/2015 12:35PM by goature.
Attachments:
open | download - Capture.PNG (12.1 KB)
Re: Random temperature spikes
July 20, 2015 01:08PM
Quote
goature
It happened again, even after changing the wire loom. Might there be something wrong with the board?

Did you check this bit from my previous reply:

Quote
dc42
If it is an Ormerod 2, it could also be caused by the back of the Duet shorting against the metal enclosure.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Random temperature spikes
July 20, 2015 01:18PM
Quote
dc42
Did you check this bit from my previous reply:

Oh! I forgot to say, it's a Ormerod 1. It has the acrylic enclosure.

Edited 1 time(s). Last edit at 07/20/2015 01:19PM by goature.
Re: Random temperature spikes
July 20, 2015 04:13PM
Changed the duet. Seems to work fine again. Gonna have to study the old board. I think the A/D-Converter in the uC might be having some trouble.

Edited 2 time(s). Last edit at 07/20/2015 04:14PM by goature.
Sorry, only registered users may post in this forum.

Click here to login