Welcome! Log In Create A New Profile


Hot End Troubles

Posted by parper101 
Hot End Troubles
November 23, 2015 05:09AM
Hi Folks,

I'm finally getting back to attempting to get my Omerod 1 printer back online after numerous frustrating setbacks involving sending the board back to England after troubleshooting (with support) a board fault to find out it was totally fine, bought a new motor, and in the end found a dodgy connector on the Y wiring loom which was throwing intermittent errors. Now that (i thought) I had everything squared away, my Hot End no longer works as of today.. worked fine 2 weeks ago. Nothing, nada. Things i've tried:

  • checking the hot end thermistor, result: within normal values
  • checking the hot end thermistor wiring loom: same as above
  • updating the firmware (had the latest, but thought i'd try), re-flashed the board, dowloaded all software new, result: no change
  • putting a 100k resistor directly on the board via jumper cables, result: no reading, similar to output below (tested the leads, and multiple resistors that read 100k away from the board)

Additionally, if this helps, Pronterface seems to not display a result when sending an M105. The graph doesn't graph even the hot bed temperature, even though it displays in the bottom left corner. The only thing that graphs are the 'target' temperatures of both the Hot End and the Bed. The output there is always some variation of: T: B:30.4 H0:30.4/-273.1 H1:22.8/-273.0. I can set the temperature of the bed through Pronterface, but it can't seem to graph it. I'm not sure if that's related or not. The heated bed does get to temperature, and is accurate, just doesn't seem to get through to Pronterface. To complicate the matter the Arduino Serial Port reports M105 reports the same (T: B:30.4 H0:30.4/-273.1 H1:22.8/-273.0)

Finally, SENDING:M563 P0 D0 H1 returns: 'Tool number 0 already in use!'

When trying to set the hot end temperature in Pronterface, i get:

Setting hotend temperature to 200.000000 degrees Celsius.
Setting temperature: no tool selected.

...and it doesn't turn on. I've tried resetting what i assumed was a fault via the troubleshooting guide
‘M562 P1’ then ‘T1’ to reset a hot end temperature fault
with M562 but no change :


Setting temperature: no tool selected.
Setting bed temperature to 0.000000 degrees Celsius.
>>> M562 P1 T1
Setting hotend temperature to 200.000000 degrees Celsius.
Setting temperature: no tool selected.
>>> M562 P1

Anyone have any thoughts after that rant?

Thanks kindly,

Green Machine - slowly becoming multicoulored!
Re: Hot End Troubles
November 23, 2015 07:46AM
Try to send T0 instead of T1. If that doesn't help, please post your config file here.
Re: Hot End Troubles
November 24, 2015 07:11AM
Try to send T0 instead of T1. If that doesn't help, please post your config file here.

Hi Chrishamm....

Thanks for the help! That has fixed the hot end heater temperature, it now heats up fine, but still hasn't fixed the temperature not reading correctly. I'm concerned it will never shut off if I let it go. M105 in Pronterface gives no reaction, and the 'watch temp' graph shows no change. M105 in Ardruino still gives: "ok T: B:35.2 H0:35.2/0.0 H1:22.8/-273.0".

My current Config file more-or-less straight out of the box:


; Configuration file for RepRap Ormerod 1

; RepRapPro Ltd
; Copy this file to config.g if you have an Ormerod 1

; If you are updating a config.g that you already have you
; may wish to go through it and this file checking what you

; want to keep from your old file.

; For G-code definitions, see [reprap.org]

M111 S0 ; Debug off

M550 PMy RepRapPro Ormerod 1 ; Machine name (can be anything you like). With DHCP enabled connect to (example) [reprapproormerod1] (machine name with no spaces).

M551 Preprap ; Machine password (currently not used)

M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address

M552 P0.0.0.0 ; Un-comment for DHCP

;M552 P192.168.1.14 ; IP address, comment for DHCP

;M553 P255.255.255.0 ; Netmask

;M554 P192.168.1.1 ; Gateway, comment for DHCP

M555 P2 ; Set output to look like Marlin

G21 ; Work in millimetres

G90 ; Send absolute corrdinates...

M83 ; ...but relative extruder moves

M906 X800 Y1000 Z800 E800 ; Set motor currents (mA)

M305 P0 R4700 ; Set the heated bed thermistor series resistor to 4K7

M305 P1 R4700 ; Set the hot end thermistor series resistor to 4K7

M569 P0 S1 ; Set X axis direction

M92 E420 ; Set extruder steps per mm

M558 P1 ; Use an unmodulated Z probe (change to P2 if you update to the modulated probe)

G31 Z0.8 P600 ; Set the probe height and threshold (deliberately too high to avoid bed crashes on initial setup)

M556 S75 X0 Y0 Z0 ; Put your axis compensation here

M201 X500 Y500 Z15 E500 ; Accelerations (mm/s^2)

M203 X15000 Y15000 Z100 E3600 ; Maximum speeds (mm/min)

M566 X200 Y200 Z30 E20 ; Minimum speeds mm/minute

M563 P0 D0 H1 ; Define tool 0

G10 P0 S-273 R-273 ; Set tool 0 operating and standby temperatures

;M563 P1 D1 H2 ; Define tool 1 Uncomment if you have a dual colour upgrade

;G10 P1 X19 S-273 R-273 ; Set tool 1 operating and standby temperatures Uncomment if you have a dual colour upgrade


Thanks again!

Green Machine - slowly becoming multicoulored!
Re: Hot End Troubles
November 25, 2015 07:37AM
Be aware that your tool change macro (in particular tpost0.g) blocks all other codes while heating up the hot end if it contains an M116 code (which is a default setting AFAIR). If you have a single-nozzle printer, then you can remove this code from your tool change macro file, but in turn you will probably have to add an extra M116 code to your start G-code in your slicer to make the printer wait for the temperature to be reached before it actually starts printing. You can shut down all heaters once the print has finished by adding M0 to your end G-code in your slicer program.
Re: Hot End Troubles (resolved)smileys with beer
November 30, 2015 04:04AM
Hi All,

Thanks so much! After a few tries, the M116 code worked a treat! Now i have to remember to put M116 in slicer and all's good! This is an odd default if I may say so.

Thanks again all,

Green Machine - slowly becoming multicoulored!
Sorry, only registered users may post in this forum.

Click here to login