Welcome! Log In Create A New Profile


Octopi on Duet - issue heating hot end

Posted by PaulHam 
Octopi on Duet - issue heating hot end
July 22, 2020 07:52AM
Hi guys,

Its been a while since I have used my Ormerod due to the LAN chip failing on the duet board, I have decided to get Ormerod working again and rather than replacing the duet board I have decided to go down the Octopi route.

I have set it up and XYZ controls work however I have an issue with commanding the hot end to active at any temperature. heated bed and hot end standby temps are fine.

I know Duet firmware is old but it worked last time I used it
FIRMWARE_NAME: RepRapFirmware for Duet FIRMWARE_VERSION: 1.12 ELECTRONICS: Duet 0.6 DATE: 2016-05-07

If I send M104 S210 ; set temperature
the new temp displays on my LCD screen as active however it doesn't heat, the only way to get it to heat is to set the standby temp high, this will start heating immediately.
It sounds like i am missing a vital gcode to tell the printer to enable heating to active temps.

Does the RepRap firmware work differently to marlin when setting active temps?

Any help/ideas appreciated.
Re: Octopi on Duet - issue heating hot end
July 22, 2020 08:09AM
Just to add, I sliced an STL using slic3r then tried to print using Octop, it fails to heat the hot end but does start 'printing', the hot end doesnt get hot and the extruder drive doesnt move

I used pronterface to print the same file and it works as expected, hot end is hot and extruder drive is moving.
Sorry, only registered users may post in this forum.

Click here to login