Gen7-Elektronik
February 16, 2011 09:22AM
Heya,

ich habe mir nun die Dateien vom Wiki für die Gen7-Elektronik runter geladen (danke Traumpflug). Nur ich kann die nicht öffnen (hab nur Eagle) und gsch2pcb kann ist momentan nur unter Linux richtig verfügbar, soweit ich das sehe.

Gibt es eine Möglichkeit, das ganze unter Windows zu öffnen/anzuschauen und welcher Hersteller kann solch ein Format lesen, um eine Platine daras zu machen.

Mit dank für Antworten,
Gabriel

Edited 1 time(s). Last edit at 02/16/2011 09:22AM by Arcangel.
Re: Gen7-Elektronik
February 16, 2011 10:43AM
Zunächst einmal gibt es einen Windows-Build: [www2.eng.cam.ac.uk] . Der soll zwar nicht so toll sein, doch ob der ausreicht, wenigstens Gerber zu exportieren, hat anscheinend noch niemand ausprobiert. Wäre toll, wenn Du das mal machen könntest.

Zweite Möglichkeit ist, Ubuntu in VirtualBox laufen zu lassen. Beide sind gratis und je nach Prozessor erreicht man mit der virtuellen Maschine 70-95% der "normalen" Geschwindigkeit. Das reicht locker zum Gerber exportieren.

Die dritte Sache ist, dass das Layout derzeit nicht weniger als 12 verschiedene Bohrergrössen enthält. Da sollte man mal aufräumen, doch sowohl Jacky als auch ich sind derzeit damit beschäftigt, Platinen her- und Bauteile zusammen zu stellen. Wenn ich das richtig sehe, hat der Jacky schon welche fertig, für eine einzelne Platine musst Du also nicht unbedingt einen eigenen Auftrag starten.

Viertens, ich hänge einfach mal alle Gerber an: Generation_7_ElectronicsGerbers2011-02-16.zip Zum gucken gibt's da gerbv, das funktioniert auch auf Windows gut.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Gen7-Elektronik
February 16, 2011 11:18AM
Heya,

danke Traumpflug.
Ich werd mal schauen ob ich da was hin bekomme.

An wen müßte ich mich wenden für eine Platine (reicht erstmal um überhaupt anzufangen)

C ya, Gabriel
Re: Gen7-Elektronik
February 16, 2011 12:33PM
Moin,
melde mich hier auch mal zu Wort. Also, ich habe Platinen bestellt, sollte laut Händler am 1.3.11 da sein.
Kann dir dann davon gerne eine verkaufen.
Re: Gen7-Elektronik
February 16, 2011 02:06PM
Heya,

Würde mich freuen, wenn das klappt. Sag dann noch mal Bescheid.

C ya Gabriel
Re: Gen7-Elektronik
February 17, 2011 11:41AM
Jo ich werde auf jeden Fall hier was posten wenn ich die Platinen habe.
Re: Gen7-Elektronik
March 07, 2011 10:21AM
Heya,

sodele, ich hab heute die Gen7-Elektronik von Traumpflug bekommen, und weil meine Kids am Feiern sind und ich damit Zeit habe, hab ich mal angefangen zu löten.

Gleich auch die erste Frage an Traumpflug:
In der Bauteileliste im Wiki (Gen7-Bauteilliste) steht für L1 eine Coil (Spule?) mit 100µH haben tue ich aber ein Widerstand mit 2Ohm. Hab ich was verpasst? Grifffehler?

Bitte hilf, Traumpflug winking smiley

C ya, Gabriel
Re: Gen7-Elektronik
March 07, 2011 10:53AM
Die Spule sieht einem Widerstand in der Tat zum verwechseln ähnlich. Ist ein bisschen dicker und hat die Ringe braun-schwarz-braun = 1-0-1Null = 100. Ein 2 Ohm Widerstand ist eigentlich nicht dabei.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Gen7-Elektronik
March 07, 2011 10:58AM
Heya,

thnxs, dann ist das die Spule. Ich hatte den nur eben an Multimeter gehängt eine Spule hat ja auch ein Widerstand. Bei mir fehlt aber ein 10µF-Kondi (hab ich aber noch in der Bastelkiste).

Kleiner Hinweis für die nächsten Platinen:
Mach die Löcher für den Reset-Schalter doch etwas größer, ich hab die mit 1,0mm - Bohrer etwas aufgebohrt, da der Taster sonst nur mit Kraft (bei mir jedenfalls) reingeht.

Edit:
Aus dem Layout geht leider nicht direkt heraus, wo bei den LEDs und den Kondensatoren + ist. Ist das der 4eckige Punkt immer?

C ya, Gabriel

Edited 1 time(s). Last edit at 03/07/2011 11:01AM by Arcangel.
Re: Gen7-Elektronik
March 07, 2011 11:11AM
Und jetzt mal Butter bei die Fische...

Die PWM-Ausgänge an dem ATmega gehören nicht auf die Endschalter sondern an die Mosfets... und erst recht nicht an die Schaltleitung vom Netzteil. An die Mosfets müssen noch 100k Pulldowns..

Nachdem ich den Prototyp soweit verändert hab, funktioniert er halbwegs.

Ansonsten gibt es Probleme mit der Firmware... dann hat die Schaltung Probleme überhaupt eine Verbindung auf zu bauen... man muß den Host bis zu 5x neu starten bis die verbindung steht.. ist sie dann einmal gelungen bleibt sie stabil vorhanden.
Die Motoren verlaufen sich nicht (wie bei der Ramps) , das ist schon mal positiv.

Aber ansonsten ist die Platine noch sehr verbesserungsbedürftig. So wie sie ist schwimmen die die Ausgänge... das Heatbed 20° rauf und runter.
Bei jedem Signal was über die FTDI-Schnittstelle kommt flimmert der eine Mosfetausgang mit...

ICH verkaufe die SO nicht !!!


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Gen7-Elektronik
March 07, 2011 12:32PM
Quote
Archangel
Mach die Löcher für den Reset-Schalter doch etwas größer

Hab ich notiert.

Quote

Aus dem Layout geht leider nicht direkt heraus, wo bei den LEDs und den Kondensatoren + ist. Ist das der 4eckige Punkt immer?

Ja, der viereckige Pin ist immer Plus, also das längere Beinchen. Muss ich mir noch was überlegen, wie man das beim fräsen kennzeichnet.


Quote
Stoffel15
Die PWM-Ausgänge an dem ATmega gehören nicht auf die Endschalter sondern an die Mosfets... und erst recht nicht an die Schaltleitung vom Netzteil.

Welche "PWM-Ausgänge" meinst Du? Der ATmega hat ein halbes Dutzend davon und die sind gut verteilt. Ausserdem erschliesst sich mir nicht, was das für einen Unterschied macht, ob ein I/O-Pin auch als PWM genutzt werden kann oder nicht. Schliesslich sind ja alle Pins mindestens dreifach belegt.

Quote

An die Mosfets müssen noch 100k Pulldowns..

Weder die Gen3 noch die Gen6 haben sowas dran. Mehr habe ich nicht nachgeschaut. Allerdings eine erwägenswerte Massnahme, schliesslich soll die Gen7 ja noch zuverlässiger als die Bisherigen laufen.

Quote

Nachdem ich den Prototyp soweit verändert hab, funktioniert er halbwegs.

Super.

Quote

Bei jedem Signal was über die FTDI-Schnittstelle kommt flimmert der eine Mosfetausgang mit...

Man braucht den FTDI nicht für den Betrieb. Zwei Endstops "flimmern" auch mit. Vier Pins nur für das aufspielen des Bootloaders zu reservieren scheint mir ein wenig übertrieben.

Quote

ICH verkaufe die SO nicht !!!

Das hier ist Open Source, nicht Open Business.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Gen7-Elektronik
March 07, 2011 12:38PM
Also jetzt muss ich mich hier auch mal zu Wort melden.
Was der Wolfgang da schreibt konnte ich bislang nur teilweise auf meinem Board beobachten. Bei mir flimmern keine LEDs beim Senden/Empfangen, die Widerstände sind auch nur nötig, wenn man die Firmware nicht richtig konfiguriert Die Verbindungsprobleme hatte ich bislang nicht und was die Regelung des Bettes angeht, das sieht bei uns ähnlich mies aus, aber was sollen wir da bitte an der Platine ändern? Die kann da wohl kaum etwas für, das liegt eher an der Firmware....
Ach ja und noch was: Ich finde es von dir, Wolfgang, unangemessen hier so um Forum rum zu posaunen, ich habe mir gestern den Arsch aufgerissen um die Firmware für dich zum laufen zu bekommen, obwohl ich eigentlich was anderes vor hatte und habe dafür nicht mal ein Danke bekommen! Frechheit!
Re: Gen7-Elektronik
March 07, 2011 12:46PM
Ach ja und noch etwas, was die PWM Ausgänge angeht: Was pisst du uns (mir) da nun ans Bein? Ich habe dir das gestern sicher 3 mal erklärt, dass das beim Bau der Platine noch kein Problem war, jede Firmware unterstützt das auch so. Nur weil jetzt eine Firmware in der neusten Version (worauf ich Triffid auch schon hingewiesen habe und er an einer Lösung arbeitet) das nicht mehr kann (die du nebenbei sowieso nicht verwenden willst) machst du jetzt hier einen Aufstand. Und nochmal was technisches dazu: Es ist totaler Humbuk die Heizungen über PWM zu betreiben, da hierdurch nur mehr Verlustleistung entsteht und eine bessere Kühlung der Mosfets erforderlich ist bzw. diese nicht so viel schalten können. Und man hat deutlich weniger EMI Probleme dadurch.
Re: Gen7-Elektronik
March 07, 2011 01:10PM
Jacky2k Wrote:
-------------------------------------------------------
> Also jetzt muss ich mich hier auch mal zu Wort
> melden.
> Was der Wolfgang da schreibt konnte ich bislang
> nur teilweise auf meinem Board beobachten. Bei mir
> flimmern keine LEDs beim Senden/Empfangen, die
> Widerstände sind auch nur nötig, wenn man die
> Firmware nicht richtig konfiguriert

Zitat Jacky2k:

"und löt die verdammten widerstände über die mosfets, das hat bei uns ein paar probleme gelöst"



> Die
> Verbindungsprobleme hatte ich bislang nicht und

Weil du nicht mit dem Host an die Platine gehst, sondern mit Terminalprogramm. klar,

aber 90% aller User hier benutzt den Host vom Adrian oder einen andern. Was dir aber egal zu sein scheint...


> was die Regelung des Bettes angeht, das sieht bei
> uns ähnlich mies aus, aber was sollen wir da
> bitte an der Platine ändern?

Dann sprich das an , anstatt so zu tun als wenn alles IO wär.
Ihr habt bei der Pinbelegung nicht aufgepasst...


> Die kann da wohl
> kaum etwas für, das liegt eher an der
> Firmware....

Erzähl nix... seltsamerweise haben andere Platinen die Probleme nicht... aber es ist die Firmware, das man die PWM-Ausgänge nicht zur Verfügung hat um vernünftig damit zu arbeiten. KLAR...

> Ach ja und noch was: Ich finde es von dir,
> Wolfgang, unangemessen hier so um Forum rum zu
> posaunen, ich habe mir gestern den Arsch
> aufgerissen um die Firmware für dich zum laufen
> zu bekommen, obwohl ich eigentlich was anderes vor
> hatte und habe dafür nicht mal ein Danke
> bekommen! Frechheit!

Ach... du weist das die Firmare auf den Ding SO nicht läuft....

Zitat Jacky2k :
"also wir haben bis eben gerade gefrickelt und sind zu dem schluss gekommen, dass die firmware läuft mit ausnahme des bettes. die regelung dafür funktioniert nicht richtig, der schwankt um plus/minus 40 grad rauf und runter"

Und dazu kommt dann noch:

Zitat Jacky2k:

"ach ja und in der firmware ist ein fehler, was dazu führt, dass der lüfter nicht funktioniert"

Komischerweise sind diese Fehler in allen Versionen von Firmware ???
Nur wenn man die Platine verändert sind sie zum größten Teil weg... die läuft hier.
Aber dafür hab ich etliche Bahnen durchtrennt und die Pinbelegung geändert.

Das Heizbett funktioniert mit der Standartfirmware, die Barrel Heizung geht... Ventilator hab ich noch nicht gebraucht, aber wenn die Maschine fertig ist werde ich den testen.

Ich will einfach nicht, das du den Leuten hier Sachen andrehst, die nicht funktionieren... wenn du die bestellst, ohne sie vernünftig zu testen, ist das dein Problem, mach es nicht zum Problem anderer Leute.

Damit verdirbst du jedem Anfänger den Spaß an dem Hobby, denn der weiß nicht woher die komischen Reaktionen der Elektronik kommen...


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Gen7-Elektronik
March 07, 2011 01:23PM
Leute, bitte ruhig!!! Arbeitet lieber gemeinsam an einer Lösung anstatt Euch gegenseitig zu zerfleischen :-(

Leidtragend sind doch nur die User, die das Dingen einsetzen wollen...





RepRap Newbie. 2x Gebrauchte Elektronik erstanden, Prusa Teile vom Wolfgang, Elektronik wehrt sich :-(
Re: Gen7-Elektronik
March 07, 2011 01:26PM
Quote

Es ist totaler Humbuk die Heizungen über PWM zu betreiben, da hierdurch nur mehr Verlustleistung entsteht und eine bessere Kühlung der Mosfets erforderlich ist bzw. diese nicht so viel schalten können. Und man hat deutlich weniger EMI Probleme dadurch.

Die RepRap-Heizungsexperten sind sich wohl halbwegs einig, dass es besser als mit einem einfachen ein/aus geht. Wenn ich mir die Teacup so betrachte, gibt es da trotz allen Expertenmeinungen die Option BANG_BANG. Also Ein, wenn die Düse zu kühl ist und Aus, wenn sie zu warm ist. Ganz ohne Kaffeesatzlesen (PID) und so. Passt das zu dem, was Du Dir vorstellst?


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Gen7-Elektronik
March 07, 2011 01:40PM
dann schalt die Bang Bang mal ein... und guck was passiert.

Jedenfalls geht sie jetzt... ohne große Änderungen der Firmware. Und Einstreuungen hab ich auch nicht.

Da frag ich mich nur welche Heizungs-Experten das wieder sind...

Wenn man so was schon anfängt, dann bitte auch richtig. Ich weiß das er studiert... nur scheint das eine Schaltung nicht vor Fehlern zu schützen, sonst wäre das resultat besser.

Die ist sehr gut geätzt, hervorragend gelötet.. alles 1a kann ich nur sagen.

Aber sich nicht genug Mühe beim Layout gegeben. Oder sagen wir mal so... da hätte vorher nochmal jemand drüber gucken sollen, der sich schon mal mit dem Chip und dem was wir damit machen, beschäftigt hat. Dann wären wahrscheinlich einige Dinge besser gelaufen.
Aber so müssen an der Platine noch einige Dinge geändert werden. Und nicht einfach alles auf die Firmware schieben.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Gen7-Elektronik
March 07, 2011 01:55PM
Quote

dann schalt die Bang Bang mal ein

Eigentlich meinte ich den Jacky. Sorry, dass ich das nicht klar gestellt habe.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Gen7-Elektronik
March 07, 2011 02:30PM
Alter Wolfgang, mir platzt jetzt echt der Kragen und ich weiß nicht was ich noch machen soll.
Mal ganz abgesehen davon, dass ich immer noch kein Danke gehört habe, was mich echt trifft, hilfst du auch nicht gerade bei der Lösung des Problems. Alleine deine Aussage, die du ständig wiederholst, "die Schaltung/die Ausgänge würden schwimmen", was auch immer das heißen mag, treibt mich noch in den Wahnsinn. Was heißt denn schwimmen für dich? Eine Schaltung schwimmt wenn die Masse fehlt. Wenn das so ist, dann hast du die Platine falsch angeschlossen!
Und nochmal um das klar zu stellen: Bei uns läuft die Firmware perfekt, abgesehen vom Bett, also man muss da nix umlöten, du bekommst es einfach nur nicht geschissen das richtige in die config.h bzw. pins.h einzutragen und lässt das dann an an uns aus, "wir seien inkompetent".

Quote

wenn du die bestellst, ohne sie vernünftig zu testen, ist das dein Problem, mach es nicht zum Problem anderer Leute.
Ich konnte ja nicht ahnen, dass du den Leuten nicht zutraust mal in Windows ne Konsole auf zu machen und "make" und "make program" einzugeben! Denn mit der Teacup läuft die Firmware bei uns bereits seit vielen Wochen stabil und zuverlässig.

Edit: Nochwas: Das Bitbanging verwendet durchaus einen PID Regler! Es wird halt nur ohne Timer gearbeitet.

Edited 1 time(s). Last edit at 03/07/2011 02:33PM by Jacky2k.
Re: Gen7-Elektronik
March 07, 2011 02:53PM
Ja klar, Platine falsch angeschlossen... ich bin ja auch erst seit gestern dabei und das ist meine erste Platine die ich anschließe.

Und die Teacup läuft bei dir auch nicht. jedenfalls bis gestern nicht... laut deiner Aussage.... "Warum nimmst du nicht die alte FiveD_on_Arduino.. die läuft wenigstens". Nachdem ich dir den Link zur Teacup gezeigt hatte...

Klar, die Motoren laufen sauber... keine Frage. Ist bestimmt Klasse um ne Fräsmaschine zu betreiben. Aber ohne Stabile HeizAusgänge nicht für nen Mendel.


Ich versuche mal ob ich dir das zeigen kann...was ich unter schwimmen verstehe..
dafür brauche ich aber ne Weile...


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Gen7-Elektronik
March 07, 2011 02:59PM

Re: Gen7-Elektronik
March 07, 2011 03:09PM



Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Attachments:
open | download - 13.gif (23 KB)
Re: Gen7-Elektronik
March 07, 2011 03:12PM
Heya,

ich glaube da haben 2 oder 3 Leute untereinander was in den falschen Hals bekommen: Nur eins dazu:
MACHT ES UNTER EUCH IN DEN PMs AUS.

Zurück zum Topic:
Der 100k Ohm Widerstand ist ein guter Hinweis von dir, Wolfgang, dafür danke ich dir, kann man recht fix nachrüsten, wenn es auf der Groundlayer zu Störungen kommen kann wegen den Polulus oder ähnliches.

Das die neue Firmware von Adrian dazu übergeht das Heizbett mit PWM zu befeuern, da kann man einen Adapter schnell bauen wo man eine andere Pinbelegung hinbekommt. Hab da schon eine Idee mit Lochstreifen.

Aber sehe ich das jetzt richtig, das die Gen7 primär für die FiveD-Firmware gestrickt ist?
Dann sollte man das vielleicht im Wiki noch mal explizit erläutern.

C ya, Gabriel, der dankbar ist für alle Hinweise, für jede Hilfe. Es ist schliesslich ein Hobby und eine Open Source Lösung die noch in den Kinderschuhen steckt
Re: Gen7-Elektronik
March 07, 2011 03:30PM
Die Gen7 ist nicht speziell für FiveD, eigentlich sollte da Teacup drauf laufen und tut es auch, ist nur ein wenig komplizierter das zum laufen zu bekommen.
Re: Gen7-Elektronik
March 07, 2011 03:35PM
Die läuft bei mir mit der letzten (nicht der neuen) Firmware vom Adrian. Wenn man die Pins austauscht. Aber die Motoren einwandfrei.. gar kein Problem.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Gen7-Elektronik
March 07, 2011 03:52PM
Ich bin da in die falsche Spalte gerutscht..
ich hab in der Delta-Reprap/Technik einen Link zu einem Avi... wo man sehen kann was ich mit dem schwimmen meine.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Gen7-Elektronik
March 07, 2011 04:00PM
Aber nachdem ich die Pins getauscht hab, und dem Adrian seine Firmware drauf gespielt hab kann man allmählich damit drucken. MIT Heizbett.



Edited 1 time(s). Last edit at 03/07/2011 04:01PM by Stoffel15.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Attachments:
open | download - greg-extruder.jpg (249.8 KB)
Re: Gen7-Elektronik
March 07, 2011 04:21PM
Vermutlich bin ich einfach im falschen Film. Da hat man Monate Arbeit rein gesteckt und nun wird das mit lauter Halbwahrheiten zerschossen. *seufz*


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Gen7-Elektronik
March 07, 2011 07:29PM
Falls jemand wissen will wie's weiter geht: [github.com]

Allein 17 Änderungen die letzten 3 Tage.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Gen7-Elektronik
March 08, 2011 01:55AM
Heya,

aber so kann man doch langsam wieder weiter arbeiten. Ich war mir schon klar, das ich ein beta-Tester bin für das Board genau wie Wolfgang.
Konsenz lautet doch bisher:
Teacup (was auch immer für eine Firmware das ist) läuft
Adrian's Firmware läuft mit Modifikationen am Board (primär Atmega644 Pinbelegung)
@Wolfgang Welche Pins hast du genau umgelegt und wie viele würde mich interessieren.

FiveD funktioniert auch oder teilweise? => Jacky und Traumpflug Aussage bitte.

@Traumpflug
Kannst du nicht zwischen den Mosfets-Gate und den Widerständen R11 (respektive R12 & R13) Löcher einplanen und bohren und das Gegenstück dann etwas rechts in den Masseleiter der zum Drain (?) führt? Dadurch kann man später immer noch optional 100kOhm-Widerstände einlöten gegen Ground wenn man sie braucht?

C ya, Gabriel
Sorry, you do not have permission to post/reply in this forum.