Welcome! Log In Create A New Profile

Advanced

Skeinforge Problem mit der Kommasetzung?

Posted by Philipp 
Skeinforge Problem mit der Kommasetzung?
June 20, 2011 03:22AM
Hallo liebes Forum,
ich habe ein Problem mit dem Skeinforge G-Code. Ich bekomme immer viel zu große Wege. Ich drucke einen Würfen mit 20mm Kantenlänge. In den Analysefenstern sieht das auch ganz gut aus. Aber im G-Code sind die Koordinaten dann um ca. Faktor 10 zu groß, aus den Kantenlängen wird dann etwa 200 mm und aus der Schichtdicke wird sogar 40mm die Höhe des Würfels mutiert sogar zu 2000 mm. Das überschreitet dann sogar die Möglichkeiten meines Druckers.
Die Skalierung ist auf 1 gestellt. Offensichtlich scheint es ein Problem mit der Kommasetzung zu sein. Hat da jemand einen Tipp für mich?
Vielen Dak
Philipp
Re: Skeinforge Problem mit der Kommasetzung?
June 20, 2011 03:28AM
Welche Skeinforge version nutzt du?

Wenn es >= SF40 ist denn muß deine E_STEPS_PER_MM im firmware geändert werden!

Für < SF40 soll es die anzahl von steps nötig um 1 mm aus der düse zu extrudieren.
Mit >= SF40 soll es die anzahl von steps nötig um 1 mm feedstock einzuziehen.

Aber der unterschied sollte factor 60 oder 80 sein... confused smiley


Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Skeinforge Problem mit der Kommasetzung?
June 20, 2011 03:35AM
@ Bob
er hat anscheint ein Gesamtproblem, das Teil wird ja erheblich zu groß. Nicht nur der Extrudervorschub.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Skeinforge Problem mit der Kommasetzung?
June 20, 2011 04:43AM
est ist tatsächlich so, dass beim G-Code export alle Kommata verschwinden. daduch werden aus 20,0mm 200mm und aus 0,40mm werden 40mm.
Das betrift alle Achse nur nicht unbedingt den Extruder, der macht glaube ich noch viel zuwenig, aber das Problem gehe ich im zweiten Schritt an.
Vielen Dank für weitere Tipps.
Philipp
VDX
Re: Skeinforge Problem mit der Kommasetzung?
June 20, 2011 04:48AM
... schau mal, was für eine Ländereinstellung du hast - bei Windows mit DE und Programmen mit EN/US-Einstellung habe ich das regelmäßig ... z.B: muß ich bei den Firmenrechnern bei Excel immer wieder mal die Ausgabe von unseren Meß- und Datenloggern mit einem Texteditor durchgehen, um vor dem Import Punkt und Komma zu vertauschen ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org]
Call for the project "garbage-free seas" - [reprap.org]
Re: Skeinforge Problem mit der Kommasetzung?
June 20, 2011 04:50AM
Tritt das Problem auch bei englischer Schreibweise der Zahlen, also Dezimalpunkte statt Dezimalkommas auf?

Gut möglich, dass auf der grafischen Oberfläche die Kommas korrekt angezeigt werden, die Berechnungsalgorithmen aber nur die Punkte berücksichtigen.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Skeinforge Problem mit der Kommasetzung?
June 20, 2011 05:06AM
Ich hab digital seperator im Windows settings als ',' muß aber trotzdem "." nutzen im Skeinforge.


Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Skeinforge Problem mit der Kommasetzung?
June 20, 2011 05:30AM
Hallo Leute,
vielen Dak für eure Anregungen, ich benutze deutsche Rechnereinstellungen. In den Skienforge Oberflächen werden die Maße richtig mit "." als Dezimalzeichen angezeigt (40.50) im G-Code steht dann so etwas (4050).
Mein RepRab-Host benutzt übrigens auch den Punkt für das Dezimalzeichen im G-Code.
Evtl. liegt es an der Verion 11.04.26 von Skeinforge?
Gruß Philipp
Re: Skeinforge Problem mit der Kommasetzung?
June 20, 2011 05:54AM
Hallo Leute vielen Dank für eure Hilfe!
ich habe den Fehler gefunden. In den Exportbedingungen war "Gcode Step" eingestellt, das kann natürlich nicht funktionieren es muss "Do not change Output" aktiviert sein.
Vielen Grüße
Philipp
Re: Skeinforge Problem mit der Kommasetzung?
June 20, 2011 05:56AM
Problem gelöst, in den Exporteinstellung stimmte etwas nicht. "Gcode Stepp" war aktiviert.
Vielen Dank für eure Hilfe
Philipp
Re: Skeinforge Problem mit der Kommasetzung?
June 20, 2011 06:57AM
Super.

Da sagte neulich jemand im Chat zu Skeinforge: "5000 Funktionen, von denen man 9 braucht." smiling smiley


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Skeinforge Problem mit der Kommasetzung?
June 21, 2011 10:05AM
Hallo zusammen,
das Tehma geht weiter. Ich habe jetzt weiter hin probiert mit Skeinforge zuarbeiten. dazu musste ic meine Firmware umstellen und die Acceleration heraus nehmen. Im Prinzip kein Problem, bis das man zum Download kommt. Ich bekomme folgende Felermeldungen:

C:\DOKUME~1\PHILIP~1\LOKALE~1\Temp\build3693871437875110598.tmp\/hostcom.h:1: error: stray '\302' in program

C:\DOKUME~1\PHILIP~1\LOKALE~1\Temp\build3693871437875110598.tmp\/hostcom.h:1: error: stray '\265' in program

C:\DOKUME~1\PHILIP~1\LOKALE~1\Temp\build3693871437875110598.tmp\/hostcom.h:1: error: stray '#' in program

C:\DOKUME~1\PHILIP~1\LOKALE~1\Temp\build3693871437875110598.tmp\/hostcom.h:240:2: error: #endif without #if

C:\DOKUME~1\PHILIP~1\LOKALE~1\Temp\build3693871437875110598.tmp\/hostcom.h:1: error: 'ifndef' does not name a type

C:\DOKUME~1\PHILIP~1\LOKALE~1\Temp\build3693871437875110598.tmp\/hostcom.h: In member function 'void hostcom::sendMessage(bool)':

C:\DOKUME~1\PHILIP~1\LOKALE~1\Temp\build3693871437875110598.tmp\/hostcom.h:196: error: 'shutdown' was not declared in this scope

Kann von Euch jemand etwas damit anfangen?
Diese Felermeldungen kommen bereits beim Compilieren.
Die Elektronik ist eine GEN3 v1.2 und hat noch nie probleme verursacht.

Achso, ich habe jetzt version Arduino018 Arduino 021 und Arduino 022 benutzt.
Ich habe mit Brücke und Ohne Brücke den Download getestet. Ich habe mit Reset herum gespielt.
Re: Skeinforge Problem mit der Kommasetzung?
June 21, 2011 10:38AM
Hm, das könnte ein Zeichensatzproblem der Dateien unter Windows sein, so dass der Compiler das File 'hostcom.h' nicht lesen kann. Evtl. mal mit einem Texteditor (z.B. Notepad++) am Encoding rumspielen. Der String '\302' könnte darauf hindeuten.
Re: Skeinforge Problem mit der Kommasetzung?
June 21, 2011 10:56AM
@schmelly,
wie soll das den plötzlich kommen? Ich habe die Arduinoumgebung doch nicht verlassen.
Was meinst Du mit Encoding?
Ratlose Grüße
Philipp
Re: Skeinforge Problem mit der Kommasetzung?
June 21, 2011 11:13AM
In der Regel nutzen Textdateien unter Linux Unicode als Zeichensatz (Hierzu gehört unter anderem auch C Programmcode). Mit Skeinforge habe ich mich bisher noch nicht beschäftigt, vermute aber, dass es ursprünglich aus der Linux Welt kommt? Unter Windows wird häufig ein anderer Zeichensatz verwendet (ISO 8859-1 oder auch Latin1, Cp1252 oder Window-1252 genannt). Es kann dann zu Problem führen, wenn ein Tool unter Windows (in diesem Fall evtl. der C-Compiler) fälschlicherweise davon ausgeht, dass eine Unicode Datei aus der Linux Welt als ISO Datei vorliegt.

Grundsätzlich ist die Fehlersuche mit der von Dir angegebenen Log-Ausgabe recht schwierig. Könntest du mal mindestens die Datei mit anhängen? Dann können wir sehen, was da eigentlich genau drin steht.
Re: Skeinforge Problem mit der Kommasetzung?
June 21, 2011 12:17PM
Hast du in der Arduino IDE das richtige Board ausgewählt?

Gruß
Flo


GRR - German RepRap
Re: Skeinforge Problem mit der Kommasetzung?
June 21, 2011 04:27PM
Quote

C:\DOKUME~1\PHILIP~1\LOKALE~1\Temp\build3693871437875110598.tmp\/hostcom.h:1: error: stray '\302' in program

Hast Du sonst noch irgendwelche Dateien in dem Ordner mit der Firmware herum liegen? Die Arduino IDE compiliert alles was ihr über den Weg läuft (sich in dem Ordner befindet), egal, ob es zum Programm dazu gehört oder nicht.

Quote

Ich habe mit Brücke und Ohne Brücke den Download getestet. Ich habe mit Reset herum gespielt.

Das kannst Du Dir alles sparen bis die IDE die Firmware erfolgreich zusammen gebaut hat. Den erfolgreichen Bau erkennt man daran, dass die Grösse der Firmware ausgegeben wird.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 10:53AM
Vielen Dank Wolfgang!
die neue Firmware funktioniert jetzt. Schein bar war die alte irgend wie zerschossen.
Jetzt kann ich "drucken". Ich mußte zwar noch die Drehrichtung der Z-Achse umkehren, doch jetzt funktionieren de x-, y-, z-Achsen schon mal.
Als nächstes muss ich herausfinden warum der Extruder zuwenig Material ausspuckt.

Da ich die "Flow Rate" bereits beginnend mit 20 bis auf 250 gesteigert habe, bin ich jetzt auch etwas iritiert.

Hat jemand einen Tipp?
Gruß
Philipp
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 11:43AM
Hallo Leute,
knn das Problem mit der Einstellung Absolut - und Relativ Extrusion unter Dimension zusammen hängen?
Viele Grüße
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 11:51AM
nein eigentlich nicht (glaub ich)

wenn du immens viel flow brauchst könnte es sein dass die Estepps nicht stimmen

welche skeinforge version nutzt du und wie hast du die Esteps berechnet?


grüße
Bernhard
------------------------------------------------------------------------------------------------------------------------------
[www.thingiverse.com]
[www.flickr.com]
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 12:05PM
Absolut ist richtig bei Dimension...

Welche Version Skeinforge ??? Eine von Ende 2010 oder eine aus diesem Jahr ?


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 01:44PM
Hallo,
ich arbeite mit der Version 10.12.18. Das Problem mit dem Extruder besteht weiterhin. Der Extruder bewegt sich immer vor und wieder zurück, er fördert aber nichts.
Viele Grüße
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 01:47PM
wie weit vor und zurück? wenn nur minimalst(wie ein zucken) ist eine spule dran wohl falsch rum gepolt


grüße
Bernhard
------------------------------------------------------------------------------------------------------------------------------
[www.thingiverse.com]
[www.flickr.com]
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 01:58PM
Hallo Poller,
der Drucker hat bereits eins A funktioniert. Allerdings mit G-Code aus dem Host-Programm. jetzt sieht es so aus als würde der Rückhub besser funktionieren als der vorhub. allerdings liegt das immer an der Programm Zeile.
Viele Grüße
Philipp
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 02:05PM
kopier mal die entsprechende passage(incl ein paar zeilen davor und dahinter) hier rein vllt ist der code echt total im eimer


grüße
Bernhard
------------------------------------------------------------------------------------------------------------------------------
[www.thingiverse.com]
[www.flickr.com]
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 02:30PM
Guck mal, ob Du "G92 E0" in Deinem G-code findest. Hast Du das nicht, dann wirft der G-code Kompiler (Skeinforge) relative Längen für das Extrudat aus. Ist die Firmware aber für absolute Längen konfiguriert, kommt es zu einem vor- und zurück fahren des Extrudermotors.

Ein Vergleich mit dem alten G-code kann natürlich auch nicht schaden smiling smiley


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 02:50PM
Versuch es mal mit dem Host der zu der Firmware gehört.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 03:21PM
Philipp Wrote:
-------------------------------------------------------
> Vielen Dank Wolfgang!
> die neue Firmware funktioniert jetzt. Schein bar
> war die alte irgend wie zerschossen.
> Jetzt kann ich "drucken". Ich mußte zwar noch die
> Drehrichtung der Z-Achse umkehren, doch jetzt
> funktionieren de x-, y-, z-Achsen schon mal.
> Als nächstes muss ich herausfinden warum der
> Extruder zuwenig Material ausspuckt.
>
> Da ich die "Flow Rate" bereits beginnend mit 20
> bis auf 250 gesteigert habe, bin ich jetzt auch
> etwas iritiert.
>
> Hat jemand einen Tipp?
> Gruß
> Philipp

Kann ja dann eigentlich nur an der E_Stepps Einstellung in der Firmware liegen... was hast du denn für einen Extruder ?

Das vor und zurück drehen kommt wahrscheinlich von der Retarkt-Funktion von Dimension in Skeinforge.

Irgendwelche Fehlermeldungen im Host ? Die replace.csv auch in der Version von Skeinforge drin ?

Funktioniert das drucken NUR mit dem Host denn noch ?


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 03:21PM
Hallo Wolfgang,
ich weiß mir langsam nicht mehr zu helfen ich habe die Feed Rate jetzt auf 250 und sie ist immer noch nicht hoch genug.
Die hostsoftware ist vielleicht die Lösung, aber morgen.
Gruß Philipp
Re: Skeinforge Problem mit der Kommasetzung?
June 23, 2011 03:43PM
Zumindest kannst du über die Hostsoftware testen ob es an einer falschen Einstellung in der Firmware liegt.

Hast du noch das Profil was ich dir gegeben habe ? Geht das auch nicht ?


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Sorry, you do not have permission to post/reply in this forum.