info Ruramps4d
October 30, 2018 07:41AM
Ciao Ragazzi ho acquistato questa scheda e mi è arrivata oggi, la scheda sembra ben fatta, però forse ho fatto una cavolata ho preso la versione con termocouple....me ne sono reso conto adessosad smiley il problema è questo non ho idea di cosa siano io fino ad ora ho sempre usato i classici sensori di temperatura100K termistor...
mi potete aiutare a capire cosa sono queste termocouple e cosa dovrei montare nella scheda? Ps. capisco veramente poco di elettronica
grazie graziesmiling smiley
Re: info Ruramps4d
October 31, 2018 02:44AM
Quote
Stefano_chi
Ciao Ragazzi ho acquistato questa scheda e mi è arrivata oggi, la scheda sembra ben fatta, però forse ho fatto una cavolata ho preso la versione con termocouple....me ne sono reso conto adessosad smiley il problema è questo non ho idea di cosa siano io fino ad ora ho sempre usato i classici sensori di temperatura100K termistor...
mi potete aiutare a capire cosa sono queste termocouple e cosa dovrei montare nella scheda? Ps. capisco veramente poco di elettronica
grazie graziesmiling smiley

Vado a memoria, ma ricordo che la versione con termocoppia, ha sia la possibilita' di collegare la stessa che i normali sensori resistivi


Stampante CoreXY Hypercube con varie migliorie ed estrusore diretto E3D V6 originale
Ruramps4d V1.1
BLTouch originale
Arduino due
Raspberry PI3 + Octoprint
Nextion 4.3
Firmware MarlinKimbra 4.3.9
Ugello 0,4
Filo 1,75
Re: info Ruramps4d
October 31, 2018 06:47AM
ok grazie mille thumbs up
Re: info Ruramps4d
November 15, 2018 01:13PM
Ragazzi mi potete dare una mano stavo provando una ruramps4d con display nextion 4.3 alla scheda ho collegato una ventola su fan1 e un sensore temperatura su t0 parte tutto però quando cerco di attivare la ventola non parte e il sensore non rileva nessuna temperatura mi potete dare qualche suggerimento uso come Fw logicamente marlinkimbra
Attachments:
open | download - 46443455_1102190786623767_6328302640396500992_n.jpg (114.8 KB)
open | download - 46277323_1102191396623706_858095793855266816_n.jpg (79.2 KB)
open | download - 46379387_1102192853290227_5189150062206255104_n.jpg (53.4 KB)
Re: info Ruramps4d
November 18, 2018 08:57AM
Innanzitutto complimenti per i collegamenti isolati con guaina termo restringente ..... nel forum ho visto collegamenti che nemmeno nei film di Dario Argento, quindi quando vedo un lavoro fatto bene mi inchino.
Poi ... il display non mostra le informazioni base e quindi partirei da qui, qualcosa non va nei collegamenti, io ho inscatolato tutto, ma se poi mi avanzano 10 minuti smonto e ti mando una foto, sicuramente sara' un cavetto invertito.
Se non ricordo male, se non funziona quello non funziona nulla.


Stampante CoreXY Hypercube con varie migliorie ed estrusore diretto E3D V6 originale
Ruramps4d V1.1
BLTouch originale
Arduino due
Raspberry PI3 + Octoprint
Nextion 4.3
Firmware MarlinKimbra 4.3.9
Ugello 0,4
Filo 1,75
Re: info Ruramps4d
November 22, 2018 06:04AM
GRAZIE MILLE ... ho risolto il problema era un cavetto difettoso adesso riesco a rilevare temperature ma ho un problema con la ventola ... sono riuscito a farla andare una volta però poi ho modificato il fw e ora non ricordo come avevo settato la porta in marlinkimbra ti ricordi che pin devo mettere
Re: info Ruramps4d
December 12, 2018 01:14PM
Ciao
Hai risolto il problema della ventola, se si mi dici cosa hai dovuto scrivere nel firmware?
Stò provando in tutti i modi ma non riesco a farla andare ....
Re: info Ruramps4d
December 12, 2018 05:01PM
Quote
silvanopas
Ciao
Hai risolto il problema della ventola, se si mi dici cosa hai dovuto scrivere nel firmware?
Stò provando in tutti i modi ma non riesco a farla andare ....

Non devi scrivere assolutamente nulla e lasciare tutto come di default, è tutto già mappato nel file della ruramps. Controlla di esserti attaccato sulla giusta uscita...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: info Ruramps4d
December 12, 2018 06:07PM
Quote
MagoKimbra
Quote
silvanopas
Ciao
Hai risolto il problema della ventola, se si mi dici cosa hai dovuto scrivere nel firmware?
Stò provando in tutti i modi ma non riesco a farla andare ....

Non devi scrivere assolutamente nulla e lasciare tutto come di default, è tutto già mappato nel file della ruramps. Controlla di esserti attaccato sulla giusta uscita...

Si avevo notato che nel file 1550.h sono già assegnati il 9 e 8 e infatti non avevo toccato nulla nel.configuratore , però non riesco con il comando gcode M106 a farla partire... Anche da repetier utilizzando il tasto accensione ventola.... Ho provato anche con tester/oscilloscopio ma non esce nessun segnale, controllato se nella mia ruramps 1.3 dovevo fare il ponticello tra i due MOSFET sotto la scheda ma non serve perché la versione del master è già sistemato.... Bho domani riprovo ....
Re: info Ruramps4d
December 13, 2018 03:32AM
Risolto, sono dovuto intervenire su Configuration_Pin.h e mettere:

#define FAN0_PIN 9
#define FAN1_PIN. 8
Re: info Ruramps4d
December 15, 2018 03:08AM
Ma non devi cambiare i pin , ci deve essere scritto:
#define FAN0_PIN ORIG_FAN0_PIN
#define FAN1_PIN ORIG_FAN1_PIN
A meno che tu nel configuratore non hai invertito i le due fan...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: info Ruramps4d
December 15, 2018 04:00AM
Se lascio come dici tu non funziona
Re: info Ruramps4d
December 15, 2018 12:50PM
Mha..

Nella scheda 1550.h c'è :
#define ORIG_FAN0_PIN 9
#define ORIG_FAN1_PIN 8

se in configuration_pins hai:

#define FAN0_PIN ORIG_FAN0_PIN
#define FAN1_PIN ORIG_FAN1_PIN

è la stessa cosa di:

#define FAN0_PIN 9
#define FAN1_PIN 8

Quindi perché dici che non funziona???


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: info Ruramps4d
December 15, 2018 12:59PM
Confermo , ma purtroppo non funziona,non so che dirti ,ho provato sia a non scrivere nulla nel configuratore che scrivere nella fan 1 pin9 e nella fan 2 pin 8, sia nella versione 4.3.5 che nel 4.3.7.
Infatti chiedevo perché mi sembrava strano questo problema.
Re: info Ruramps4d
December 15, 2018 03:28PM
Partono da 0 gli id, perché dici fan 1 e fan 2, sarà fan 0 e fan 1.. Mha non so che dirti a tutti funziona cosi a prescindere dalla scheda e a te no... Ma se nel configuratore scrivi 9 e 8 nei pin delle due fan deve per forza funzionare..

Edited 1 time(s). Last edit at 12/15/2018 03:40PM by MagoKimbra.


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: info Ruramps4d
December 15, 2018 04:18PM
Ho sbagliato a scrivere intendevo fan 0.e fan 1 scusa ma non ho il pc sotto mano , lunedì riprovo (ho il.materiale in ufficio) e ti giro il file overall, a me non funziona , non so che dirti, credimi dopo 3 giorni di prove ho dovuto forzare intervenendo su pin.h mentre per quando riguarda l'opzione auto fan intervenendo sul configuratore funziona.
Re: info Ruramps4d
December 15, 2018 04:21PM
È se leggi qualche messaggio più indietro anche Stefano_chi aveva segnalato un problema con la ventola ed era dovuto intervenire nel firmware ma non si ricordava dove....
Re: info Ruramps4d
December 15, 2018 04:36PM
Si ma tu non hai fatto altro che modificare a mano il file configuration_pins che lo fa il configuratore, mettendo 9 e 8 su fan0 pin e fan pin quindi non hai fatto praticamente nulla...
Ecco perché ti dico che se lasciavi come stava avrebbe funzionato lo stesso... In più forse ancora non vi è chiaro i pin delle ventole come altre cose vengono salvati in eeprom e possono essere modificati direttamente con i comandi host senza fare tutto questo...
Quindi riconfermo quello che ho scritto prima, se lascivi come di default senza toccare nulla funzionava tutto perfettamente...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: info Ruramps4d
December 15, 2018 04:51PM
Avevo anche provato a non toccare nulla ma le ventole non hanno mai funzionato , faccio sempre M502 e poi M500 prima di provare una nuova configurazione per evitare dubbi ...
Comunque non impazzire per questa cosa , non ho la scheda sotto mano e non riesco a fare delle prove, lunedì creo una nuova configurazione e ti aggiorno.
Re: info Ruramps4d
December 17, 2018 08:40AM
Quote
MagoKimbra
Si ma tu non hai fatto altro che modificare a mano il file configuration_pins che lo fa il configuratore, mettendo 9 e 8 su fan0 pin e fan pin quindi non hai fatto praticamente nulla...
Ecco perché ti dico che se lasciavi come stava avrebbe funzionato lo stesso... In più forse ancora non vi è chiaro i pin delle ventole come altre cose vengono salvati in eeprom e possono essere modificati direttamente con i comandi host senza fare tutto questo...
Quindi riconfermo quello che ho scritto prima, se lascivi come di default senza toccare nulla funzionava tutto perfettamente...

Ciao Mago

Oggi ho ricompilato con la versione 4.3.7 del 16/12 e:

Nel configuratore ho provato sia a lasciarlo comè (lasciando in fan 0 e in fan 1 disabled/no pin assigned) che mettere in fan 0 il pin 9 pwm e in fan 1 il pin 8 pwm e non sono mai riuscito a far partire le ventole però;

se lascio il configuratore comè (lasciando in fan 0 e in fan 1 disabled/no pin assigned) e intervengo manualmente nel Configuration_Pins.h scrivendo:

// FAN pins
#define FAN0_PIN 9
#define FAN1_PIN 8
#define FAN2_PIN NoPin
#define FAN3_PIN NoPin
#define FAN4_PIN NoPin
#define FAN5_PIN NoPin


In questo modo riesco a far funzionare la fan.... (che è lo stesso passaggio che ho fatto con la 4.3.5 e la 4.3.7 del 12/12

e ti garantisco che ogni volta che carico il firmware inserisco sempre M502 e M500.

Ti prego non prendermi per matto ( mi riservo di fare altre prove).

Edited 2 time(s). Last edit at 12/17/2018 08:46AM by silvanopas.
Re: info Ruramps4d
December 18, 2018 11:09AM
Allora il problema è che di dafault non sono in disabled/no pin assigned quello lo avrai messo tu precedentemente, di default sono cosi:


Cosi prende i valori dal file della tua board...

E Fan 0 Pin nella tua scheda è 9 e Fan 1 pin è 8 quindi è come se mettessi 9 e 8...

Edited 1 time(s). Last edit at 12/18/2018 11:10AM by MagoKimbra.


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: info Ruramps4d
December 19, 2018 05:30AM
Quote
MagoKimbra
Allora il problema è che di dafault non sono in disabled/no pin assigned quello lo avrai messo tu precedentemente, di default sono cosi:
[attachment 108772 FAN.png]

Cosi prende i valori dal file della tua board...

E Fan 0 Pin nella tua scheda è 9 e Fan 1 pin è 8 quindi è come se mettessi 9 e 8...

Grazie Mago, confermo che ora funziona, molto probabilmente durante i passaggi da release precedenti il default è stato cambiato o l'ho involontariamente cambiato .. ,non avevo mai provato a mettere fan pin 0 e fan pin 1 perchè mi sembrava anomalo , ora mi è tutto chiaro.

Edited 1 time(s). Last edit at 12/19/2018 05:30AM by silvanopas.
Sorry, only registered users may post in this forum.

Click here to login