Welcome! Log In Create A New Profile

Advanced

Sensore Autobed leveling - BLTOUCH

Posted by Graziano 
Re: Sensore Autobed leveling - BLTOUCH
April 11, 2018 05:31PM
ciao a tutti, mi sono appena comprato il bltouch smart originale per una anycubic delta, stavo capendo come montarlo ma non mi è chiaro in che posizione montarlo, o meglio a quale altezza perchè sulla pagina indigogo

[www.indiegogo.com]

poco dopo la metà, nel paragrafo "CAD Dimension ( BLTouch-Smart )" c'è uno schema che dice (dalla plastica alla punta nozzle) 5.5+2.5 (+-0.5) [cioè da 7.5 a 8.5mm] ma poche righe dopo, c'è il link alla installazione ( BLTouch-Smart Setup manual) che apre un pdf nel quale la stessa distanza è 5,5+3(+-0.3) [cioè da 8.2 a 8.8] ... quindi secondo voi quale altezza è corretta ?

grazie
marco
Re: Sensore Autobed leveling - BLTOUCH
April 16, 2018 05:53PM
ciao a tutti, nel frattempo ho risolto... con qualche tentativo... però non riesco a far funzionare il tutto, ovvero non riesco ad avere una z=0 omogenea sul piatto....

Io faccio così:

(setup , nel firmware impostata bilinear, stampante anycubic kossel linear plus con marli 1.1.8)

M502
M500
M501
G28
G29 V1 P5
ottengo una bella mappa centrata sul piatto:
Bilinear Leveling Grid:
0 1 2 3 4
0 -6.911 -7.506 -7.942 -8.284 -8.565
1 -6.773 -7.277 -7.789 -8.077 -8.287
2 -6.748 -7.298 -7.687 -7.915 -8.078
3 -6.879 -7.518 -7.660 -7.817 -7.979
4 -7.335 -7.737 -7.827 -7.879 -8.029

faccio un M500 e salvo.... ok ma come la uso ? devo mettere uno script in startup ?
inoltre qualunque cosa faccio non riesco ad avere una lineratità nella z, se nel centro ho z=0 preciso in un punto per esempio ho il nozzle che tocca a 0.45
Re: Sensore Autobed leveling - BLTOUCH
April 17, 2018 03:33AM
Se hai quella matrice hai tutto completamente sbagliato i valori devono essere prossimi allo zero. Questo vuol dire che hai il probe offset sbagliato...

Una volta salvato devi attivarlo con M420 S1 dopo G28 nello start gcode...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Sensore Autobed leveling - BLTOUCH
April 17, 2018 08:03AM
ok domani sera provo (sono in trasferta) sebbene mi stiano passando una versione del tuo fw da provare... ora cerco di capire. però perchè alla fine ho una z=0 centrale (ho una delta) perfetta na da un lato sono molto alto (tipo 0.5mm) e dall'altro tocco il piatto tanto che non esce materiale ? dovrebbe comensare... mi sta facendo uscire matto quando lo facevo a mano veniva molto meglio...
Re: Sensore Autobed leveling - BLTOUCH
May 01, 2018 03:42AM
Ciao ragazzi, ho comprato un sensore bltouch ...ho una prusa i3 pro...quando lancio la home mi fa la home x la home y e alla z il pin del sensore va fuori appena tocca il piano il pin si rialza ma il nozzle continua a scendere impattando sul piatto e devo spegnere tutto.
Premetto che ho montato il sensore a 8,2mm dal nozzle , ho caricato un firmware per bl touch dal sito geeetech e non ho fatto altro... va modificato il firmware?...come faccio a settare lo z0?
In allegato ho messi il firmware che ho caricato
Grazie in anticipo
Attachments:
open | download - Marlin-PI3_Pro_B_3DTouch (A+)firmware modificato.zip (324.7 KB)
Re: Sensore Autobed leveling - BLTOUCH
May 01, 2018 08:08AM
Devi attivare Z_SAFE_HOMING per fare la home di Z al centro sul piatto!


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Sensore Autobed leveling - BLTOUCH
July 13, 2018 05:32PM
Ciao, giuro che mi sono letto tutti i post sull'argomento, ed è più di un mese che ci sto su, ma non riesco a venirne a capo!
Premetto che non sono molto afferrato nella configurazione HW di Arduino e dellla RAMPS

Ho una CORE XY con la RRD fan extender, due estrusori e il blTouch.
Ho provato, a mio parere, tutte le possibii configurazioni del firmware, ma la macchina si comporta sempre uguale:

- Ai comandi di apertura/chiusura risponde bene
- Se lancio il test si apre e chiude i continuo e, se ci metto qualcosa sotto per farlo leggere, si chiude e inizia a lampeggiare (Questo già mi fa strano...)
- se lancio l'azzeramento l'asse Z va sempe nella direzione opposta, si ferma apre il bltouch, lo chiude e ri va ancora più giù con la Z. Ripete perdue volte e poi si azzera a Z=3
Anche se gli metto qualcosa a toccare dopo lanciato l'azzeramento, ripete sempre i stessi tre step.

Io credo che non vede il segnale del probe, per una errata configurazione, ma non sono riuscito a trovare niente per risolvere.
In allegato il file Overall, se qualcuno ha voglia di darmi una mano...
Attachments:
open | download - Configuration_Overall.h (45.5 KB)
Re: Sensore Autobed leveling - BLTOUCH
July 13, 2018 05:48PM
Dimenticavo...
Per i collegamenti ho fatto come qui, e poi c'è il file della scheda per l'indirizzamento dei pin (ho solo una ventola per due estrusori, ma ancora il secondo non l'ho mai usato perché ancora la stampante non è finita)
Attachments:
open | download - RRDFanExtenderS.jpg (89.5 KB)
open | download - 34.h (11 KB)
Re: Sensore Autobed leveling - BLTOUCH
July 18, 2018 07:27AM
Ancora sono fermo qui, ahimè!

Ho provato con il firmware Repetier e ho qualche miglioria:
Se lancio solo l'azzeramento di Z1 ho lo stesso problema però, se prima apro il BLtouch con il comando M340 P0 S700, l'asse Z si muove nella direzione giusta e si ferma sul probe (poi comunque inizia a lampeggiare e rimane con il probe aperto)

La cosa che non capisco è perché nel firmware Repetier viene indicato di settare il sensore di Z1 come "Electronic, Normally Closed", mentre su MarlinKinbra mi sembra che impostate tutti come "Switch on GND, Normally Closed", non Electronic insomma, è normale?

Il comportamento mi fa pensare a errori simili a una impostazione errata sul micro, ma le ho provate tutte e non ne vengo a capo.
Con un tester ho controllato il contatto su Z1min. E' sempre aperto, tranne se, dopo aver esteso il probe con il comando, lo pigio a mano. In quel caso il tester suona per un istante.
Questo mi sembra un comportamento corretto no?
Ma, se così fosse, perché viene impostato come NC?

Allego i file di configurazone

Riguardo al grano superiore del bltouch? Ho letto che qualcuno lo muove, in altre parti ho letto che non si deve mai muovere assolutamente.
Che mi dite? potrebbe essere necessaria una regolazione lì?
Attachments:
open | download - Configuration.h (31.6 KB)
open | download - Configuration_Overall.h (53.6 KB)
Re: Sensore Autobed leveling - BLTOUCH
July 18, 2018 09:38AM
Ciao il bltouch lo devi impostare in marlinkimbra come Electronic gnd.
Poi devi attivare il servo dandogli la posizione 10-90°.

Dal comportamento che indichi hai gli endstop configurati male.

Anche io ci sono un po' impazzito all'inizio...
Re: Sensore Autobed leveling - BLTOUCH
July 18, 2018 09:39AM
Ps: nell'ultima versione del bltouch, cioè la smart, la vite di regolazione non va toccata!
Re: Sensore Autobed leveling - BLTOUCH
July 19, 2018 06:28AM
Ciao, innanzi tutto grazie.
Ho fatto come mi hai consigliato, ma cambia poco (in allegato l'Overall).

La direzione di Z durante l'azzeramento è ok adesso, però continua a non fermarsi quando tocca il probe.

Avrei anche delle domande, se mi puoi aiutare:

1 - Abilito SERVO con la 4.3.6, lasciandoci 0, poi apro l'Overall e vedo che su SERVO c'è -1.
Così è abilitato? Con -1 non credo, ma cos'è il configuratore che ha dei problemi?
Comunque poi, come nel file allegato, ci ho messo 0, ma restano sempre i stessi problemi

2 - nella riga sotto a SERVO trovo sempre (90,0) e non 10. Mi hai suggerito di mettere 10,90. L'ordine cambia qualcosa? (comunque ho provato in entrambe le situazioni, era giusto per chiarirmi un po' le idee)

3 - Avendo il FanExtender devo spostare dei PIN. Seguendo le guide online metto D5 e D4 per le ventole, ma se poi vado a controllare nel file 34 (quello della mia scheda RAMPS_13_HHcool smiley, vedo che gli indirizzamenti sono rimasti come originale.
Come mai? Li devo editare io? (vedi allegati)

Grazie, ciao
Attachments:
open | download - Configuration_Overall.h (51.9 KB)
open | download - fan_pin.png (38.9 KB)
open | download - conf.png (62.4 KB)
Re: Sensore Autobed leveling - BLTOUCH
July 20, 2018 03:27AM
Ciao.

Allora, non serve che tocchi nulla nei file interni di MK.

di seguito ti lascio le schermate di come utilizzo io il BLtouch.

La schermata di arduino IDE è riferita al config_overall, dove devi settare correttamente i pullup sui finecorsa e sul bltouch.

Non copiare direttamente tutte le impostazioni in quanto la mia stampante ha logica negata per gli endstop.

Io ho collegato il bltouch su Zmax in quanto Zmin mi serve per fare la home quando uso il laser.

Attento anche su che pin hai collegato il bltouch, in quanto lo devi interfacciare su D11.

Buona giornata

Edited 1 time(s). Last edit at 07/20/2018 03:29AM by whitedavil.
Attachments:
open | download - 2018-07-20 09_17_10-https___marlinkimbra.it_configurator_v4_3_6_firmware_configurator.php.png (80.5 KB)
open | download - 2018-07-20 09_19_42-https___marlinkimbra.it_configurator_v4_3_6_firmware_configurator.php.png (78 KB)
open | download - 2018-07-20 09_20_57-MK4duo - Configuration_Overall.h _ Arduino 1.8.5.png (25.1 KB)
Re: Sensore Autobed leveling - BLTOUCH
July 20, 2018 09:32AM
Niente, non ne vengo a capo.

Ma come mai nel mio configuratore se ttivo il SERVO non mi dà le finestre per mettere i gradi?
Se uso la 4.3.4 sì. Non capisco proprio! (vedi allegati)

Poi ho comunque editato il file e messo come da te, ma non cambia

Per il Z MIN? va bene così??
Ho provato anche a metterlo nel Z MAX come te, ma sempre uguale:
La Z si muove dall'altro verso, poi apre il probe e sse lo tocco due volte azzera a -2.9

Non è che mi potresti passare il tuo OVERALL per confrontarlo?

A questo punto mi viene il dubbio che ho abbia dei problemi sulla RAMPS: tempo fa ho bruciato ARDUINO perché avevo collegato male il Z1 MIN, non vorrei che si fosse danneggiato anche quello...
Attachments:
open | download - 1.png (125.2 KB)
open | download - 2.png (166.9 KB)
open | download - 3.png (93.6 KB)
Re: Sensore Autobed leveling - BLTOUCH
July 20, 2018 10:53AM
Ma scusa, il tuo BLtouch è originale o una copia? Chiedo perchè cambia....

Quando il BLtouch abbassa l'asta, vedi solo il led blu acceso?
Quando il BLtouch ha l'asta su, vedi sia il led rosso che blu accesi?

Forse c'è un problema nel configuratore in quanto vedo che tu hai una COREXY, mentre io ho una cartesiana. ma per questo devi sentire il gentilissimo MagoKimbra.

Ti allego i file di configurazione principali dove dovresti trovare tutte le impostazioni.
Attachments:
open | download - Configuration_Overall.h (52.8 KB)
open | download - Configuration_Pins.h (7.5 KB)
open | download - Configuration_Feature.h (130.1 KB)
Re: Sensore Autobed leveling - BLTOUCH
July 20, 2018 11:25AM
Il BlTouch dovrebbe essere l'originale, lo Smart.
Dico dovrebbe perché anche a me sono sorti dei dubbi.
La confezione era identica a quella del sito Antclabs, con il foglietto della Antclabs che ne attesa l'originalità, qrcode etc.... (allegato)
Però ha il pernetto in plastica, mentre nei video vedo sempre quello in metallo (ma questo forse perché è l'ultimo modello?)
Comunque il led blu non ce l'ha, oppure non si è mai acceso...
Attachments:
open | download - Screenshot_2018-07-20-17-24-16.png (612.7 KB)
Re: Sensore Autobed leveling - BLTOUCH
July 20, 2018 11:33AM
Se non si accende il led blu allora l'endstop è collegato/configurato male. È successo anche a me ed era una questione di cavo e connettore sulla scheda madre, nel tuo caso la ramps.

Io ho acquistato il medesimo dallo stesso venditore su amazon ed è originale. Ma deve avere il perno in alluminio, no plastica....

Per favore fai una foto al sensore a stampante accesa e una a stampante spenta....
Re: Sensore Autobed leveling - BLTOUCH
July 20, 2018 12:05PM
Sono fuori casa, stasera...
Grazie ancora x l'aiuto e l'interesse winking smiley
Re: Sensore Autobed leveling - BLTOUCH
July 20, 2018 05:56PM
ecco le foto winking smiley
Attachments:
open | download - 20180720_235151.jpg (423.7 KB)
open | download - 20180720_235249.jpg (439.9 KB)
Re: Sensore Autobed leveling - BLTOUCH
July 21, 2018 04:51AM
Ok il bltouch è originale. Se a stampante accesa e pin abbassato non hai la luce blu, allora non e collegato correttamente il connettore o non è configurato in maniera giusta l'endstop

Assicurati che il connettore a 3 pin sia su D11

Appena ho tempo guardo il tuo overall
Re: Sensore Autobed leveling - BLTOUCH
July 21, 2018 05:22AM
Vedi foto.
Filo verde è il segnale e va su D11, il nero è +5V e il rosso è GND.

Per favore non dirmi niente sulla scelta dei colori!
Re: Sensore Autobed leveling - BLTOUCH
July 21, 2018 06:53AM
Non sono qui a rompere le palle per le convenzioni elettriche....
Re: Sensore Autobed leveling - BLTOUCH
July 21, 2018 06:54AM
I pin del endstop come e dove li hai collegati?

Normalmente usi zmin o zmax come segnale e gnd

Ps: la foto non si vede!
Re: Sensore Autobed leveling - BLTOUCH
July 21, 2018 09:05AM
Scusa ma mi sono accorto solo adesso che il led blu c'è, e si accende.
In allegato c'è un video con il probe aperto, poi lo tocco con un dito, si chiude e si riapre.
Il funzionamento mi sembrerebbe corretto, no?

Ho aggiunto anche le foto che mancavano prima, più il micro collegato su Z1min
Attachments:
open | download - IMG_20180721_16208.jpg (48.8 KB)
open | download - IMG_20180721_59169.jpg (40.9 KB)
open | download - videocompress-017-20180721_112432.mp4 (318.6 KB)
Re: Sensore Autobed leveling - BLTOUCH
July 21, 2018 10:35AM
No non è normale, se lo estendi fa la luce solo blu.
Poi quando lo tocchi deve salice, accendendo anche la rossa, ma deve stare su.

Ma la stampante non riporta nessun errore riguardo il sensore?

Per scrupolo, prova a rifare la configurazione e caricare mk 4.3.5. Magari è un bug della nuova versione
Re: Sensore Autobed leveling - BLTOUCH
July 21, 2018 11:05AM
Miii con sto BLtouch..

Non devi settare assolutamente nessun grado e altro. Attivi un servo, attivi la sonda bltouch e metti come endstop switch normally closed gnd. Bho fine..
Con il comando M43 S1 lo testi e il firmware ti dice se è tutto ok oppure è un clone.
Se è ok hai fatto, se è un clone allora lo setti come un comune endstop con il servo.

Solo una cosa ricordati che la logica degli endstop come l'attivazione o meno della pullup si salva in eeprom, quindi se la usi, e cambi i parametri riscaricando il firmware la devi resettare con M502 e M500, spegnere e riaccendere...

Edited 1 time(s). Last edit at 07/21/2018 11:06AM by MagoKimbra.


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Sensore Autobed leveling - BLTOUCH
July 22, 2018 12:45PM
Grazie mille a entrambi, ho risolto!

Il problema era tutto nella EEPROM, chiedo scusa ma avevo letto anni fa le guide di MarlinKimbra su come si dovesse utilizzare, ma me ne ero dimenticato e non pensavo che finissero lì anche questi dati.

Provvederò a ristudiarmi un po' le cose.
Grazie ancora
Sorry, only registered users may post in this forum.

Click here to login