Welcome! Log In Create A New Profile

Advanced

Kossel motori non si muovono

Posted by gabrygtt 
Kossel motori non si muovono
November 15, 2016 05:04AM
Buongiorno a tutti, sto realizzando una Kossel XL, come elettronica ho acquistato Arduino 2, RADDS 1.5, driver RAPS128, motori nema 17 0.9°, finecorsa meccanici e schermo touch Nextion.
Alimentazione a 24V.
Ho configurato marlinkimbra tramite il configuratore online omettendo solo i valori relativi all'estrusore in quanto ancora non l'ho acquistato, ora sto cercando di testare motori ed endstop ma non si muove nulla... come programma sto utilizzando Reperier host per Mac.. una cosa che ho notato è che appena connetto la stampante a repetier i motori vanno in tensione e come giusto diventano duri, ma appena lancio un comando per muovere un asse diventano molli.. spero qualcuno mi possa dare una mano, intanto vi ringrazio molto..ciao

p.s. allego file di configurazione
Attachments:
open | download - MK4duo.ino (13.7 KB)
Re: Kossel motori non si muovono
November 15, 2016 05:08AM
Senza sensore di temperatura la scheda si blocca, metti come tipo di sensore nel fw il dummy 998 o 999 che fa rilevare una falsa temperatura di 25°


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Kossel motori non si muovono
November 15, 2016 05:22AM
Caspita questa cosa mi era sfuggita, ti ringrazio molto, stasera provo subito! graziethumbs up

Edited 1 time(s). Last edit at 11/15/2016 05:23AM by gabrygtt.
Re: Kossel motori non si muovono
November 15, 2016 03:29PM
Purtroppo nulla ancora.. ora il sensore rileva si 25 gradi, ma non si muove nulla.. e come accennato sopra, appena avviato reperire i motori diventano duri, e appena do un comando di movimento diventano molli di colpo.....confused smiley
Re: Kossel motori non si muovono
November 15, 2016 06:12PM
Devi invertire l'enable dei motori, molto probabilmente i driver che usi hanno la logica invertita..


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Kossel motori non si muovono
November 16, 2016 02:29PM
Grazie mille Mago, ho invertito gli enable portando il valore da 0 a 1 ma nulla ancora.. non si muove ninete.. caspita mi sono letto un sacco di discussioni, le sto provando tutte ma nulla...
Re: Kossel motori non si muovono
November 16, 2016 05:10PM
Risolto, grazie ancora..cool smiley
allora, ho impostato il Baud rate a 250000, controllato bene di aver gettato gli enable al valore 1, perché l'avevo impostato nella scheda delta.h e non funzionava, una volta impostato nella scheda overall.h finalmente si è mossa..cool smiley
Re: Kossel motori non si muovono
November 16, 2016 05:20PM
Miii ma fallo con il configuratore...
Almeno le modifiche rimangono in memoria, quelle fatte a mano no e quando reimporti il file per aggiornare poi non le hai...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Sorry, only registered users may post in this forum.

Click here to login