Re: RURAMPS - Commenti da chi la usa
December 21, 2018 05:02AM
Quote
thedragonlord
Quote
rosario3dprt
Si. È un problema generalizzato sia sui cloni che sull'originale.
Al boot il DUE non aspetta il tempo sufficiente per fare in maniera corretta la procedura.

Se invece è già alimentarto funziona tutto correttamente.


Puoi risolvere in due modi:

Installi un nuovo boot della scheda che detti i tempi corretti di boot

Oppure

Saldi una resistenza da 10k sulla scheda.

La prima, per ovvi motivi, è preferibile.

Su Internet trovi facilmente diverse pagine che trattano l'argomento e le due soluzioni (ora non li ho a portata di mano)

Ciao
ho provato a cercare il boot cui facevi riferimento ma mi sa che non ho cercato i termini giusti, che testo di recerca dovrei inserire? Ho provato con "arduino due tempi di boot...

Ciao,

scusa il ritardo.

Per la procedura del bootloader puoi seguire questi link:

Tutorial
[www.arduino.cc]
[www.arduino.cc]


Discussione
[translate.google.com]

Il bootloader è in allegato.


Devi avere due schede. Una che ti fa da programmer (su cui caricare uno sketch Arduino ISP) e l'altro che fa da targert (in questo caso l'ArduinoDUE da sistemare).
Per il programmer fai attenzione ai livelli di tensione in uscita. Il DUE accetta solo 3V3. Sul sito consigliano si alimentare comunque tutto a 3V3.

Personalmente finora ho solo applicato la soluzione HW (su due ArduinoDUE ho saldato la resistenza SMD).
Ho altri ArduinoDUE da sistemare e questa volta voglio applicare il metodo SW. Prossima settimana ci provo appena ho un pò di tempo libero.

Ti faccio sapere com'è andata.

Ciao
Attachments:
open | download - Arduino-DUE-usbserial-prod-firmware-2013-02-05_resetfix.hex (11.9 KB)
Re: RURAMPS - Commenti da chi la usa
December 22, 2018 05:09PM
Ma si sa se la nuova scheda sarà una all in one oppure ancora una shield? Processore usato?
Re: RURAMPS - Commenti da chi la usa
December 25, 2018 08:18AM
All-in-one, con alloggio per Raspberry Pi Zero.
Ho un'anteprima della board che mi ha passato Serge ma non la posso postare per ovvi motivi.
Il processore non so, dall'immagine potrebbe anche esser un SAM3X8E, oppure un STM32F401VE, non si capisce.
Re: RURAMPS - Commenti da chi la usa
December 28, 2018 12:37PM
Quote
Marco67
All-in-one, con alloggio per Raspberry Pi Zero.
Ho un'anteprima della board che mi ha passato Serge ma non la posso postare per ovvi motivi.
Il processore non so, dall'immagine potrebbe anche esser un SAM3X8E, oppure un STM32F401VE, non si capisce.

Grazie per l'info!

SAM3X8E è praticamente arduino due, spero nel STM32F401VE altrimenti nasce già un po' vecchiotta.
Peccato anche per Pi Zero, mi risulta non riesca a tenere una camera USB perché lagga...

Però rimango in attesa, a mio avviso la ruramps4d è una delle migliori/più completa shield x due in circolazione
Re: RURAMPS - Commenti da chi la usa
December 29, 2018 12:49PM
Non penso stia andando sui processori STM, a memoria, non ci sono molti FW che li supportano.

Un saluto


Salvatore.


--- Prusa i3 Steel (20x20x20)                        --- Prusa i3 Steel XL (30x30x30)
    Motori 200 passi                                     Motori 400 passi
    Stepper drive - DRV8825                              Stepper drive - DRV8825
    RAMPS 1.4                                            RADDS 1.5
    HotEnd IeC                                           HotEnd IeC
    FW MK4DUO 4.3.2                                      FW MK4DUO 4.3.5
Re: RURAMPS - Commenti da chi la usa
December 29, 2018 04:18PM
Quote
laudix
Non penso stia andando sui processori STM, a memoria, non ci sono molti FW che li supportano.

Un saluto

Peccato! io uso Marlin e lui ha supporto per questo chip
Re: RURAMPS - Commenti da chi la usa
January 04, 2019 05:50AM
Se può essere utile ho visto una nuova scheda che sembra pinout compatibile con mega e due ma usa un cortex M4 a 120MHz

[www.adafruit.com]

se confermata la compatibilità dei pin potrebbe essere usata con ruramps4d 1.3 in sostituzione della due
Re: RURAMPS - Commenti da chi la usa
January 04, 2019 05:55AM
Quote
GZMG
Se può essere utile ho visto una nuova scheda che sembra pinout compatibile con mega e due ma usa un cortex M4 a 120MHz

[www.adafruit.com]

se confermata la compatibilità dei pin potrebbe essere usata con ruramps4d 1.3 in sostituzione della due

Interessante
Re: RURAMPS - Commenti da chi la usa
January 04, 2019 07:42AM
Altrettanto interessante è questa scheda che potrebbe addirittura essere compatibile con l'Arduino MEGA e che consentirebbe di avere un controller a 32 bit sulle schede che normalmente montano un 8bit, oppure di usarlo in sostituzione di Arduino DUE, cominciando ad aprire verso un mondo a 32 bit diverso dai processori AVR.

Un saluto


Salvatore.


--- Prusa i3 Steel (20x20x20)                        --- Prusa i3 Steel XL (30x30x30)
    Motori 200 passi                                     Motori 400 passi
    Stepper drive - DRV8825                              Stepper drive - DRV8825
    RAMPS 1.4                                            RADDS 1.5
    HotEnd IeC                                           HotEnd IeC
    FW MK4DUO 4.3.2                                      FW MK4DUO 4.3.5
Re: RURAMPS - Commenti da chi la usa
January 07, 2019 05:37AM
Qualcuno mi sà dire se con la ruramps 1.3 e arduino due devo modificare qualcosa nell'overall per utilizzare la eeprom della ruramps ?

EDIT

Mi rispondo da solo , non bisogna fare nulla è già implementato nel file 1550.h per ruramps 1.1 e 1551.h per ruramps 1.3, scusate

Edited 1 time(s). Last edit at 01/07/2019 06:21AM by silvanopas.
Re: RURAMPS - Commenti da chi la usa
January 09, 2019 09:27AM
Qualcuno di voi stà utilizzando la RURAMPS 1.3 con i drive TM2130 e SD (MKDUO 4.3.7)?

Ho dovuto disabilitare la SD perchè mi dava problemi con i TMC2130
Sicuramente è un problema di CS...

Come avete risolto?
Re: RURAMPS - Commenti da chi la usa
January 09, 2019 09:38AM
Ciao,

ho anch'io la v1.3 ma non ho avuto ancora modo di testarla.
Ho letto comunque che c'è un problema su un pin del motore E0 (credo proprio il CS) e, in caso si voglia usare i TMC anche per gli estrusore, va fatto un ponticello.

Per quanto riguarda la SD invece leggevo sul gruppo fb MK4Duo che ci dovrebbe essere un problema con la pinnatura.

Vedo se riesco a recuperarlo.


Rosario P.
- CoreXY Autocostruita
con Arduino 2560, RAMPS 1.4, Driver A4988, estrusore bowden con E3D v6, FW MK4Duo 4.3.x_dev
- ShareBot NG modificata in ShaRuBot. Sostituita elettronica con RuRamps4D v1.1 con DRV8825 e Xcarriage ridisegnato per Bowden con E3Dv6. MK4Duo 4.3.x_dev

---- Progetto "Work in progress" CoreXY 3D printer Meccanica OpenBuild su barre V-Slot, piano magnetico riscaldato 300x200, RuRamps4D v1.3 con TMC2130 in SPI e Nextion 7, Estrusore E3Dv6 a 3 colori. Ovviamente latest MK4Duo 4.3.x"      ---- Prossimamente su Thingiverse
Re: RURAMPS - Commenti da chi la usa
January 09, 2019 09:39AM
incredibile.....
Re: RURAMPS - Commenti da chi la usa
January 09, 2019 09:45AM
Scusa rettifico. Per la SD il problema era con la RADDS. Con la RuRamps dovrebbe andare attivando correttamente il FW.

Non so se hai il nextion. In quel caso dei collegarlo nella maniera opportuna seguendo lo schema della scheda
Re: RURAMPS - Commenti da chi la usa
January 09, 2019 09:55AM
Quote
rosario3dprt
Scusa rettifico. Per la SD il problema era con la RADDS. Con la RuRamps dovrebbe andare attivando correttamente il FW.

Non so se hai il nextion. In quel caso dei collegarlo nella maniera opportuna seguendo lo schema della scheda

Forse non sono stato chiaro:

La SD è collegata sul connettore EXP2 e funziona se non monto i tmc2130 , con i TMC 2130 continua a funzionare ma manda in crisi gli assi, se la utilizzo con altri drive passivi tipo A4988 o drv8825 non ho problemi , i collegamenti sono corretti, il problema che la SD non ha un CS dedicato e questo crea problemi e volevo sapere se qualcuno ha risolto con MKDUO.
Lo stesso problema lo hai anche se monti una full graphics sulla ruramps e TMC2130.
Re: RURAMPS - Commenti da chi la usa
January 09, 2019 10:11AM
Si. ok. Ripeto il problema sta proprio sul CS dell'estruso E0 (gli altri sono ok).
Vedi questo link
discussione problema CS di E0 su RuRamps v1.3

E' lungo ma verso la fine c'è anche un'immagine del ponticello da fare.

Non ho risolto io personalmente in quanto non l'ho potuta ancora testare ma ti riporto quanto visto in alcune discussioni.

Stai usando un TMC anche per l'estruso su E0?
Se si, c'è da fare sicuramente una modifica su una pista.
Se no, dovrebbe funzionare.

Se non ricordo male c'era stato anche un problema analogo è hanno risolto impostando i TMC in StealthChoop. Puoi fare anche questa prova.

Ciao


Rosario P.
- CoreXY Autocostruita
con Arduino 2560, RAMPS 1.4, Driver A4988, estrusore bowden con E3D v6, FW MK4Duo 4.3.x_dev
- ShareBot NG modificata in ShaRuBot. Sostituita elettronica con RuRamps4D v1.1 con DRV8825 e Xcarriage ridisegnato per Bowden con E3Dv6. MK4Duo 4.3.x_dev

---- Progetto "Work in progress" CoreXY 3D printer Meccanica OpenBuild su barre V-Slot, piano magnetico riscaldato 300x200, RuRamps4D v1.3 con TMC2130 in SPI e Nextion 7, Estrusore E3Dv6 a 3 colori. Ovviamente latest MK4Duo 4.3.x"      ---- Prossimamente su Thingiverse
Re: RURAMPS - Commenti da chi la usa
January 09, 2019 10:22AM
Quote
rosario3dprt
Si. ok. Ripeto il problema sta proprio sul CS dell'estruso E0 (gli altri sono ok).
Vedi questo link
discussione problema CS di E0 su RuRamps v1.3

E' lungo ma verso la fine c'è anche un'immagine del ponticello da fare.

Non ho risolto io personalmente in quanto non l'ho potuta ancora testare ma ti riporto quanto visto in alcune discussioni.

Stai usando un TMC anche per l'estruso su E0?
Se si, c'è da fare sicuramente una modifica su una pista.
Se no, dovrebbe funzionare.

Se non ricordo male c'era stato anche un problema analogo è hanno risolto impostando i TMC in StealthChoop. Puoi fare anche questa prova.

Ciao

Sapendo del problema di E0 ho utilizzato E1 come estrusore con un TMC , questa sera provo a mettere un DRV8825 su E0 e vediamo se il problema rimane (avevo provato anche con Stealtchop) , poi vi aggiorno. Grazie per l'interessamento

Edited 1 time(s). Last edit at 01/09/2019 10:23AM by silvanopas.
Re: RURAMPS - Commenti da chi la usa
January 10, 2019 03:09AM
Ieri sera ho provato con un DRV8825 e il problema di conflitto con la SD rimane (e ne ero convinto) , inoltre ho notato che il CS della SD è collegato (mi ero sbagliato) , però non trovo nessuna DEFINE di questo pin...

Ora stavo guardando il file 1551.h in MKDUO\src\boards e ho notato che se si utilizza il NEXTION non viene definito SD_DETECT_PIN che andrebbe messo a 51 , potrebbe essere quello il problema ? Appena arrivo a casa provo..
Re: RURAMPS - Commenti da chi la usa
January 10, 2019 07:14AM
Il pin detect serve solo per sapere se la sd è dentro o meno, se non c'è all'accensione viene montata la scheda, se la trova dentro ti da i file se non la tova per lui non c'è e fin quando non gli dai il comando di mount non caria i file...
Il CS pin è quello chiamato SDSS che nella 1551.h è:
#define SDSS 4


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: RURAMPS - Commenti da chi la usa
January 10, 2019 07:28AM
Si mentre mi scrivevi avevo trovato la definizione di SDSS in 1551.h, e anche il DETECT so a che serve .... , è che non ne riesco a venire fuori da questo problema, consigli?

Edited 1 time(s). Last edit at 01/10/2019 07:28AM by silvanopas.
Re: RURAMPS - Commenti da chi la usa
January 10, 2019 10:41AM
Marco Robustini in FB usa la ruramps 1.3 con i TMC2130 display e sd senza alcun problema: quindi riverifica tutti i pin, se un solo CS non va bene blocca la porta SPI.
PEr effettuare la prova stacca tutti i driver abilitali e prova la SD vedrai che va, come quando non sono abilitati. Poi ne metti uno a uno finché non trovi quello che blocca la porta SPI..


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: RURAMPS - Commenti da chi la usa
January 10, 2019 10:48AM
Non ho fatto modifiche ai pin , sono quelli definiti nel file 1551.h , comunque questa sera provo drive x drive , thanks
Re: RURAMPS - Commenti da chi la usa
January 10, 2019 12:44PM
Ciao
Ho preso il mio overall dato in pasto al configuratore 4.3.7 del 10/01/19 ricompilato e ora funziona sia SD che TMC2130, non so se hai fatto delle modifiche ma ora va...confused smiley
Re: RURAMPS - Commenti da chi la usa
January 10, 2019 03:42PM
Assolutamente nulla su SD e TMC!!!


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: RURAMPS - Commenti da chi la usa
January 16, 2019 05:31AM
Mi sono accorto che ogni tanto mi risponde Write error quando utilizzo il comando M500 , poi se magari lo riscrivo una seconda volta tutto ok , potrebbe essere un problema della eeprom montata sulla ruramps?

A nessuno capita?
Re: RURAMPS - Commenti da chi la usa
January 16, 2019 08:11AM
Quote
silvanopas
Mi sono accorto che ogni tanto mi risponde Write error quando utilizzo il comando M500 , poi se magari lo riscrivo una seconda volta tutto ok , potrebbe essere un problema della eeprom montata sulla ruramps?

A nessuno capita?

Ho sostituito nei due punti del file I2cEeprom.cpp contenuto in MKDUO/scr/platform/common

HAL::delayMilliseconds(5);

com

HAL::delayMilliseconds(10);

molto probabilmente bastavano 6 millisecondi....

e ora non mi dà più problemi di scrittura.
molto probabilmente la eeprom che monta il russo è lenta o al limite.

X Mago puoi renderla definitiva nel firmware (oppure una if condizionata alla ruramps)? grazie
Re: RURAMPS - Commenti da chi la usa
January 17, 2019 02:32AM
Ok fatto!!!


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: RURAMPS - Commenti da chi la usa
February 18, 2019 07:40AM
Per chi avesse errori di "TMC connection error" utilizzando i driver FYSETC in SPI su RuRamps, i driver vanno "settati" in modalità SPI.



Grazie a Marco Robustini che mi ha dato la dritta.

Ora ho una nuova CoreXY multiestrusore/single-nozzle su ruote OpenBuilds quasi ultimata (devo lavorare ancora sugli estrusori) spinning smiley sticking its tongue out


Rosario P.
- CoreXY Autocostruita
con Arduino 2560, RAMPS 1.4, Driver A4988, estrusore bowden con E3D v6, FW MK4Duo 4.3.x_dev
- ShareBot NG modificata in ShaRuBot. Sostituita elettronica con RuRamps4D v1.1 con DRV8825 e Xcarriage ridisegnato per Bowden con E3Dv6. MK4Duo 4.3.x_dev

---- Progetto "Work in progress" CoreXY 3D printer Meccanica OpenBuild su barre V-Slot, piano magnetico riscaldato 300x200, RuRamps4D v1.3 con TMC2130 in SPI e Nextion 7, Estrusore E3Dv6 a 3 colori. Ovviamente latest MK4Duo 4.3.x"      ---- Prossimamente su Thingiverse

Re: RURAMPS - Commenti da chi la usa
February 21, 2019 01:16AM
Buongiorno a tutti, ho appena finito di montare la mia RuRamps4D 1.3 ed ho alcune perplessità, spero che qualcuno possa aiutarmi a venirne a capo.

Innanzitutto qualche info sul mio setup: ho una cartesiana autocostruita su telaio tatara 1.1 in acciaio, i 2 motori Z sono collegati uno su Z e l'altro su E1, il bltouch è collegato sulla porta apposita. ho i TL-smoother su tutti i motori, DRV8825 per tutti i motori tranne l'estrusore che usa un A4988. Utilizzo Marlin 2.0 ultima bugfix.

Domanda 1: BLTOUCH
Ho configurato il bltouch seguendo le info sparse qua e la su internet e diciamo che funziona: segue i comandi M280 e riesco a fare sia l'homing con G28 che il leveling con G29. Il problema è all'accensione della stampante: Il blt dovrebbe eseguire un self test abbassando il probe un paio di volte e poi accendere il led rosso. Il mio non lo fa ed il led rosso inizia a lampeggiare lentamente, nella condizione che sul sito antclab viene definita 'wiring error'.
La cosa divertente è che se scollego il pin del signal (arancione) e lascio collegata solo l'alimentazione (rosso e marrone) il sensore fa il test correttamente e senza errore, attaccando il signal dopo il test tutto funziona. Altra cosa buffa.. il mio sistema prima girava su una Ramps 1.4 e ricordo che il led blu del bltouch emetteva una luce più intensa… è normale ?
Potrebbe essere il passaggio da 5V a 3.3V ? Ma sulla RuRamps4D il bltouch è alimentato a 5V o 3.3V ? Sul sito antclab dicono di tagliare una pista per lavorare a 3.3 ma non mi sono azzardato a farlo (ancora).

Domanda 2: Spunto all'accensione
Ho notato che all'accensione i motori fanno un rumore abbastanza forte, cosa che prima con la Ramps 1.4 non accadeva, almeno non così. Qualcuno ha trovato un motivo o una soluzione ? Potrebbe essere un picco di tensione o qualcosa di simile ? Stavo riflettendo che il bltouch è un servo meccanico emulato e magari lo 'spunto' di accensione arriva anche a lui e provoca il fallimento del test..

Avete qualche idea ? Devo comprarmi un oscilloscopio e iniziare a testare tutte le uscite PWM ?

Grazie a tutti per le risposte.
Re: RURAMPS - Commenti da chi la usa
February 21, 2019 01:28AM
Ho trovato questo schema che ti dice come collegarlo
[www.google.it]

E qui l'articolo
[3dtoday.ru]

Edited 4 time(s). Last edit at 02/21/2019 01:44AM by silvanopas.
Sorry, only registered users may post in this forum.

Click here to login