Welcome! Log In Create A New Profile

Advanced

Problema Ruramps1.1 e Arduino due originale

Posted by Bumbex 
Problema Ruramps1.1 e Arduino due originale
March 05, 2019 07:05AM
Ciao a tutti, ho un problema con la Ruramps 1.1 e arduino due , quando la scheda è alimentata e collego la porta USB mi fa spegnere il computer e viceversa se accendo la stampante e la USB è collegata fa l ho stesso problema, misurato la tensione sul cavo USB che va da stampante al pc e mi da 7 volt, pensavo di creare un cavo USB senza alimentazione tenendo sempre la massa , può essere una soluzione o avete altri consigli?

PS. 2 VOLTE su 10 mi segna 5 volt e quando collego il pc non si spegne.
Re: Problema Ruramps1.1 e Arduino due originale
March 05, 2019 07:59PM
Non è una soluzione, se usi un portatile potrebbe essere dovuto al tipo di alimentatore del portatile, oppure ai "loop di corrente" , ahime è un problema comune e si risolve, "stampando da SD" o suando il WiFi, a meno di non acquistare un cavo USB con isolamento galvanico, oppure optoisolato che però costa una paccata di soldi, altra soluzione potrebbe essere quella di usare un "traformatore di isolamento" che alimenti il portatile oppure la stampante, in quesot modo non vendo "collegamenti comuni" essendo la fase ed il neutro di un uitlizzatore (in genere quello a doppio isolamento) non collegate "elettricamente" con quelle dell'altro utilizzatore, ma solo attraverso l'accoppiamento "magnetico" delle spire del trasformatore non ci dovrebbero essere "loop di corrente" tra i capi della USB.

Saluti

Carlo D.


P3Steel - MKS GEN v1.2 e REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER + Gen 7 MOSFET (HotBed) + alimentatore step-down 12V -> 5V
Firmware MK4duo 4.3.5 (4.3.6 in testing) con ABL capacitivo - Slic3R (Originale) ed ESP3D per controllare la stampante da remoto.
HotEnd Cinese V6 clone con ugello da 0.4mm.

[My Building Log]
Re: Problema Ruramps1.1 e Arduino due originale
March 06, 2019 12:50AM
grazie per le informazioni importanti, quindi consiglieresti di mettere un trasformatore di isolamento tra l alimentatore della stampante alla scheda che devo alimentare?
Re: Problema Ruramps1.1 e Arduino due originale
March 06, 2019 01:35PM
Ad uno dei due capi, ovviamente dato che il traformatore di isolamento non prevede la "messa a terra" e in genere la stampante ha la messa a terra, mentre l'eventuale portatile in genere è a "doppio isolamento" quindi il suo alimentatore non ha la "messa a terra" sarebbe meglio metterlo dal lato portatile, in genere la messa a terra è rara negli alimentatori dei portatili perché poi, l'uscita prevede una tensione continua con solo un positivo ed un negativo.
Il problema in genere deriva dal fatto che il negativo a volte è "accoppiato" alla carcassa di schermatura che a sua volta è collegata da una rete RC oppure da due condensatori alla fase e al neutro della tensione di rete, provocando i problemi, usando un "trasformatore di isolamento" ottieni una "separazione galvanica" dei due circuiti che hanno in comune solo "l'accoppiamento magnetico" delle spire del trasformatore.


Se però usi un computer desktop il problema si complica, ed allora mi sa che devi ricorrere a qualche "artificio diverso", stampare da SD, usare il WiFi oppure usare una comunicazione rs232 con un capo optoisolato (in genere quello che va alla stampante , bypassando il convertitore USB integrato nella scheda Arduino), però non so se arduino Due abbia la USB nativa cioè integrata nel chip Atmel in quel caso non hai seriali rs232 da poter usare come comunicazione optoisolata.


Saluti

Carlo D.


P3Steel - MKS GEN v1.2 e REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER + Gen 7 MOSFET (HotBed) + alimentatore step-down 12V -> 5V
Firmware MK4duo 4.3.5 (4.3.6 in testing) con ABL capacitivo - Slic3R (Originale) ed ESP3D per controllare la stampante da remoto.
HotEnd Cinese V6 clone con ugello da 0.4mm.

[My Building Log]
Re: Problema Ruramps1.1 e Arduino due originale
March 07, 2019 01:18AM
buongiorno e grazie ancora, ho trovato il problema , fatto delle prove staccando arduino due e alimentando la scheda direttamente dall ingresso Vin con 9 volt ,sul cavo USB mi da tensione di 7 volt mentre se do sul Vin 7 volt sul cavo USB mi da 5volt , in teoria dovrebbe essere 5 volt stabilizzato o addirittura non dovrebbe esserci alimentazione , consigli?
Re: Problema Ruramps1.1 e Arduino due originale
March 07, 2019 01:53PM
Ciao Bumbex,
come tutti gli Arduini c'è un circuito interno che seleziona se alimentare la scheda dal connettore di alimentazione/dai terminali o dalla porta USB. Se metti solo un tester da lato USB e alimenti l'Arduino, in virtu dell'alta impedenza dello strumento oterrai comunque una lettura, ma in genere non è quello il problema. Esistono invece seri problemi di loop di corrente sulle masse e disturbi indotti nel collegare una stampante 3D ad un pc, che sono quasi sempre da imputare agli alimentatori della stampante e che sono particolarmete subdoli da individuare.
Concordo con onekk che come soluzione veloce è economica meglio se prendi l'abitudine di stampare da SD, o che ti collegli alla stampante da un portatile alimentato a batterie.
Personalmente non ho mai avuto problemi ma sto comunque verificando come aggiungere ad Arduino con un convertitore ethernet/uart senza modificare il firmware, bypassando l'ATmega16U2 che è usato come convertitore USB/seriale sia sulla Mega che sulla DUE, e per ma per mancanza di tempo (leggi pigrizia) ho anche ordinato un componente che promette di separare galvanicamente la connessione USB con poche decine di euro. Eventualmente dopo che l'ho testato, se nessuno ha niente in contrario, posso postare il link di dove acquistarlo.

Edited 1 time(s). Last edit at 03/07/2019 01:55PM by truck64.


Luca
Re: Problema Ruramps1.1 e Arduino due originale
March 07, 2019 03:17PM
grazie truck64 , mi farebbe piacere sapere il link prossimamente, fatto delle prove con un arduino mega normale alimentandolo dal Vin e sul cavo usb da zeo volt, domani dovrebbe arrivarmi un arduino 2 nuovo e vi facci sapere
Re: Problema Ruramps1.1 e Arduino due originale
March 08, 2019 04:12PM
ciao a tutti ,fatto prove con scheda nuova e mi da lo stesso problema
, scheda collegata con usb portatile e se nel Vin/Jack collego batteria 9 volt mi spegne portatile
Re: Problema Ruramps1.1 e Arduino due originale
March 09, 2019 04:41AM
Ciao Bumpex,
quello che dici è molto strano, e avendo tempo sarebbe interessante capirne le cause.
Come ho detto sopra non ho ancora testato l'interfaccia di isolamento USB, quindi non ho indicazioni certe per ora.
Se hai tempo e voglia di fare qualche prova ti consiglo di fare una ricerca riguardo i componenti che usano l'ADuM4160 di AnalogDevice.
Ci sono molti post di gente che riporta la sua esperienza in relazione all'uso con Arduino.
E per quanto riguarda schedine acquistabili in rete ne trovi parecchie in vendita a costi anche contenuti.

Edited 2 time(s). Last edit at 03/09/2019 04:42AM by truck64.


Luca
Re: Problema Ruramps1.1 e Arduino due originale
March 11, 2019 01:05PM
Ciao leggendo in giro c’è una problematica di boot, praticamente bisogna saldare una resistenza.... quando mi arrivano provo e ti faccio sapere
Sorry, only registered users may post in this forum.

Click here to login