Welcome! Log In Create A New Profile

Advanced

Problema esttusore con Petg

Posted by filofilato 
Problema esttusore con Petg
November 11, 2018 04:36PM
Buonasera a tutti.

Oggi ho stampato per la prima volta con petg.
Mentre con pla non ho problemi con il petg invece l esttusore scatta.
Ho alzato la temperatura a 246 ed il problema è diminuito un poco.
Abbassando la velocità a 40 ce la fa quasi.
Ho paura a salire ancora con la temperatura per il ptfe.
Potrebbe esse e il caso di verificare la vref? (Mai verificata prima)
Grazie
Filo
Re: Problema esttusore con Petg
November 12, 2018 01:41AM
Quote
filofilato
Buonasera a tutti.

Oggi ho stampato per la prima volta con petg.
Mentre con pla non ho problemi con il petg invece l esttusore scatta.
Ho alzato la temperatura a 246 ed il problema è diminuito un poco.
Abbassando la velocità a 40 ce la fa quasi.
Ho paura a salire ancora con la temperatura per il ptfe.
Potrebbe esse e il caso di verificare la vref? (Mai verificata prima)
Grazie
Filo

Servirebbe qualche altra info...
... anche solo che stampante hai, che estrusore usi, che hotend, insomma le basi...


Qualcosetta più che un neofina oramai, anche se non si finisce mai d'imparare!
DUE Stampati GEEETech i3B, GT2560+, Marlin GEEETech originale con un paio di modifichine personali (Pin dedicato per la Z Probe e stampa dell'ETE da SD), Barre Trapezie, Estrusore da 0.3 con filo da 1.75, una con estrusore metallico ed una con estrusore ridisegnato e stampato da me, Software AutoCAD/Slic3r/Repetier

My Thingiverse
My Linkedin
Re: Problema esttusore con Petg
November 12, 2018 04:50AM
Sei sicuro che la temperatura che leggi sia quella "vera" tanto per informazione il mio estrusore indicava una temperatura di 20°C superiore a quella misurata con un termometro a termocoppia.

Per il PTFE in teoria regge bene i 240°C dovrebbe avere un limite di 250°C, però su molti hot end è possibile montare un "core" all-metal che non ha problemi con temperature "limite".

Occhio però ad una cosa se mescoli materiali a volte si creano strani miscugli che carbonizzano all'interno della "gola" dell'estrusore, ad esempio io dopo aver stampato ABS non riesco più a stampare il PLA senza dover pulire benissimo il "core" del mio Hot End.

Lo scatto potrebbe essere sia il rumore dell'estrusore che "perde" passi sia il rumore dei denti che "strappano" sul filo, sta a te capire la causa del rumore ed agire do conseguenza sulle molle di regolazione del carico del cuscinetto dell'estrusore.

Saluti

Carlo D.


P3Steel - MKS GEN v1.2 e REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER + Gen 7 MOSFET (HotBed) + alimentatore step-down 12V -> 5V
Firmware MK4duo 4.3.5 (4.3.6 in testing) con ABL capacitivo - Slic3R (Originale) ed ESP3D per controllare la stampante da remoto.
HotEnd Cinese V6 clone con ugello da 0.4mm.

[My Building Log]
Re: Problema esttusore con Petg
November 12, 2018 07:10AM
Hai ragione Luca,

la stampante è un a Anet E12 le prove le sto facendo con estrusore da 0,4 e larghezza filamento impostata a 0,35
l'hot end è quello che era in dotazione ed è simile a quello di questa foto che allego.

Carlo grazie,
Per quanto riguarda il problema non si tratta di scivolamento della ruota godronata ma è proprio il motore dell'estrusore che perde il passo e lo fa molto spesso anche ogni 3- 5 secondi.
Si vede il motore che torna indietro in maniera evidente (non è retrazione).

Cercando in rete che vedo che probabilmente (verifico stasera) la mia scheda non ha i driver con potenziometri a regolazione meccanica ma probabilmente la regolazione delle vref avviene sul firmware.
Stasera aggiorno.

Edited 1 time(s). Last edit at 11/12/2018 07:11AM by filofilato.
Attachments:
open | download - hot.JPG (27.4 KB)
Re: Problema esttusore con Petg
November 12, 2018 11:23AM
Confrmato la mia scheda è una Anet V1-5 e non ha i trimmer fisici (ne ha uno solo).
A quanto ho letto i valori della vref si settano da firmware-
Mi pare anche che si settino anche col comando G130 anche se non sono riuscito a chiarirmi esattamente come.

lego sul wiki che:

G130 X10 Y18 Z15 A20 B12
Set the digital potentiometer value for the given axes. This is used to configure the current applied to each stepper axis. The value is specified as a value from 0-127; the mapping from current to potentimeter value is machine specific.

prima di modificare i settaggi del firmware vorrei però leggere quali valori sono impostati ora sul parametro G130.

Qualcuno può aiutarmi ?
Re: Problema esttusore con Petg
November 12, 2018 12:08PM
Quote
filofilato
...le prove le sto facendo con estrusore da 0,4 e larghezza filamento impostata a 0,35...

mi paiono paramentri quanto meno bizzarri da mettere in coppia...
... credo che la perdita passi che accusi sull'estrusore possa essere imputata a due potenziali cause:
  1. temperatura non adeguata al filo che usi
  2. errata impostazione del valore dell'extrusion multiplier nello slicer
Personalmente io faccio, per ogni bobina, sia la torre delle temperature che la calibrazione dell'extrusione multiplier (ho spiegato qui come faccio il tutto), e rarissimamente ho delle perdite passi nell'estrusore, anche con il PETG che è più rognoso del PLA!


Qualcosetta più che un neofina oramai, anche se non si finisce mai d'imparare!
DUE Stampati GEEETech i3B, GT2560+, Marlin GEEETech originale con un paio di modifichine personali (Pin dedicato per la Z Probe e stampa dell'ETE da SD), Barre Trapezie, Estrusore da 0.3 con filo da 1.75, una con estrusore metallico ed una con estrusore ridisegnato e stampato da me, Software AutoCAD/Slic3r/Repetier

My Thingiverse
My Linkedin
Re: Problema esttusore con Petg
November 12, 2018 12:21PM
Allora la regolazione della Vref può essere una causa, ma se hai l'estrusore originale, in teoria dovrebbe essere tarata in fabbrica, non conoscendo la scheda probabilmente ci sarà in giro una tabella che permette di avere una relazione tra il valore del comando G130 e la relativa corrente fornita agli stepper.

Rimane comunque sempre la possibilità che la molla dell'estrusore prema "troppo" sul cuscinetto con il filamento PetG, se hai una regolazione, io proverei a segnare la posizione e poi provare ad allentare la vite di regolazione di un quarto di giro e vedere come va, se diminuisce sai che bisogna scaricare la molla con quel materiale, ovviamente se diminunisce ma non sparisce.

Alcuni estrusori hanno le viti solo "di bellezza" o meglio servono solo per guidare la molla, sta a te capire se il ruo agisce sulla tensione della molla oppure se devi giocare con spessori o altro per caricare la molla, oppure tagliare la molla in modo da accorciarla e aggiungere spessori alla bisogna come nel caso di un mio estrusore del tipo tutto in metallo.

Saluti

Carlo D.


P3Steel - MKS GEN v1.2 e REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER + Gen 7 MOSFET (HotBed) + alimentatore step-down 12V -> 5V
Firmware MK4duo 4.3.5 (4.3.6 in testing) con ABL capacitivo - Slic3R (Originale) ed ESP3D per controllare la stampante da remoto.
HotEnd Cinese V6 clone con ugello da 0.4mm.

[My Building Log]
Re: Problema esttusore con Petg
November 12, 2018 01:26PM
intanto grazie Luca e grazie Carlo,
vi rispondo :

Scusa Luca maledetta la mia ignoranza il filamento è da 1,75 per 0,35 intendevo il wall line with...........

Sono anche io dell' idea che salendo con la temp possa migliorare ma non so fino a che temperatura posso spingermi per non danneggiare il teflon dell' hot end.
Sono arrivato a 246 posso salire?

L'extrusion multiplier l'avevo verificato (anche se non così approfonditamente come nella tua procedura) e pensavo che una volta impostato (ora era 82%) non fosse da modificare ogni bobina;

Avevo anche verificato la lunghezza di filo estruso in relazione al comando ed ora è corretta (questa non penso sia da riverificare vero?)

Verifico sicuramente il valore del flusso ma la mia impressione è che il problema sia più grossolano di un 10-15% di materiale + o -......... comunque procedo.

Carlo,

non ho viti di regolazione sull'estrusore,
il problema appare nettamente solo con petg che ha diametro uguale (ameno di un paio di centesimi) al pla. per cui sarei portato ad escludere una questione meccanica sull'estrusore.
Re: Problema esttusore con Petg
November 12, 2018 02:56PM
Quote
filofilato
...per 0,35 intendevo il wall line with...

Scusa ma mi sono di nuovo perso...
... se non sbaglio avevi detto che usi un nozzle da 0.4, ed in tal caso mi pare che 0,35 di larghezza di tratto sia un valore errato...
... che slicer usi?


Qualcosetta più che un neofina oramai, anche se non si finisce mai d'imparare!
DUE Stampati GEEETech i3B, GT2560+, Marlin GEEETech originale con un paio di modifichine personali (Pin dedicato per la Z Probe e stampa dell'ETE da SD), Barre Trapezie, Estrusore da 0.3 con filo da 1.75, una con estrusore metallico ed una con estrusore ridisegnato e stampato da me, Software AutoCAD/Slic3r/Repetier

My Thingiverse
My Linkedin
Re: Problema esttusore con Petg
November 12, 2018 03:04PM
io pensavo potesse andare bene diciamo tra 0,35 e 0,4
si ho nozzle da 0,4
quali valori posso mettere?


nel frattempo ho rimesso in quadro il carrello delle x , era una cosa che volevo fare da un po
ora che è rimontato vado con la prova del flusso

Edited 3 time(s). Last edit at 11/12/2018 03:07PM by filofilato.
Re: Problema esttusore con Petg
November 12, 2018 03:52PM
Prova di extruder multiplier fatta:
il risultato corretto è stato di 0,9 mentre prima usavo 0,82.

Il problema si propone sempre anche se le stampe sono più che accettabili anzi il cubetto di prova è venuto molto bene con superfici laterali e orizzontale buone

durante la stampa del blocchetto 20x20x10 l'estrusore perde passo ogni 5 secondi circa nei layer iniziali (quelli pieni) e poi nei layer superiori dove fa solo il profilo circa ogni 40 secondi
Re: Problema esttusore con Petg
November 13, 2018 02:04AM
Quote
filofilato
...l'estrusore perde passo ogni 5 secondi circa nei layer iniziali (quelli pieni) e poi nei layer superiori dove fa solo il profilo circa ogni 40 secondi

Hai fatto anche la torre delle temperature per "scovare" la giusta temperatura per il filo che stai usando sulla tua stampante?
Sai, ogni filo si comporta in modo leggermente differente su ogni stampante, soprattutto quando sono fili non del produttore della stampante e quando si ha a che fare con stampanti costruire da se o da un kit... la grande differenza fra le stampanti "pro" e le nostre è proprio l'accurato accoppiamento di stampante, materiali e software!


Qualcosetta più che un neofina oramai, anche se non si finisce mai d'imparare!
DUE Stampati GEEETech i3B, GT2560+, Marlin GEEETech originale con un paio di modifichine personali (Pin dedicato per la Z Probe e stampa dell'ETE da SD), Barre Trapezie, Estrusore da 0.3 con filo da 1.75, una con estrusore metallico ed una con estrusore ridisegnato e stampato da me, Software AutoCAD/Slic3r/Repetier

My Thingiverse
My Linkedin
Re: Problema esttusore con Petg
November 13, 2018 04:43AM
Ciao Luca,

si mi rendo perfettamente conto che l'uso di queste stampanti sia in pieno campo hobbistico e avevo messo in conto un bella dose di smanettamenti...........
anzi ti dirò che è proprio il bello di questa cosa.

Ho scelto questa stampante sapendo che la messa a punto sarebbe stata articolata e ampia ma come pensavo sto conoscendo la stampante molto più a fondo che se ne avessi presa una "apri e stampa".

Ho finito proprio irei di metterla in squadra, aveva infatti tutta la meccanica sballata sia del carrallo x sia dell assi z sia del piano di stampa, non c'erano due assi paralleli e tree in squadra..................
dopo un paio di interventi radicali ora il livellamento del piano è molto facile ed ho dei primi layer più che accettabili.
Tra l'altro mi sto affacciando sul mondo di arduino (di cui ho un kit molto completo mai usato) e la cosa mi affascina molto.

Per risponderti, non ho fatto la torre della temperatura tutta insieme come la proponi tu ma ho stampato il materiale a 210-220-230-240-250 su provini identici e non ci vedo tutta questa gran differenza anche se sembra un po meglio a 250°.


L'estrusore perde passi ad ogni temperatura anche se il fenomeno diminuisce un po all'aumentare della temperatura medesima.
Ho qualche dubbio sulla veridicità della temperatura indicata: I valori della temperatura li prendo dal sensore sull' hot end perchè non ho termometri a infrarossi.

Ho qualche perplessità sulla temperatura anche perchè in pratica il filo estruso (facendo estrudere a vuoto) a partire dai 220 gradi fino ai 250 non sembra variare moltissimo la sua viscosità.

Quello che noto è che il PLA a 200 gradi esce bello perpendicolare dall'estrusore (sempre estrusione a vuoto) mentre il PETG alle varie temperature tende a fare dei ricciolini...........non so se è una cosa indicativa.
Questa cosa si riflette anche sulla qualità di stampa che con il PETG sulle superfici lascia a vista i vari fili separati e distinguibili............
Anche per questo oltre che allo scatto dell'estrusore sospetto bassa temperatura nonostante le indicazioni dello schermo.
Vorrei provare a salire ancora ma non riesco a trovare da nessuna parte il limite di temperatura sopportabile dal tubetto in teflon che sta dentro all'estrusore.
Fino a che temp posso spingermi per non rischiare di scioglierlo?

Edited 1 time(s). Last edit at 11/13/2018 04:45AM by filofilato.
Re: Problema esttusore con Petg
November 13, 2018 05:53AM
Quote
filofilato
...Vorrei provare a salire ancora ma non riesco a trovare da nessuna parte il limite di temperatura sopportabile dal tubetto in teflon...

Mi pare che sei comunque già bello alto di temperature, il PETG si dovrebbe stampare "più basso", qui sei alle temperature dell'ABS!

Per la perdita passi sull'estrusore, quello che tu chiami scatto, vi è sempre la possibilità che la VREF del driver sia troppo bassa e/o che la molla di precarico del feeder non prema abbastanza...
... hai provato a controllare la VREF e provare a dare più precarico al feeder?


Qualcosetta più che un neofina oramai, anche se non si finisce mai d'imparare!
DUE Stampati GEEETech i3B, GT2560+, Marlin GEEETech originale con un paio di modifichine personali (Pin dedicato per la Z Probe e stampa dell'ETE da SD), Barre Trapezie, Estrusore da 0.3 con filo da 1.75, una con estrusore metallico ed una con estrusore ridisegnato e stampato da me, Software AutoCAD/Slic3r/Repetier

My Thingiverse
My Linkedin
Re: Problema esttusore con Petg
November 13, 2018 07:06AM
Sulla non presenza di regolazioni ho qualche dubbio, una molla da qualche parte ci deve essere, nel caso basta spessorare per aumentare e tagliare e spessorare meno per diminuire.

Sul fatto che il diametro del filo sia corretto non ho dubbi, però una cosa è partire con un materiale "duro" come il PLA, cosa diversa è con una plastica come il PET che è leggermente morbida e "scivolosa", dovresti vedere se riesci come viene compresso dai denti dell'estrusore, se ha segni troppo marcati devi scaricare la molla, a volte viene deformato e zigrinato e forza sul condotto invece di scivolarci.

Però se la stampante ha un blocco unico devi smontare la parte calda ed estrudere solo filo, misurare e vedere come tarare l'extrusion multiplier.

Ho dato un'occhio alla scheda, praticamente è la vecchia 1.0 con qualche miglioria ali componenti, ma è dedicata a quella classe di stampante, ha solo una regolazione della Vref sullo Z probabilmente per adattarsi a diversi "carrelli" a 1 o due motori.

qualcuno però ci ha caricato Marlin 1.1.9

Link


Per l'estrusore non ho trovato foto, ma probabilmente ha il core attaccato all'uscita del gruppo spingifilo per cui devi smontare il riscaldatore e il termistore ed estrudere da lì. Prova a cercare una modifica Bowden

Estrudi 10 cm, misuri e facendo le proporzioni ottieni un valore percentuale da mettere nel "extrusion multiplier", nel frattempo vedi come esce il filamento in termini di segni o deformazioni.

Smanettare si ma farlo con metodo e cognizione di causa, altrimenti non ne vieni a capo se non per una botta di ....

Saluti

Carlo D.

Edited 1 time(s). Last edit at 11/13/2018 07:17AM by onekk.


P3Steel - MKS GEN v1.2 e REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER + Gen 7 MOSFET (HotBed) + alimentatore step-down 12V -> 5V
Firmware MK4duo 4.3.5 (4.3.6 in testing) con ABL capacitivo - Slic3R (Originale) ed ESP3D per controllare la stampante da remoto.
HotEnd Cinese V6 clone con ugello da 0.4mm.

[My Building Log]
Re: Problema esttusore con Petg
November 13, 2018 07:24AM
This comes with ANET's firmware which has a bad reputation. Flashing this to Marlin is doable but unlike with the v1.0 board, you will need to flash the bootloader via the J3 header before you can flash Marlin via USB. You will need a 10 pin USBasp and a 10 to 6 pin convertor to flash the bootloader.

* Download the Arduino IDE.
* Download Marlin.
* Configure Marlin in the Arduino IDE with your settings.
* Plug in the board-side of the USBasp using an adapter in to the middle of J3 (SCK faces the notch - you should google for diagrams).
* Plug in the second board-to-computer USB cable at the top of the board.
* Plug in the ANET A8 Power.
* Plug in the computer side of the USBasp.

PLEASE NOTE: many tutorials say you don't need power to your board to flash it. However, if you have other things plugged into the board, such as fans, they could potentially try to start after rebooting from the flash, which will draw power from your USBasp and burn it out. I was able to flash my board just fine with it plugged into my ANET power supply.

* Install the USBasp drivers (I used zadig and selected the libusbK v3.0.7.0 driver).
* In the IDE, go to tools and then select "ANET v1.0 (optiboot)", you may have to download this separately.
* Select tools, programmer, USBASP.
* Select tools, burn bootloader.
* You will see "Cannot set sck" errors. Ignore these.
* The IDE will tell you that it's finished (in very small print at the bottom).
* Select Sketch, then Upload to install your custom Marlin configuration.
* Unplug USB and serial.
* Power down your ANET 3d printer.

Upon reboot you should see the Marlin firmware splash screen on your printer's LCD.

Da un messaggio su una valutazione della scheda di comando sembra che la cosa sia un pochino complicata su alcune schede v 1.5

Saluti

Carlo D.


P3Steel - MKS GEN v1.2 e REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER + Gen 7 MOSFET (HotBed) + alimentatore step-down 12V -> 5V
Firmware MK4duo 4.3.5 (4.3.6 in testing) con ABL capacitivo - Slic3R (Originale) ed ESP3D per controllare la stampante da remoto.
HotEnd Cinese V6 clone con ugello da 0.4mm.

[My Building Log]
Re: Problema esttusore con Petg
November 13, 2018 08:28AM
Luca, Carlo, grazie dell'attenzione,
Sono sicuro vi rendiate conto di quanto siano preziose le vostre info.
Non ci conosciamo e quindi è difficile per voi valutarmi e valutare quale sia il mio skill:
sono piuttosto "abile" in ambiente informatico e meccanico (lungi da me l'idea di vantarmi vorrei solo darvi qualche info di ritorno per meglio permettervi di aiutarmi) ma ora sono (sulle stampanti 3d) in quella fase in cui non hai ancora dissolto la nebbia generale e costruito quei pochi punti di riferimento ai quali poi ti puoi appoggiare e sui quali poi puoi costruire cercando info ed assemblandole.

Precisazione la stampante ha il sistema Bowden


Luca;
mi confermi quindi che la temperatura che ho letto sulle bobine del PETG ovvero 210-240 potrebbe quindi essere sufficiente, resta allora il fatto che la Vref potrebbe essere bassa.
Purtroppo sulla mia scheda non ci sono i potenziometri per regolarla (Anet3d V1-5) come diceva Carlo c'è solo un potenziometro delle Z.
Cosa intendi per "più precarico al feeder" ? intendi la molla che chiude la ruota godronata sul filamento? se il problema fosse di una molla poco forte però il filamento semplicemente slitterebbe con minore qualità di stampa ed invece il motore perde passo il che vuole dire che sforza troppo ergo o la vref è poca o lo sforzo di estrudere il filamento è troppo.

Carlo,
escluderei la molla poco carica resta la tua ipotesi di molla troppo carica che segna il filo e genera attriti.
verifico stasera lo stato del filo e poi provo a ridurre il carico (se possibile).

Il caricamento del firmware sulla mia scheda dovrebbe essere possibile,
a parte quello l'MK4duo (che sarebbe quello che vorrei usare) ho visto un paio di video e di siti ove spiegano come caricare il bootloader sulla mia scheda e come poi caricare un firmware.
In pratica prima dovrei flashare il bootloader e poi la stamapnde sarebbe in grado di ricevere firmware.

Ma sul caricamento ci andrei con i piedi di piombo, non vorei ritrovarmi poi a piedi...........

Ora mi studio il link del caricamento del marlin 1.1.9.

stasera faccio qualche altra prova e vi aggiorno.

Edited 1 time(s). Last edit at 11/13/2018 08:31AM by filofilato.
Re: Problema esttusore con Petg
November 13, 2018 11:40AM
Quote
filofilato
...c'è solo un potenziometro delle Z...

Riesci a mettere una foto della tua elettronica?
Genericamente i driver sono componenti a parte, montati sulla scheda e non integrati


Qualcosetta più che un neofina oramai, anche se non si finisce mai d'imparare!
DUE Stampati GEEETech i3B, GT2560+, Marlin GEEETech originale con un paio di modifichine personali (Pin dedicato per la Z Probe e stampa dell'ETE da SD), Barre Trapezie, Estrusore da 0.3 con filo da 1.75, una con estrusore metallico ed una con estrusore ridisegnato e stampato da me, Software AutoCAD/Slic3r/Repetier

My Thingiverse
My Linkedin
Re: Problema esttusore con Petg
November 13, 2018 12:07PM
Se puoi caricare Marlin, MK4Duo è una versione "personalizzata" di Marlin che è stata sviluppata da un utente di questo forum, e cucita per adattarsi ad alcune modifiche e personalizzazioni create in ambiente italiano, come il "flusso canalizzatore" ed altre cose, il problema è cosa vuoi farci stare su quella scheda, che a naso ha un paio di limitazioni, ha pochi pin disponibili per l'espansione (non ha la piedinatura della Ramps per quanto riguarda gli AUX e i servo ad esempio) ed è dotata di componenti "non eccelsi".

Il problema delle modifiche in genere risiede nelle differenti combinazioni di opzioni e nelle prestazioni che vuoi ottenere, però per poter prendere qualche decisione devi considerare un paio di cose:

Primo

Lo stato dei firmware per le stampanti 3D in genere è che le versioni per 8bit ormai si possono considerare "mature" e in fase di "manutenzione per il funzionamento" nessun nuovo processore presumo venga implementato o nuove funzioni in quanto ormai si è raggiunto un livello talmente alto che il processore arrranca sia come numero di pin che come velocità di elaborazione.

In soldoni, non pretendere troppo da quella scheda, limitati a capire dove arrivano i suoi limiti (e secondo me ci sei molto vicino con le cose che vuoi fargli fare).

Soluzioni alternative ce ne sarebbero anche, sono state provate agli inizi dell'avventura RepRap Elettroniche modulari con parti che "comunicavano tra di loro" quindi altamente modificabili e che lasciavano il campo a sperimentazioni interessanti, c'era una "elettronica di base", un "modulo di controllo motori" un "modulo controllo estrusori" che comprendeva il driver per i motori e il controllo della temperatura (che non era fatto dall'elettronica di base, che si limitava a dire alla "scheda di controllo temperatura" voglio 180°C, e magari interrogarla ogni tanto per visualizzare un dato sul display).

Però come al solito ci vuole gente che porti avanti i progetti e in genere non ce ne è in giro molta, con le opportune competenze, il tempo libero e anche le risorse ecoomiche per farlo. (dovevi ordinare le schede e poi assemblarle), tutto questo poi ha portato alla RAMPS e a tutte le altre cose che trovi in giro oggi, un progetto interessante è il Gen 7 a 32 Bit però nessuno tranne l'autore ci ha scritto del firmware che ci giri sopra, in quanto è stato usato un chip ARM che non è "compatibile" con Arduino Due o all'altra versione del processore a 32 bit usata da Arduino (ora non ricordo).

Secondo

Analizza bene il mondo delle "32 bit" però soluzioni "economiche" non ne trovi molte in giro, siamo ancora nel campo del "relativamente costoso" o molto "personalizzato" nel senso che ci sono schede All-in-One ma per ora sono per "hobbysti esperti" e "danarosi" sotto i 100 Euro una All-in One, mi sembra che non si trovi ancora in giro nulla.

Ovviamente tutto dipende da cosa vuoi farci con la stampante 3D, e dal tuo budget.


Un approccio ragionevole è quello di rimanere ad "8 bit" con "materiale decente ma ancora economico" ed in futuro sostituire la scheda di controllo con una 32bit non appena il mercato permetterà di avere "soluzoni economiche alla portata di studente delle superiori senza papà ricco".

Poi al solito è una mia personale visione e sicuramente ho dimenticato qualcosa.

Saluti

Carlo D.


P3Steel - MKS GEN v1.2 e REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER + Gen 7 MOSFET (HotBed) + alimentatore step-down 12V -> 5V
Firmware MK4duo 4.3.5 (4.3.6 in testing) con ABL capacitivo - Slic3R (Originale) ed ESP3D per controllare la stampante da remoto.
HotEnd Cinese V6 clone con ugello da 0.4mm.

[My Building Log]
Re: Problema esttusore con Petg
November 13, 2018 12:18PM
Quote
Luca_Benedetto
Quote
filofilato
...c'è solo un potenziometro delle Z...

Riesci a mettere una foto della tua elettronica?
Genericamente i driver sono componenti a parte, montati sulla scheda e non integrati

Da quello che ha detto in precedenza è una Anet v1.5, il solo potenziometro è dato dal fatto che solo l'asse Z in quelle stampanti può assumere versioni diverse con uno o due motori oppure con estrusore integrato o bowden, quindi con "carichi" diversi e che necessitano di regolazione.

probabilmente questa:

una a caso

O almeno è quello che una rapida occhiata al modello di stampante rivela su internet. Non cercherei cose esotiche su quella scheda rispetto all v 1.0 molto conosciuta dalle varie Anet a8 e a6 magari ha qualche componente migliore nella parte di potenza (MOSFET meno delicati) e qualche miglioria nell'elettronica di contorno.

Qui qualche info sulla famiglia delle Anet

la E12 è una E10 con dimensioni di stampa leggermente più ampie.


Ad esempio il display LCD non ha una SD in quanto è integrata nella scheda madre.

Saluti

Carlo D.


P3Steel - MKS GEN v1.2 e REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER + Gen 7 MOSFET (HotBed) + alimentatore step-down 12V -> 5V
Firmware MK4duo 4.3.5 (4.3.6 in testing) con ABL capacitivo - Slic3R (Originale) ed ESP3D per controllare la stampante da remoto.
HotEnd Cinese V6 clone con ugello da 0.4mm.

[My Building Log]
Re: Problema esttusore con Petg
November 13, 2018 02:40PM
Si, confermo, la scheda è assolutamente quella postata da Carlo.

Per quanto riguarda lastampante devo dire che se riesco a risolvere questo problema dell'estrusore la stampante mi va bene.
Devo anche dire però che l'idea di installare il FW marlin mi piace per esempio per provare il bed leveling manuale.

Ho verificato anche io che esiste la possibilità di installare il FW marlin
[www.researchgate.net]

(come fate a mettere i link in modo così figo...???)

Carlo mi hai anticipato...........stavo proprio guardando le ramps.
a quali schede ti riferiresti per esempio tra le economiche ma già più moderne?
per esempio alle ramps 1.6 tipo questa [it.aliexpress.com]
potrei fare tutto ?


Luca , si come diceva Carlo la mia schedina ha i driver integrati-

Edited 3 time(s). Last edit at 11/13/2018 02:44PM by filofilato.
Re: Problema esttusore con Petg
November 13, 2018 02:58PM
Foto estrusore ed hot end
Attachments:
open | download - hot.JPG (29.6 KB)
open | download - estrusor motor.JPG (33.4 KB)
Re: Problema esttusore con Petg
November 14, 2018 12:21PM
Sono sempre più convinto che si tratti di una perdita di passo dovuta allo sforzo maggiore della soglia di taratura (della I o v che sia) del motore dell'estrusore (vi chiedo un atto di fede in questo senso).
(Per esempio se durante un tratto di riempimento di una faccia dove l'estrusione è costante "accompagno" il motore anche solo un pochino il fenomeno scompare).

Ho provato a modificare da terminale il valore della corrente del motore ma non sembra variare nulla.
M906 E600 per esempio per impostare 600 mA (il motore ha corrente nominale 900mA).
ho dato il comando da terminale prima di lanciare una stampa usando octoprint.
Ho dato valori 300 400 500 600 700 e 800 ma anche 005


Quello che non mi convince è che sia salendo fino a 800 sia scendendo a 5 non cambia nulla.
Se il valore avesse agito effettivamente a 005 il motore avrebbe dovuto nono essere in grado di lavorare ed invece scatta ne più ne meno da cvui deduco che non ho settato un bel niente.
Che svarione sto prendendo?

Non ho salvato con M500 perchè ho paura di modificare se prima non riesco a leggere quale valore è impostato.
Non trovo un comando per displayare il valore M906 .
Re: Problema esttusore con Petg
November 14, 2018 01:08PM
Secondo voi se installo il FW marlin su questa scheda
[www.researchgate.net]

ci sono possibilità che poi riesca a modificare con successo i valori della i del motore dell'estrusore o ancor meglio che i valori preimpostati siano diversi e magari il problema si risolva (ammesso e non concesso che sia un problema di i max del motore )?

oppure pensate che rischio grosso di ritrovarmi "a piedi" ?

-------------------

aggiornamento:

ho flashato il bootloader e caricato il FW marlin.

Il problema è praticamente sparito.
Ora appare solo se stampo sotto i 240 gradi a velocità dai 60 mm/s in su diciamo che in una configurazione tipo 245° e 40-50 mm/s non si presenta più.

Ci sono molte cose che voglio approfondire sul fw e questa è stata un'occasione per andarci a sbattere un poco col naso.

E poi vorrei caricare il FW del MagoKimbra............vado a studiare...........

grazie ancora Luca e Carlo ci sentiamo

Edited 2 time(s). Last edit at 11/14/2018 05:12PM by filofilato.
Re: Problema esttusore con Petg
November 15, 2018 03:25AM
Per quello che ne so m906 serve per driver tmc, probabilmente è per quello che non ti cambiava nulla.


Prusa I3 Hephestos XL + Rumba + barre trapezie 8x2 + Hotend Iec 4.0 + Fw MK4duo
Re: Problema esttusore con Petg
November 15, 2018 11:10AM
Allora da una rapida occhiata quella scheda monta dei comuni driver senza regolazione elettronica, solo che si hanno risparmiato mettendo delle resistenze fisse per la corrente dei motori.

in giro ci sono delle modifiche che saldano un potenziometro al posto della reistenza fissa e permettono di regolare la corrente del motore, mi pare strano che almeno per l'estrusore non lo abbiano fatto già in fabbrica, ma tant'è magari a loro andava bene così.

Se vuoi sostituire la scheda, di economico e di quella classe hai la MKS GEN, io ho la v 1.2 economica e che al massimo è scarsina nel regolatore di temsione, però la trovi a 20-25 euro e un riduttore da 12V a 5V non costa i 15 - 20 Euro di differenza con la MKS GEN v1.4, e separi i carichi esterni come i led degli endstop e magari anche qualche altra cosa che in futuro vorrai aggiungere (ad esempio un modulo WiFi io per il mio ho speso 5 Euro, cos' divisi 1 Euro per il modulo WiFi, 1 Euro per la schedina che lo supporta e 2 Euro per il riduttore di tensione da 5V a 3.3v e al massimo 1 Euro di componenti di contorno come reistenze e diodi).

Poi cìè in giro di tutto, però ripeto le RAMPS 1.5 e 1.6 sono belle ma costose e hanno sempre il problema di Arduino Mega che sta sotto e che deve fornire la tensione a tutto e che lavora proprio al limite, la MKS GEN 1.2 ad esempio te la danno per 2A (io comunque più di 1A non ce lo preleverei visto che in genere mettono i dati di "picco"), io per sicurezza ho aggiunto un riduttore di tensione da 12V a 5V con 3 o 4 Euro in più.

Se guardi il mio Blog che ho in firma vedrai cosa ho fatto, ad esempio la RAMPS 1.5 e forse la 1.6 sostituiscono i fusibili autoripristinabili della RAMPS 1.4 con dei fusibili discreti mi pare nella 1.6 con quelli del tipo "automobilistico" come ho usato io nella mia soluzione, tieni conto che i portafusibili "professionali" che ho usato io costano 50 centesimi l'uno da un buon ricambista auto e sopportano tranquillamente 25 o 30A (provati io quando facevo l'elettrauto) senza scaldarsi.

Saluti

Carlo D.


P3Steel - MKS GEN v1.2 e REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER + Gen 7 MOSFET (HotBed) + alimentatore step-down 12V -> 5V
Firmware MK4duo 4.3.5 (4.3.6 in testing) con ABL capacitivo - Slic3R (Originale) ed ESP3D per controllare la stampante da remoto.
HotEnd Cinese V6 clone con ugello da 0.4mm.

[My Building Log]
Re: Problema esttusore con Petg
November 15, 2018 04:02PM
Mm mm Carlo, mi hai dato un bel Po di materiale da metabolizzare.

Ho caricato con successo Silla mia scheda il Marylin della t3hd e sto facendo delle prove col FW di magoKimbra.

Il FW t3hd lavora già come fornito ma è un Po scarsino di opzioni

Il Mk4duo invece è più completo ma mi satura la memoria.....
Domani sono in ferie e ci gioco......

Per ora l'opzione che più mi interessa e Il annuale bed Leveling.

Però tra 2 settimane e il mio compleanno e la moglie non sa cosa regalarmi......un cambio board non mi dispiacerebbe......

Guardo le schede di cui mi parlavi......
Re: Problema esttusore con Petg
November 16, 2018 02:31AM
Quote
filofilato
...un cambio board non mi dispiacerebbe...

Se vuoi cambiare board e vuoi restare su una "tutto in uno" mi sento di suggerirti la GEEETech GT2560 A+, la trovi anche su Amazon.


Qualcosetta più che un neofina oramai, anche se non si finisce mai d'imparare!
DUE Stampati GEEETech i3B, GT2560+, Marlin GEEETech originale con un paio di modifichine personali (Pin dedicato per la Z Probe e stampa dell'ETE da SD), Barre Trapezie, Estrusore da 0.3 con filo da 1.75, una con estrusore metallico ed una con estrusore ridisegnato e stampato da me, Software AutoCAD/Slic3r/Repetier

My Thingiverse
My Linkedin
Re: Problema esttusore con Petg
November 16, 2018 03:40PM
Grazie Luca,
E per la configurazione del firmware dovrebbe essere semplice?
Con la scheda che ho ora sto faticando, forse per ignoranza ma mi sembra non molto diffusa

O sbaglio?
Re: Problema esttusore con Petg
November 17, 2018 03:10AM
Quote
filofilato
E per la configurazione del firmware dovrebbe essere semplice?

Direi di si,
di fatto questa scheda è una "tutto in uno" fatta da un Arduino Mega 2560 + una Ramps, e non dovresti avere troppa difficoltà nel programmarla!
SUl configuratore del Mago se non erro è anche già presente come setting


Qualcosetta più che un neofina oramai, anche se non si finisce mai d'imparare!
DUE Stampati GEEETech i3B, GT2560+, Marlin GEEETech originale con un paio di modifichine personali (Pin dedicato per la Z Probe e stampa dell'ETE da SD), Barre Trapezie, Estrusore da 0.3 con filo da 1.75, una con estrusore metallico ed una con estrusore ridisegnato e stampato da me, Software AutoCAD/Slic3r/Repetier

My Thingiverse
My Linkedin
Sorry, only registered users may post in this forum.

Click here to login