Welcome! Log In Create A New Profile

Advanced

Kossel Full 3DMakerlab problema MK 4.3.x

Posted by paolopa 
Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 10:59AM
Salve sono da poco felicemente in possesso di una Kossel Full della 3DMakerlab e a differenza della mia precedente delta sono riuscito in pochi passi e pochi problemi a farla stampare in maniera decente anche se le stampe sono state solo di prova.
Devo dire che sono felice di aver dato fiducia ad una ditta italiana di cui posso dire solo bene per i piccoli problemi, subito risolti che si potevano presentare.

Detto questo veniamo al problema che ho, mi è stato fornito un firmware MK 4.1.2, dato che vorrei mettere un display Nextion come sull’altra mia stampante e su questo firmware non è possibile ho fatto il classico lavoro con il compilatore online e mi sono scaricato l’ultimo MK 4.3.x.
Facendo poi delle prove di stampadopo aver messo il MK 4.3.x mi sono accorto di un problema, cioè in un punto sembra ci sia materiale di troppo oppure il nozzle sposta del materiale quando passa e crea un problema di allineamento o se si guardata mentre stampa il nozzle sposta il materiale che sembra in eccesso o non freddo e questo lo disallinea come dalla foto cerchiata in rosso.

La prima cosa che ho provato è stata di controllare il piano, tutto allineato a dovere.
Ho controllato poi le varie temperature, provando a stampare a temperatura molto bassa ma il problema persiste.
Ho provato a mettere una ventola da 120 a raffreddare la stampa in quanto mi sembra che lì proprio in quel punto il getto dell’aria della ventola che raffredda il materiale passi molto poco rispetto ad altre parti, ma niente da fare.
Poi mi sono accorto che in quel punto la stampante effettua una ritrazione del materiale per poi spostarsi in un'altra zona e ricominciare a stampare proprio in quel punto.
Ho ricontrollato all’ora il valore di ritrazione dei 2 MK (4.1.2 e 4.3.x) ma sono settati allo stesso modo unica differenza un valore che nel 4.2.1 c’è mentre nel 4.3.x non c’è che è il Retraction Feedrate configurato a mille metto le 2 sezioni dell’estrusore qui sotto:


Ho all’ora provato ad alzare il valore Retract Acceleration di default a 3000 a 10000 ma il problema si presenta ugualmente anche se mi sembra in maniera leggermente di pochissimo migliorato.
Mi sembra di averlo messo altissimo, non ho più idee di cosa possa essere.
Possibile sia la differenza dei 2 MK dato che il 4.1.2 non presenta questo problema?


Hictop ALLUMINIO RepRap Prusa i3 3DP11 Radds V1.6 DRV8825
Nozle 0.4 filo 1.75 Nextion display 7" Diamond MK4duo 4.3.2

Kossel Full 3DMakerlab
Trigorilla 8bit
Nozle 0.4 filo 1.75 Nextion display BLTouch MK4duo
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 11:17AM
Il feedrate in ritrazione l'ho tolta ecco perché non la trovi... Unica cosa che potrebbe essere hai provato a fare i pid, le gestione è molto diversa dai due firmware...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 11:30AM
Quote
MagoKimbra
Il feedrate in ritrazione l'ho tolta ecco perché non la trovi... Unica cosa che potrebbe essere hai provato a fare i pid, le gestione è molto diversa dai due firmware...

No sinceramente non ho fatto i PID Autotune, anche perchè non ho attivato la eeprom nel 4.1.2 non è attiva e nel passaggio al 4.3.x non la ho attivata

serve la eeprom attiva, o ho detto una cazzata?


Hictop ALLUMINIO RepRap Prusa i3 3DP11 Radds V1.6 DRV8825
Nozle 0.4 filo 1.75 Nextion display 7" Diamond MK4duo 4.3.2

Kossel Full 3DMakerlab
Trigorilla 8bit
Nozle 0.4 filo 1.75 Nextion display BLTouch MK4duo
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 11:54AM
Assolutamente no... Quando hai i 3 valori li copi nel fw e rifai la compilazione e lo scarichi nella board...
Con la eeprom attiva sarebbe tutto più facile, ma se preferisci non averla va bene uguale...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 12:20PM
Quote
MagoKimbra
Assolutamente no... Quando hai i 3 valori li copi nel fw e rifai la compilazione e lo scarichi nella board...
Con la eeprom attiva sarebbe tutto più facile, ma se preferisci non averla va bene uguale...

Ok, ho fatto i Pid che mi danno così:
18:11:30.669 : PID Autotune start
18:11:30.669 : Hotend: 0 Temp: 200.00 Cycles: 5
18:14:07.526 : bias: 52 d: 52 min: 197.02 max: 206.76 Ku: 6.80 Tu: 31.26
18:14:07.526 : Classic PID
18:14:07.526 : Kp: 4.08 Ki: 0.26 Kd: 15.94
18:14:39.011 : bias: 47 d: 47 min: 196.39 max: 205.31 Ku: 6.71 Tu: 31.56
18:14:39.011 : Classic PID
18:14:39.012 : Kp: 4.03 Ki: 0.26 Kd: 15.88
18:15:09.336 : bias: 47 d: 47 min: 196.36 max: 204.13 Ku: 7.70 Tu: 30.38
18:15:09.336 : Classic PID
18:15:09.336 : Kp: 4.62 Ki: 0.30 Kd: 17.55
18:15:09.336 : PID Autotune finished! Put the last Kp, Ki and Kd constants from above into Configuration.h or send command M500 for save in EEPROM the new value!
18:15:09.336 : Kp: 4.62 Ki: 0.30 Kd: 17.55

Ma da quelli del 4.2.1 possibile tutta questa differenzaconfused smiley

Kp 18,15
Ki 1,24
Kd 66,62

Edited 1 time(s). Last edit at 01/29/2017 12:21PM by paolopa.


Hictop ALLUMINIO RepRap Prusa i3 3DP11 Radds V1.6 DRV8825
Nozle 0.4 filo 1.75 Nextion display 7" Diamond MK4duo 4.3.2

Kossel Full 3DMakerlab
Trigorilla 8bit
Nozle 0.4 filo 1.75 Nextion display BLTouch MK4duo
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 01:22PM
Si, perché come ti ho detto è più veloce la gestione della temperatura rispetto a prima e quindi gli interventi di spegni e accendi e della gestione pwm è molto diversa...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 02:02PM
Ho messo i valori e sto provando ma ho diversi problemi, il primo è che quando arriva a temperatura per poi iniziare a stampare (205°) subito dopo la temperatura scende a 193 e per circa un minuto non risale a 205° questo mi da problemi e i primi layer si imbarcano non aderendo bene al piano e neanche fra di loro, dopodichè parte a stampare a 205° gradi costanti fregandosene anche se accendo la ventola da 120 che soffia sul piatto di stampa.

Naturalmente la ventola da 120 non la accendo subito e ho provato anche a tenerla spenta ma in partenza non c'è verso di stabilizzare la temperatura ho una caduta di oltre 10° che fà una stampa di cacca poi tutto bene o quasi




Hictop ALLUMINIO RepRap Prusa i3 3DP11 Radds V1.6 DRV8825
Nozle 0.4 filo 1.75 Nextion display 7" Diamond MK4duo 4.3.2

Kossel Full 3DMakerlab
Trigorilla 8bit
Nozle 0.4 filo 1.75 Nextion display BLTouch MK4duo
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 02:35PM
Mi sembra molto ma molto strano... Tieni conto che io stesso ho montato il FW su 3 macchine diverse, la Kossel K2 con IeC V4, una Wanhao con scheda a 8 bit e il loro hotend, la Vulcanus che ha un E3D lite e in nessuna di queste sgarra di 1 grado...
Prova a rifare i pid, non vorrei che con i valori cosi diversi abbia sballato la misura....


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 03:16PM
Quote
MagoKimbra
Mi sembra molto ma molto strano... Tieni conto che io stesso ho montato il FW su 3 macchine diverse, la Kossel K2 con IeC V4, una Wanhao con scheda a 8 bit e il loro hotend, la Vulcanus che ha un E3D lite e in nessuna di queste sgarra di 1 grado...
Prova a rifare i pid, non vorrei che con i valori cosi diversi abbia sballato la misura....

All'ora ho rifatto i pid con questo comando:
M303 E0 S210 C5

e variano di un niente cioè prima era Ki 0.3 Kp 4.62 Kd 17.55

21:05:52.335 : PID Autotune start
21:05:52.335 : Hotend: 0 Temp: 200.00 Cycles: 5
21:09:04.139 : bias: 51 d: 51 min: 196.99 max: 206.72 Ku: 6.67 Tu: 31.26
21:09:04.139 : Classic PID
21:09:04.139 : Kp: 4.00 Ki: 0.26 Kd: 15.65
21:09:34.739 : bias: 47 d: 47 min: 196.90 max: 205.00 Ku: 7.39 Tu: 30.67
21:09:34.740 : Classic PID
21:09:34.740 : Kp: 4.43 Ki: 0.29 Kd: 17.00
21:10:05.358 : bias: 47 d: 47 min: 196.45 max: 204.17 Ku: 7.75 Tu: 30.67
21:10:05.358 : Classic PID
21:10:05.358 : Kp: 4.65 Ki: 0.30 Kd: 17.84
21:10:05.358 : PID Autotune finished! Put the last Kp, Ki and Kd constants from above into Configuration.h or send command M500 for save in EEPROM the new value!
21:10:05.358 : Kp: 4.65 Ki: 0.30 Kd: 17.84
Ma fa sempre ugualeangry smiley
Volevo aggiungere che come scheda ho una Trigorilla e in giro ho letto che danno molti problemi, sarà poi vero?

Edited 1 time(s). Last edit at 01/29/2017 03:24PM by paolopa.


Hictop ALLUMINIO RepRap Prusa i3 3DP11 Radds V1.6 DRV8825
Nozle 0.4 filo 1.75 Nextion display 7" Diamond MK4duo 4.3.2

Kossel Full 3DMakerlab
Trigorilla 8bit
Nozle 0.4 filo 1.75 Nextion display BLTouch MK4duo
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 05:55PM
Stò ribattendo i valori del compilatore, trovo una discordanza.

Io ho caricato il file Configuration della 4.2.1 direttamente nel compilatore della 4.3.x e ho fatto delle correzioni sui motori invertendo su alcuni la direzione.
Poi ho dovuto correggere, in quanto anche se livellato sul 4.2.1 il piano mi risultava sballato sui 3 punti di controllo tutti alla medesima misura di errore tranne che al centro dove era preciso e ho dovuto variare il Delta smooth ROD offset per compensare e tutto è tornato perfetto.

Ora controllando nel file del 4.2.1 Configuration_Delta.h trovo questa stringa:
#define DEFAULT_AXIS_STEPS_PER_UNIT {80.45,80.45,80.45,95.35,93.1,625,625}
dove dovrebbero essere i passi dei vari X, Y, Z, E0, ecc ecc. Trovo che E0 è impostato a 95.35 eye popping smiley ma nel compilatore della 4.3.x mi ritrovo che legge 157.56 dove ha preso quel valore?
Sbaglio io nel leggerlo?

Allego i file Configuration della 4.2.1 in dotazione, il file Overall uscito dalla 4.3.x e il file Delta.h


Hictop ALLUMINIO RepRap Prusa i3 3DP11 Radds V1.6 DRV8825
Nozle 0.4 filo 1.75 Nextion display 7" Diamond MK4duo 4.3.2

Kossel Full 3DMakerlab
Trigorilla 8bit
Nozle 0.4 filo 1.75 Nextion display BLTouch MK4duo
Attachments:
open | download - Configuration.h (40.4 KB)
open | download - Configuration_Overall.h (42.9 KB)
open | download - Configuration_Delta.h (7.6 KB)
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 05:58PM
Ok, quindi i pid sono ok... E la temperatura dopo aver fatto i pid è stabile se la porti a 205? Senza stampare intendo!!!
Potrebbe esserci un calo di corrente durante la fase di stampa per esempio che fa calare la temperatura...
Oppure di un piccolo falso contatto durante la stampa che fa rilevare temperature false


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 06:16PM
Si la temperatura se la porto a 205 senza stampare resta costante, proverò a controllare il sensore della temperatura e i collegamenti e meglio ancora a sostituire l'alimentatore che è molto piccolo intendo come grandezza, comunque lo cambio con uno più potente, ma domani.
Ma in riferimento all'errore di stampa Delle foto sopra potrebbe essere troppo materiale estruso dato i valori diversi di passi che riscontro nel file e quello che imposta il compilatore?


Hictop ALLUMINIO RepRap Prusa i3 3DP11 Radds V1.6 DRV8825
Nozle 0.4 filo 1.75 Nextion display 7" Diamond MK4duo 4.3.2

Kossel Full 3DMakerlab
Trigorilla 8bit
Nozle 0.4 filo 1.75 Nextion display BLTouch MK4duo
Re: Kossel Full 3DMakerlab problema MK 4.3.x
January 29, 2017 06:32PM
Perché il configuratore non legge quei valori li, ma un database che è alla fine del file.
"bedcenter00": "0",
"Xhomepos": 0,
"Yhomepos": 0,
"Zhomepos": 0,
"Xstepspermm": 80.45,
"Ystepspermm": 80.45,
"Zstepspermm": 80.45,
"E0stepspermm": 157.65,
"E1stepspermm": 93.1,
"E2stepspermm": 625,
"E3stepspermm": 625,
"E4stepspermm": 625,
"E5stepspermm": 625,
"Xmaxspeed": 300,
"Ymaxspeed": 300,
"Zmaxspeed": 300,

Il fatto che hanno modificato i valori a mano e non con il configuratore, cosa che io dico sempre di non fare se non per delle prove, ma poi di riportare sempre il tutto nel configuratore stesso..
Quindi devi rimettere a mano tutti i valori che non sono quelli che effettivamente stai usando in questo modo quando scarichi avrai un file pulito...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Sorry, only registered users may post in this forum.

Click here to login