Welcome! Log In Create A New Profile

Advanced

MK4duo 4.3.9. non funziona hotend/hotbed/fan

Posted by whitedavil 
MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 04:18AM
Buon giorno a tutti.

Notando degli aggiornamenti (29/05/19) sul sito del mago, ho deciso di riprovare la nuova versione ma sempre con gli stessi risultati.

Installo la 4.3.9 e i motori funzionano, esegue i movimenti impartiti correttamente, mentre tutta la parte hotend-heatbed-fan non risponde hai comandi.

Se avvio il PID autotune il software risponde correttamente e crede di star eseguendo tutta la procedura ma fisicamente l'hotend non si scalda.
Stessa cosa per heatbed e ventole.

Questo problema lo riscontro solo dalla 4.3.7 in su. Uso con successo la 436.

Inoltre, riscontro un problema quando collego fisicamente la SDcard.
In pratica collego il classico display 2004 con encoder e subito mi restituisce errori sui pilotaggi dei driver TMC2130SPI.
Per funzionare son costretto a staccare il cavo dei dati della SDcard.

Grazie

Un po di dati:
MKS GEN 1.4, TMC2130 in SPI, display 2004 con encoder

allego overall (la configurazione è ridotta all'osso)
Attachments:
open | download - Configuration_Overall.h (57.4 KB)
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 04:22AM
PS: Per scongiurare problemi di EEPROM eseguo questa procedura:

- installo il nuovo FW
- M502
- M500 (successivamente, se presenti, ricarico i dati di step/mm ecc e salvo nuovamente con M500)
-Spengo e riaccendo la stampante.
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 05:13AM
Non devi fare M502. Quando scarichi io nuovo firmware ha già di suo messo i parametri di default. Quindi solo m500.

Nel tuo overall non vedo settata la SD, il define SDSUPPORT è commentato. Se è commentato non setta i pin CS della SD card quindi quando la colleghi succede che risponde anche lei alle richieste sulla porta SPI dandoti i problemi sui TMC, tutte le periferiche SPI se sono collegate vanno abilitate nel firmware in modo che setti opportunamente i pin CS.

Resetta la eeprom con uno sketch qualsiasi che trovi su internet, cancella totalmente tutto quello che è scritto, poi rimetti il firmware e fai solo m500.

A quel punto mi fai sapere se va tutto..


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 05:23AM
Innanzitutto grazie mago.

Provo subito quello che mi hai consigliato.

Capito per la SD, ma non è possibile definirlo ugualmente? Io la SD non la utilizzo e non la utilizzerò mai, ma il display mi impone di connetterla altrimenti l'encoder non funziona.
Ma appena collego il relativo cavo, chiaramente senza nessuna SD inserita, mi restituisce gli errori di cui parlavo.

Mha, in teroria finchè non alzo il PIN CS della SD a +3.3V lei non dovrebbe rispondere sul bus SPI, almeno in teoria....

grazie intatnto
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 06:06AM
Niente da fare.

Ho usato questo sketch per resettare la eeprom:
 * EEPROM Clear
 *
 * Sets all of the bytes of the EEPROM to 0.
 * Please see eeprom_iteration for a more in depth
 * look at how to traverse the EEPROM.
 *
 * This example code is in the public domain.
 */

#include 

void setup() {
  // initialize the LED pin as an output.
  pinMode(13, OUTPUT);
  
  /***
    Iterate through each byte of the EEPROM storage.

    Larger AVR processors have larger EEPROM sizes, E.g:
    - Arduno Duemilanove: 512b EEPROM storage.
    - Arduino Uno:        1kb EEPROM storage.
    - Arduino Mega:       4kb EEPROM storage.

    Rather than hard-coding the length, you should use the pre-provided length function.
    This will make your code portable to all AVR processors.
  ***/

  for (int i = 0 ; i < 4096 ; i++) {
    EEPROM.write(i, 0);
  }

  // turn the LED on when we're done
  digitalWrite(13, HIGH);
}

void loop() {
  /** Empty loop. **/
}

Poi ho caricato il FW, fatto M500 e..... nulla stesso problema.

Ti allego tutti i file da me modificati con le varie funzione che necessito.

A disposizione per prove ed affini

Grazie Mago
Attachments:
open | download - Configuration_Overall.h (57.4 KB)
open | download - Configuration_Laser.h (4 KB)
open | download - Configuration_Pins.h (8.9 KB)
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 06:14AM
PS: compilo con arduino 1.8.9
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 07:35AM
Ma perchè hai il laser???

Se hai il laser prima devi passare in modalità FFF altrimenti non si accendono i riscaldatori...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 07:49AM
lo so ben, il problema è che non vanno in nessuna modalità smiling smiley

Prima di aprire il topic le ho provate un pò tutte, compreso una configurazione base, solo FFF senza case light, offset, ecc.

Anche se vado sul configuratore, importo l'overall e disabilito tutto il superfluo per una FFF, comunque ho lo stesso problema.

PS: Non è che potresti aggiungere il supporto alla board FYSETC F6? smiling smiley

A disposizione
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 07:52AM
PPSconfused smileye vuoi, mi invii il FW in formato hex da te compilato e lo provo. io con versioni >= 4.3.7 non ne vengo fuori...
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 12:09PM
Ma a questo punto è un problema di pin, ma tu non hai quindi una MKS 1_3???


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 01:30PM
Scusa Mago, forse non sono stato chiaro.

la configurazione è nel primo posto (i dati dell'elettronica)

Poi, sulla mia stampante vado a montare sia un laser che un piccolo motore per fare incisioni sul legno ed è per questo che volevo sfruttare tutte e 3 le modalità.

Al di la delle modalità, anche se carico un fw con solo FFF, i riscaldatori e le ventole non vengono comandati.

nelle varie prove ho provato anche ad assegnare a mano i singoli pin nel apposito file, senza successo.

Ripeto, con la 4.3.6 funziona tutto ed è la versione che uso attualmente per stampare. Se vuoi ti posso dare l'overall e file annessi della 4.3.6

Mi piacciono le implementazioni nella nuova versione (sopratutto il comando M228), dimmi come posso aiutarti a capire il problema smiling smiley

Grazie
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 01, 2019 02:43PM
Allora dai il comando M306 e leggi che pin ha l'hotend, poi fai lo stesso con M306 H-1 segnateli.
Poi fai la stessa cosa per il pin della fan con M106.
Applica questo sketch cambiando il valore del pin con uno alla vota dei pin dei riscaldatori o della fan, lo metti e controlla se si accende. Mi raccomando stai attento perché questo accende e spegne ma non fa nessun controllo quindi la temperatura va su...
Se tutto vediamo altre cose..


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Attachments:
open | download - Test_pin_output.ino (177 bytes)
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 02, 2019 03:28AM
Buon giorno Mago.

Grazie per l'aiuto.

Appena finito una stampa, ho caricato la 4.3.9 e salvato con M500.

Di seguito i dati richiesti:

M306 H0 P10 A40 B230 C255 F250 L5 O400 U1 I0 Q0 R0
M306 H-1 T0 P8 A40 B230 C255 F100 L5 O150 U1 I0 Q0 R0
M106 P0 U9 L0 X255 F250 I0 H-1
M106 P1 U7 L0 X255 F250 I0 H-1

Come puoi vedere ho 2 ventole separate.

Subito dopo ho testato tutti i pin come hai chiesto e risultano tutti funzionanti.
Re: MK4duo 4.3.9. non funziona hotend/hotbed/fan
June 07, 2019 07:11PM
Ma è possibile che solo io ho questo problema?

Non credo di essere l'unico ad avere una mks gen 1.4 + tmc2130spi su una corexy
Sorry, only registered users may post in this forum.

Click here to login