Welcome! Log In Create A New Profile

Advanced

Poor Man's Digital Dentist Core XY build

Posted by Qdeathstar 
Re: Poor Man's Digital Dentist Core XY build
January 24, 2018 12:18AM
You can get a heat gun from harbor freight tools for $13.

The problem with hair dryers and heat guns is the type of motor they use makes an awful racket, about as pleasing to the ear as a vacuum cleaner due to the very high rotational speed. I doubt the motors are made for long operating life.

Cheap coffee makers usually have high powered heaters. If you pull one of them and clamp it to a heatsink, then blow air over it with a fan, you've got a pretty good heater for very low cost. They even come with TCOs attached.


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: Poor Man's Digital Dentist Core XY build
February 17, 2018 05:33PM
I have printed a few things with my printer and im trying to get it calibrated.

One issue that i am having is that it seems to be over extruding. However, if I tell the printed to extrude 20mm and measure it before the extruder, it appears dead-nuts on. I am calibrating the extrusion width using this method:

[print.theporto.com]


And it says i should set my extrusion multiplier to .83 after initial testing. My question is why? Isnt that setting just a fudge factor for something else that is messed up? Im pretty sure it is extruding too much plastic because when i extrude my tracks are wider than they should be which results in about 10-15 percent of overlap between lines. That pushes plastic up during the higher layers and causes the nozzle to wam into the print which causes the stepper motors to stall/skip steps.



Speaking of which, it seems like it is a lot easier for this printer to stall out than other printers i have used. I have got the belts pretty tight, i feel like it is the motors themselves that are stalling and not the belt slipping, but i have to investigate that issue further. It only happens when the nozzle strikes
the plastic as i said, so it might not even be an issue....

The other thing is when i print the cube, it is outer dimensions measure between 19.98-20.01 mm which is pretty good i think, but if i was that off with my extrusion steps id expect a problem to show up on the over all dimensions. Any thoughts are appreciated.

Edited 1 time(s). Last edit at 02/17/2018 05:35PM by Qdeathstar.
Re: Poor Man's Digital Dentist Core XY build
February 17, 2018 05:47PM
The single wall test is not accurate. I find it better to adjust the extrusion factor on the fly while printing top solid infill until I find a value that gives good results. Then I stick with that value for that roll of filament.

Motors stalling too easily usually means either the motor current is set too low, or the speed is too high for that combination of motor inductance, steps/mm and supply voltage. There is a calculator for maximum speed before torque starts to reduce at [reprapfirmware.org].

Edited 1 time(s). Last edit at 02/17/2018 05:49PM by dc42.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Poor Man's Digital Dentist Core XY build
February 17, 2018 06:05PM
20mm is too small to calibrate XYZ steps per mm. There is error in every measurement you make Error in your measurement becomes part of your calibration. If you print a bigger object, say 100 mm, that error will be multiplied by 5.

You should calibrate with as large an object as you can measure accurately. If you have a 6" caliper, print a 140-150 mm square. When you print smaller objects, the error in your large object measurement will be divided. You can check for squareness of the X and Y axes by printing a square/rectangle and measuring the diagonals. If the axes are square the diagonals will match.

Extrusion multiplier is a fudge factor used to compensate for filament that isn't actually the nominal 1.75 mm. But, you can just use the actual filament diameter and leave the extrusion multiplier set at 100%. Either way works. Extrusion multiplier requires that you print a test piece from every new spool, then mark the extrusion multiplier on the spool Using filament diameter requires measuring and calculating an average value. The site you linked uses 5 measurements. Not enough. Use 20-30. Filament isn't round, it's oval. You need to randomly orient the caliper on the filament as you randomly select points to measure. Once you've measured and calculated the average, mark it on the spool.

Use this calibration- it works well. Pay attention to the fine e-steps calibration. Also read the stuff on volumetric extrusion. It makes the gcode file uncritical of the filament diameter. You can reuse the gcode when you change filament spools and they are different diameters without having to reslice. You enter filament diameter at print time using an M200 command if you use host software or using LCD panel if your printer has one and the firmware supports entering filament diameter. Otherwise, use the average diameter when slicing. Whatever you do, use the calculated average filament diameter when calibrating the extruder. If your firmware don't know the filament going into the extruder, how can it be expected to extrude the right amount?

I don't know why it would be easier to stall unless you're using too small motors, running low current in the motors, or the mechanism isn't properly aligned and there's too much drag. For most moves both motors are contributing to motion, so you typically have more torque than either single motor can deliver moving things around.


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: Poor Man's Digital Dentist Core XY build
February 17, 2018 06:30PM
Thanks DC42. I used your calculator and found out that my steps per MM were off because i calculated with 30 teeth instead of 32 teeth. Oops. It also says the maximum speed:

Speed at which torque starts to drop (low slip angle): 125.2 mm/s @ 17.7 kHz

So, as long as all my speeds are less than that i should be good?


TheDigitalDentist, thanks. That would explain why my steps/mm could be off but it still appear like i am getting good results. I will print the larger square as recommended.

Edited 1 time(s). Last edit at 02/17/2018 06:32PM by Qdeathstar.
Re: Poor Man's Digital Dentist Core XY build
February 18, 2018 06:21PM
NO LONGER RELEVANT

This does not make a lot of sense.


I have been struggling to print that test option sense last night. What would happen is when it is printing the 45* angle infill (one stepper moving) it would skip steps and the layers would shift. I thought this was because the motors were straining so I lowered my print speed to 20mm/s and lowered my jerk to 50mm/min and then i noticed that the nozzle was digging into the filament so much it was actually flexing the mount for my exturders (which is made of 1/8* aluminum). I thought perhaps this was due to a bad level map/bed leveling. So I redid that, but still nothing joy. It kept jamming. So then i gradually reduced my steps per mm and it got better (took longer before the shift happened) but it was still happening. Perplexed i started reducing steps per mm by large amounts till i got down to half.

I am using these steppers:

[e3d-online.com]

They are listed on the website as .9* steppers. However, based on some previous discussion here

It seems like the the steppers might be 1.8* steppers. I've reduced my steps/mm by half (to reflect the 200 steps per rotation vs the 400 with .09* steppers and im currently getting the best results ive gotten so far. They are stamped ON THE MOTOR as being .9* motors. What is going on? Can you fry steppers to a point where they become 1.8 steppers, or did e3d make a mistake with these motors? Or what other logical explanation is there.


Another thing that makes zero sense is that when i did the extrusion test for calibrating steps/mm by making marks on the filament, if i was that far off on the steps/mm i should have been able to see it right? Well, it looked like was dead nuts on. I've just redone the test and It looks like when i command that 50MM of filament get extruder, i am only seeing 25mm of filament being extruded. (eg, a .9* motor). I also examined the print that was printing w/o skipping steps at the lower steps/mm setting and it sems like it is under extruding, but not by a lot.

I am guessing that i do have a .09* motor, and that the steps/mm are correct, but that something else is wrong. I am going to try to print a 100mm tall object to check and see if my steps/mm on the z axis are too low.

Edited 1 time(s). Last edit at 02/18/2018 09:33PM by Qdeathstar.
Re: Poor Man's Digital Dentist Core XY build
February 18, 2018 06:22PM
NO LONGER RELEVANT.




This is the top down look at one of the failed prints that had a layer shift. To me, it looks like there is a lot of over lap and that the groves made into the plastic are from the hot-end digging through rather than plastic being layed down.



Here is the bottom. Im kind of a crummy photo guy, but you can see the first layer prints OK, but once you get to the upper layers thats when it starts to have issues. This one skipped on the second layer. There seems to be a lot of overlap in the plastic extrusion.





This is the bottom of the one i printed at half steps per MM. No layer shifts, but you can clearly see lines on the bottom layer where the extrusions dont meet to form a base.



This is the top of the one i printed at half steps per mm. It looks pretty good, but the outside layers are bonded to well with the support extrusions and you can easily break it. But it sure was printing nicely.



I just had a thought to move my infil over lap from 10% to zero. So i am going to try that.

Edited 4 time(s). Last edit at 02/18/2018 09:32PM by Qdeathstar.
Re: Poor Man's Digital Dentist Core XY build
February 18, 2018 07:37PM
Didn’t really help. At all.



Re: Poor Man's Digital Dentist Core XY build
February 18, 2018 09:31PM
nevermind, my x-y steps actually were 106.67 not 100mm. I was going through my purchase history to determine the pulley teeth, and used the right one originally but the wrong one when use DC49s configuration over the weekend. Now i am able to print at least several layers of the calibration item without it skipping at a steps per mm that makes sense, so on to fine tuning the calibration
Re: Poor Man's Digital Dentist Core XY build
February 19, 2018 04:43AM
So the suggested 0.86 extrusion multiplier was in fact a combination of wrong e-steps ( 107% ) and wrong xy-steps ( 93% )? Imagine, you'd have 93% underextrusion instead, you wouldn't have noticed until you'd find your parts were too small.
Re: Poor Man's Digital Dentist Core XY build
February 19, 2018 07:37AM
no, i am essentially back where i started when i posted that. That suggestion was made with the corrrct xy steps. I changed them to the wrong steps before calibrating using the tool in the calibration guide. I am going through that calibration guide the digital dentist linked to now with the correct steps/mm

Edited 2 time(s). Last edit at 02/19/2018 07:39AM by Qdeathstar.
Re: Poor Man's Digital Dentist Core XY build
February 19, 2018 08:01PM
The Digital Dentist,

I noticed in this topic:

[forums.reprap.org]


You have a calibration object that you designed to help calibrate the printer. My question is do you still recommend it it? And, also, you said to calibrate the E-steps before using it. Im not sure that makes sense and so i wanted to double check with you.

Right now, I am using the large multi-stepped triangular object and it looks like while the documentation on e3d's site says steps/mm should be 837, after doing the calibration as listed in the link you provide, im going to be closer to 785 steps/mm (im still working on it, but i'm getting very close)


However, i was measuring my lastest iteration on the X and Y planes and I got 61.8mm on the X axis, and 62.29 on the Y axis. The object is supposed to measure 62.5mm on each side. Now, my thinking is that when I do the steps/mm calibration as listed with your design, the object will get bigger and this there is more "room" for the plastic and therefore i will need more plastic in order to fill the spaces -- Basically, because my object is too small i will be underextruding when the print is adjusted up to the correct size. Does that make sense?

Edited 1 time(s). Last edit at 02/19/2018 08:14PM by Qdeathstar.
Re: Poor Man's Digital Dentist Core XY build
February 19, 2018 10:05PM
That calibration cube works well for testing orthogonality, but it's not so great for squaring X and Y in a corexy machine. When you set up a coreXY machine, you want the X and Y axis rails to be square before you put the belts on it. Once you put the belts on, uneven belt tension can cause the X axis to skew a little. When you tension the second belt, it increases tension on the first belt, so you have to adjust carefully can check squareness while doing so. Checking alignment of the guide rails using a framing or large machinist's square is probably the best way to do that.

Are the diagonals matched and are you setting the steps/mm for X and Y to the same value?


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: Poor Man's Digital Dentist Core XY build
February 19, 2018 10:36PM
I am not exactly sure by what you mean “are the diagonals matched”... do you mean between the stepper motors and idler pulleys?

Step/mm are set to the same value x/y
Re: Poor Man's Digital Dentist Core XY build
February 19, 2018 10:48PM
No I mean the print diagonals. If they match, the X and Y axes are square.


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: Poor Man's Digital Dentist Core XY build
February 19, 2018 11:03PM
It’s still printing, got about 2hours left on it, but it’s looking good while it’s printing.
Re: Poor Man's Digital Dentist Core XY build
February 20, 2018 08:26AM
Ok, so on XZ plane and YZ plane, both horizontals measure 141mm on each plane. On the xy plane, one measures 141mm and the other measures 140mm. So those are a little off. What is a realistic margin of error for a reasonable well built machine? That looks like a decent tolerance over the size of the object, but I have no idea really. Also, assuming the x and y axis was square before the belts, is this a symptom of different belt tensions? Is there an accurate way to make adjustments other than modify and retest?
Re: Poor Man's Digital Dentist Core XY build
March 28, 2018 09:12PM
Hi guys.

Unfortunately I am not getting a sucessful print with a larger nozzle.

I have recalibrated my extrusion, decreased the extrusion width, and recalibrated my bed leveling. I have also verified z-steps per mm (by putting the nozzle at bed level, then lowering the bed by 100mm and measuring).

The first layer looks pretty good but the second layer is terrible. It looks like it is too high. I’m not sure though. What ends up having is that the nozzle digs into the plastic, and then skips steps. I haven’t kept track of if it is at the same exact spot each time, but it never makes it past the second layer and never fails before the second layer....











I have cross posted this here:

[duet3d.com]

But if I get solution there I will update this topic
Re: Poor Man's Digital Dentist Core XY build
March 29, 2018 03:34AM
You sure print the first layer pretty slow and the extruder is up to it. But the following layers are printed faster. Too fast for your extruder? E-stepper current too low?
Did you run a PID calibration for the extruder heater? Maybe you see a huge temp drop in layer two?

I also saw your perimeters weren't exactly parallel to each other. There is definitely some backlash in the XY movement.
Re: Poor Man's Digital Dentist Core XY build
March 29, 2018 07:47AM
Olampe, those are some great suggestions, i will give them a shot. i’m not sure how to tackle the backlash problem, everything feels pretty stiff.
Re: Poor Man's Digital Dentist Core XY build
March 30, 2018 08:09AM
Yea, the temperature stayed pretty steady but I think the aero extruded just didn’t have enough torque to pull through .4mm of filament at 60mm/s

I tried 40 mm/s and it got 4-5 layers deep before failure so I lowered it again to 30 mm/s and it seems to print fine 8 hours in.

I didn’t hear any clicking from the extruded, so my guess is that the cog was just grinding on the filament slipping in it.

Unfortunately I’m out of white pla due to all the “testing” so I put the printer on pause while I wait for some more.

I will need to test the backlash later, because at the slower speed it doesn’t show up. I had printed some larger parts using a .4mm nozzle and didn’t see any issues, but they were all square parts.


Thanks olampe!
Re: Poor Man's Digital Dentist Core XY build
March 30, 2018 09:00AM
Are you using a pancake motor on the extruder?

I use a 40 mm motor on my Titan/v6/0.4mm and it can keep up at >200 mm/sec.

If it is chewing up the filament, the pinch roller pressure is not high enough.


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: Poor Man's Digital Dentist Core XY build
March 30, 2018 09:51AM
Yes, I am using the pancake motor, but I don’t think the motor is stalling.
Re: Poor Man's Digital Dentist Core XY build
March 30, 2018 10:37AM
I looked at the video on the other forum- the pair of lines interspersed with gaps is a backlash problem or you're driving one motor at different steps/mm than the other. Check the XY mechanism for smooth operation- it may operate smoothly without belts but start to bind when you apply belt tension. Try printing the same pattern in the other direction- does it do the same thing? Verify that the motors are operating at the same current. My printer doesn't have particularly high torque motors (64 ozin, IRIC) but I can't imagine that dragging the nozzle on a previous layer could cause the mechanism to skip steps. When the motors are on I can't move the extruder carriage manually (at least with a reasonable amount of force applied, certainly far more than a nozzle drag could create without bending the heat-break).

As far as the extruder goes, I'm no fan of pancake motors. Many people think they need lower mass to print faster, so they strip out the things that make the machine reliable and capable of quality prints. A low torque motor on an extruder is asking for trouble, even if the motor has gear reduction. When you operate everything right at the limit of its performance, as soon as something isn't ideal, the mechanism fails. Reliability is about building in some margin. A little more motor mass and maybe a little slower printing is a small price to pay for an extruder that "just works".


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: Poor Man's Digital Dentist Core XY build
March 30, 2018 11:26AM
Whether a pancake motor is a good idea or not depends entirely on the gearing. I suggest a formula from which the motor torque can be worked out at [duet3d.dozuki.com].

TL;DR: for something like a Titan (about 3:1 gearing) use a short stepper motor, but not a pancake. For a remote direct drive extruder (20:1 or 40:1), use a pancake motor.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Poor Man's Digital Dentist Core XY build
March 30, 2018 12:32PM
I am using the smaller stepper that e3d provides for the titan, so maybe that is not a pancake. For some reason they chose .09 degree steppers and afaik that generally is lower torque compared to a 1.8 degree motor and I doubt an extruder needs the extra resolution.

[e3d-online.com]

As far as the backlash, here is a picture of the first layer (though it is being printed at about 30mm/s where as the second layer outlines in the video were being printed at about 45mm/s.


The first layer looks ok.



Edited 3 time(s). Last edit at 03/30/2018 12:53PM by Qdeathstar.
Re: Poor Man's Digital Dentist Core XY build
March 30, 2018 12:37PM
I agree that the nozzle hitting plastic shouldn’t cause it to skip steps though, none my other printers did that... they would just knock the print off the build plate or gouge it...
Re: Poor Man's Digital Dentist Core XY build
March 30, 2018 08:11PM
Hey guys...

This is the motor i am using for X and Y:

[www.ebay.com]


I have the current set to 1500 in the duetWifi. The stepper does not appear to be getting hot. (which is strange, isn't it, since I'm close to the rated current?)

Using a method that probably is invalid, it looks like it takes about 2.4kg of force to stall the motors. I used a fish scale attached to one side of the printer, and the other end to the y carriage and moved the carriage toward X-min until it stalled, which was at about 2.4kg. That is with both motors running. Im not sure how i would test one motor, since that is a diagonal movement.


I then pulled the fish scale in the x and y directions. In the X direction, it seems like it takes about 3kg of force to get it to move, in the Y direction it seems like it takes about 2kg of force to move (it is noticeably easier to move it on the y axis than on the x axis) It all moves fairly smoothly, but it does take a bit of force to move it in the x direction. I have attained a short video that shows that i am doing. (in a moment)


Here is the video:

[www.youtube.com]


I am in the process of ending out the audio, but its been stuck in "editing" for about 10 minutes. Its kind of loud and obnoxious.... So, mute grinning smiley Edit: I tried to mute the sound but now somehow some royalty free music got set as the sound and it is even more obnoxious so, just keep the mute on.. sorry.



My main question is, what does "smooth" mean, and do you think my printer is "smooth"?

Edited 2 time(s). Last edit at 03/30/2018 09:14PM by Qdeathstar.
Re: Poor Man's Digital Dentist Core XY build
March 31, 2018 12:18PM
Smooth means you should be able to move any X or Y with your little pinky and little effort.
BUT the steppers must be disconnected, that is the plugs removed.

Edited 1 time(s). Last edit at 03/31/2018 12:21PM by MKSA.


"A comical prototype doesn't mean a dumb idea is possible" (Thunderf00t)
Re: Poor Man's Digital Dentist Core XY build
April 01, 2018 08:51AM
Thanks.

I’ve checked the alignment for my x rails and although it appears to be quite good, i think eventually i will replace the rails with 25mm wide rails (they are 10mm now) and i will mount them onto an aluminum backplate, instead of directly onto the extrusion. This should help insure everything (idler, motormount, and rail) is dead nuts on.


We are in the process of moving so my mill is at the old house, i’ve got to see if it up to the task size wize, i think it is close.


For now, what i did was loosened the belt tension.Im not really sure what a good tension is, but before the belts were very tight so that when you plucked them, they made a sound like a string... now they have some give to them and the head moves easier. I’ve also been able to print since doing that. Is it possible the belts were over tensioned?
Sorry, only registered users may post in this forum.

Click here to login