Welcome! Log In Create A New Profile


My HyperCube Problem

Posted by Slapjack14 
My HyperCube Problem
November 17, 2019 05:57AM
Hello everybody

i have a problem with my freshly build Hypercube, and it is a problem ive been struggling with for 5 weeks now, and i have no clue what is going on... i hope someone on here is willing to help.. because im lost......

My setup:
- Bigtreetech SKR 1.3 mainboard
- 4x Bigtreetech TMC2208 in UART mode for X,Y,Z,E

My problem is this:

When i tried to print something i noticed my extruder was only going backwards during print.... so i cancelled, reversed my extruder output in the firmware and tried again.... it was extruding... but not extracting, something was off. I cancelled the
print again, and went back to the firmware to check settings in marlin, everything seems okay, so i used PronterFace to connect to my printer and heated up my nozzle to 185 degrees Celsius, so i could test extruder safely..

if i press extrude, my motor extrudes in the right direction, if i press retract, it still extrudes....., no matter what i do, my extruder only goes forward... no matter what input i give, with every command it extrudes....

i had no clue what was going on so i started to check everything...

Things i did:
- first i replaced my extruder motor with another stepper i knew was working, same problem
- the i ordered a new stepper driver for e0 slot, same problem
- i tried another axis on E0 output, same problem
- i was getting tired and i ordered a new motherboard, SAME PROBLEM!!!

i have no clue what to do next, i tried looking at my Marlin again, and yesterday i download newest Marlin 2.0 bugfix, copied the config.h and config_adv.h to it, reupload, same problem.

ive uploaded my files to this post

im lost....

hope somebody have some ideas

thanks in advance

Edited 1 time(s). Last edit at 11/17/2019 05:58AM by Slapjack14.
open | download - Configuration.h (79.6 KB)
open | download - Configuration_adv.h (105.5 KB)
Re: My HyperCube Problem
November 18, 2019 02:29PM
problem solved....
Re: My HyperCube Problem
February 11, 2020 07:14PM
What was the issue?
Sorry, only registered users may post in this forum.

Click here to login