Welcome! Log In Create A New Profile


Airwolf Axiom Z axis movement problem

Posted by jspring111 
Airwolf Axiom Z axis movement problem
June 29, 2020 05:31PM
I have an Airwolf Axiom printer that has a new problem I'm hoping someone can help me solve. It's an OK printer if you live within its limitations. It's a core XY machine if you're not familiar with it. Very bad heat creep with PLA but usually works OK with ABS. I think it could potentially be a good printer with the right upgrades. I don't have much experience with upgrading but I'm willing to learn. Airwolf won't release Firmware source code so I will eventually need to learn how to write it from scratch.

So I thought I'd start with the hot end. I bought a cheap E3d knockoff from Ali Express with the thought of buying the real thing if i can get it to work. So I designed and printed a new mount for the hot end to fit onto the existing direct drive extruder. It's a little longer than the old hot end so I had to make some changes in gcode so the nozzle wouldn't hit the bed. I did that and got it to print a couple test cubes but now it's acting all weird. I've figured out that the bed now won't travel up when I try to print. It moves around OK (I think) on X and Y and I think the bed will move down but not up. I connected it to Pronterface and I can move it up and down fine manually but it won't move up on Z when printing using gcode. I've tried printing things I've printed successfully in the past but same problem so I don't think the problem is in the gcode. I checked the Z limit switch and it is working fine. So I'm pretty sure it's not gcode or the stepper motor. And probably not the limit switch. I also tried reloading the firmware, no difference. It has auto leveling. It makes electrical contact between the nozzle and the metal rails on the build plate.

so when the build plate is all the way down,and the limit switch is depressed it reports:
> M119
Reporting endstop status
z_min: open


And when I raise the bed and the z limit switch is not depressed it reports: > M119
Reporting endstop status
z_min: open

z_max: open

Also, If I start the printing process, after it heats up, if the bed is up off the endstop, it moves down (as I believe it should since the gcode instructs Auto Home.
The next thing that should happen is the bed should rise to the top, and then perform a brush cleaning then auto leveling, then start the print.
But the bed never rises and the X and Y axes move as they should but if it gets that far before I stop the print, it will air print about 200mm above the print bed.

I've checked the leveling and limit switch wiring and all looks well and tests good for continuity.

I can't understand why it won't raise the bed. the gcode sends G28 (auto home) and then G1 Z0 F1200. (Z0 is the top of the bed's travel direction)

Does this make sense?
Re: Airwolf Axiom Z axis movement problem
July 02, 2020 12:29AM
You should contact Airwolf3d, They have good technical support team (at least from my experience).
Re: Airwolf Axiom Z axis movement problem
July 03, 2020 07:06PM
I sent Airwolf a message several days ago. They haven't responded.
Re: Airwolf Axiom Z axis movement problem
July 04, 2020 02:33AM
Call them. My last interactions with them were several years ago and I remember that call worked better than messages.

Edited 1 time(s). Last edit at 07/04/2020 02:39AM by piper3d.
Re: Airwolf Axiom Z axis movement problem
July 06, 2020 09:24PM
your endstop switches appear to be operating but can you raise the bed and trigger the Z_min endstop?
If Z_min is open, it should rise until it closes. If you turn the Z motor by hand is it difficult to raise?
Even if it were, because it is not tripping the Z_min endstop it should produce an error and stop.
Somehow it thinks it is getting to Z0. Since you don't have option of setting a config file, it sounds like an interrnal error issue.
By the way, based on the effort Marlin puts into their firmware, I suspect writing new code will be a lifelong process.
All printers have the same type of hardware. If I were updating, I think I would buy new electronics capable of loading Marlin and go with that.
Otherwise, you may begin to look like me with no hair.
Sorry, only registered users may post in this forum.

Click here to login