Welcome! Log In Create A New Profile


Screen and configuration issues with new Sapphire Plus printer

Posted by Peleg 
Screen and configuration issues with new Sapphire Plus printer
November 28, 2020 01:47PM
I've issues with a new Sapphire Plus printer that I didn't manage to operate. The printer's controller is MKS Robin 1.2.
1. The Touch screen is not working properly, When I press a screen button, most of the time, other buttons are activated, and also I can't activate the left side menu buttons at all. I've tried disconnecting and reconnecting the screen flat cable, but it didn't solve the problem. Is it defective screen ?
2. I've tried to update the firmware, hoping to solve the problem. I've used the firmware version and configuration of Sapphire Plus that I've downloaded from the manufacturer's site. I think that It's incorrect due to the actual size of the print attempt and the axis running of the limits. Can someone direct me the correct firmware and configuration file?
3. Is there a way to remote operation, or to send GCODE, by USB, In order to workaround the screen problem? What application and settings should I use in Linux?
Sorry, only registered users may post in this forum.

Click here to login