Welcome! Log In Create A New Profile


Error Message

Posted by sun2407 
Error Message
December 16, 2008 08:21PM

I just started building the RepRap machine. I installed the RepRap software and everything but when I execute the program I get the following error message.

Error initialising comms: java.lang.Exception
Could not connect at /dev/ttyUSB0.

Check to make sure that is the right path.
Check that you have your serial connector plugged in. The program will continue but your geometry preference has been set to 'nullcartesian' for this session.

I'm using the RepRap PowerComms board version 1.3 since I ordered this board long time ago. This is connected to my PC using a USB to serial adapter.

I have checked and made sure that my adapter drivers are installed and also I have tried different COM locations, "COM1, COM2, COM3, COM4" but that doesn't seem to be the solution. I have tried changing ttyUSB0 to "ttyUSB1, ..USB2" but that isn't the solution either.

Has anyone else had this problem? What could be the solution?

thank you
open | download - error message.JPG (124.4 KB)
Re: Error Message
December 17, 2008 03:34AM


look here:- [objects.reprap.org]


I can't help


Re: Error Message
December 17, 2008 04:40AM
If Linux make sure you are in the dialout group (or whatever group is given write access to /dev/ttyUSB0). Also check the system log from when you inserted the USB adapter to make sure that it was assigned to ttyUSB0.
Re: Error Message
December 17, 2008 07:26AM
I would say: Check what maps there are in /dev and try to locate the right map...

Are you using ubuntu or some different kind of linux? (i know from experience that even if they are in dev, the names can be different (like /dev/usb/ttyUSB0)
Re: Error Message
December 17, 2008 08:49AM
well from the picture I'd say it's not linux at all grinning smiley

Re: Error Message
December 17, 2008 11:21AM
I'm actually using Windows XP.

Re: Error Message
December 17, 2008 11:52AM
Ian's link above should direct you to the right place.

To find out which COM port the Arduino is using, go to the Windows Control Panel (Start -> Control Panel) and then the Hardware Manager (System -> Hardware -> Device Manager). Scroll down to Ports (COM & LPT) and expand the tree by clicking on the plus sign. There you should see something to the effect of a Communications Port (COM1) and USB Device (COM4). It may not be COM4 on your machine it all depends on how Windows addressed it when you installed the drivers. Back in the preferences of the Host Software, type "COM*", replacing * with the number you saw in the Device Manager (see attached). Make sure you use all capital letters for COM and no spaces between it and the number.

If you do *not* see the device in the Device Manager, you may need to reinstall the drivers. One way possible way would be to plug the Arduino into a different USB port. Hope this helps.

(edit to add pic)

Edited 1 time(s). Last edit at 12/17/2008 11:59AM by Rick.

- Rick

A chicken has a head the size of a walnut. Yet, even it has the sense to come in out of the rain.
open | download - Port Example.JPG (14 KB)
Re: Error Message
December 17, 2008 12:45PM
Thanks Rick. I think that worked out.

Sorry, only registered users may post in this forum.

Click here to login