Welcome! Log In Create A New Profile


Motor Problems

Posted by JPT 
Motor Problems
April 26, 2014 05:58AM

I'm having problems with my motors.
ie. they randomly lose steps, or don't move at all.

Hardware details:
- Sangoinololu 1.3a
- 12V 30A industrial power supply
- NEMA 17 motors: Wantai 12BYGH W811 - 47.0 N·cm - 3.1 V - 2.5 A, 1.8°
- MendelMax 1.5, which means on the Z-axis are two motors.
- The Z-Axis uses T8 not TR8.

The Z-Axis has problems when moving up, ie. it starts to move for about 5 mm, then is blocked. Sometimes it does not move at all. This has never been a problem during print because moving up one layer always worked. The current limit screw on the pololu seems to be already at it's max. (there are two motors attached!)

The Y-axis randomly loses steps. This was up to 5 cm during one layer. I tried to increase the current, but there is no end to the screw. it turns endlessly and goes back to min current at a certain position.
I reduced the max speed and max acceleration to:
Maximum feedrates (mm/s):
M203 X100.00 Y50.00
Maximum Acceleration (mm/s2):
M201 X9000 Y500
This helped, but there are still problems with the Y axis.
I did not touch the pololu screw any more, fearing to reach the min pos again.
Do you know any way to monitor the changes? ie measure current or move the Y motor continously so I have time to adjust the pololu screw?



edit: moving the motors by hand does not show any increased resistance.

Edited 2 time(s). Last edit at 04/26/2014 06:00AM by JPT.
Re: Motor Problems
April 26, 2014 10:17AM
I'm not familiar with that electronics package but why did you choose motors with that high of a amperage rating on the z that means you need a lot of amps. Most of electronics packages can only handle approximately 1.5 amp reliably

Edited 1 time(s). Last edit at 04/26/2014 10:21AM by cnc dick.
Re: Motor Problems
April 26, 2014 10:41AM
Well, this was a kit. But the kit sucks. I did not choose any of the components. I trusted in the vendor sad smiley

I wonder why printing works at all:
just before print start Sli3cer orders the z-axis up (which is blocked always),
after that it moves down again to start printing. this is blocked by the bed.
so the head sits directly on the glass.
calibrating the distance between glass and hotend at end-stop-switch is completely useless.

I ordered some TR8 hardware so I can replace the - how do you call them? - on z axis.
Do you suggest replacing the motors?
There is a nice list NEMA_17_Stepper_motor but this does not help the newbie. o.O

The Pololus ususally are rated at 2A per coil. Should be enough?
I don't know how mine are rated but they aren't getting hot...
Re: Motor Problems
April 26, 2014 12:08PM
It is kind of strange that your drivers are not getting warm do you have heatsinks on them with those motors they definitely should be turned up to the max and running especially without a fan should get very warm. It maybe you're just not able to run the printer long enough to see how hot they get take the plastic out of the extruder take the belts off the X and Y and try running a print so the motors can run for a while. I would look into what motors everybody else uses and possibly buy them. Be careful adjusting the drivers you should use a plastic screwdriver or you can do it with a toothpick chopped off like a chisel. And with the belts off slide the X and Y axis is back and forth their should be no resistance no binding mechanically at all should slide very freely from one end to the other with very very little push

Edited 4 time(s). Last edit at 04/26/2014 12:21PM by cnc dick.
Re: Motor Problems
April 26, 2014 02:02PM
Thank you very much! It works now.
The solution was to reduce max Z speed. 5mm/s looks soooo slooowww but was even too fast.

Well, the motors are just cold, but the pololus are hot, approx. 80°C. They only have heat sinks, no fan.
I was able to run the printer long enough but I never checked the temperature after it was running for an hour winking smiley
According to something I read today, the motors are completely over-dimensioned because at full 2.5 A they would heat up to 100°C which would melt the PLA they are mounted to.

Well, the bearings do not move that slightly one could expect. But I haven't got much experience with linear(?) bearings.
Created a turntable for a 3d scanner myself. This one is going easy! It's all about the quality of the bearings.

The toothpick is a good idea!

Re: Motor Problems
May 28, 2014 10:05AM

Working on my own - with similar problems to your description.

What were the setting changes you made to get to work?
You say you've reduced the "max Z speed", but I don't know which config parameter that identifies ?
Are you using A4988 or DRV8825 chips. The A4988, oriented with power on left pot on right, are supposedly set to 10 o'clock. DRV8825 are oriented with pot to left, toward power input, but not sure of proper pot setting - whether 10 o'clock or 4 o'clock
Re: Motor Problems
May 28, 2014 12:35PM
Hi Spurtee,

mine looks like this.

Maximum feedrates (mm/s):
  M203 X100.00 Y50.00 Z3.00 E25.00
Maximum Acceleration (mm/s2):
  M201 X1000 Y500 Z50 E10000
Acceleration: S=acceleration, T=retract acceleration
  M204 S3000.00 T3000.00
Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s),  Z=maximum Z jerk (mm/s),  E=maximum E jerk (mm/s)
  M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00

as you can see, the values for x axis are half those of y axis. and z axis is far less. I did not modify M204 and M205. No idea what they do. What does "jerk" mean?

you can read your settings by writing "M503", and you can save them to eprom, so they are restored on reset or poweroff by sending "M500"
see GCodes for a list of commands.

I don't know which chips i've got. there are heatsinks glued to them. The pot is to the right. I tried turning until it seemed to be max.

I just replaced my z axis M8 thread rods with TR8 because the M8 are already dead.
Boy, they don't want to move at all! Now I've got a problem!

Re: Motor Problems
May 28, 2014 06:36PM
Hey JPT,

If your pots are on the right, you probably have the A4998 chips. Supposedly, the flat-side of the pots should be aimed at 10 o'clock.
If you've got stops on your pot, so you can identify a max - your ahead. Mine don't and just turn around.

With your stops what is the range? I've heard it's from 7 - 4, low-high.

I see your X is twice that of Y.
Maximum feedrates (mm/s): M203 X100.00 Y50.00 Z3.00 E25.00
Maximum Acceleration (mm/s2): M201 X1000 Y500 Z50 E10000

Have seen ACCELERATION for X half what you have, 450 for all 3.
Can't give a good def of the jerk params, but it has to do with cornering.
Re: Motor Problems
May 29, 2014 04:53AM
Hey spurtee,

I cannot see any indication of the position on my pots. but yes, the range would match 7 - 4.
3 of my pots do have a limit, one doesn't. maybe I applied to much force to this one.
It is said, if they do not deliver enough power, you should try to apply a fan. Because they will just switch off if they became too hot which also results in lost steps.
Haven't done so myself, yet... The z axis *is* very hot, because it's two motors.

To find the spot between min and max:
  • run your motors slowly for a far move
  • turn clockwise until the pololus switch from max to min.
> I see your X is twice that of Y.
yes. and still the Y axis is less accurate than the X.
I am going to replace the transparent plastic (in german "Plexiglas") below the heat-bed with a 10 mm one, so it's more stable.

The problem with my TR8 is:
one of the nuts doesn't sit perfectly vertical. The TR8 and the rod aren't parallel. It's only 3mm on 40 cm, but it's too much.
I am considering moving the MendelMax z axis motors from the sides to only one on the top. Would be a lot of effort.
Sorry, only registered users may post in this forum.

Click here to login