Welcome! Log In Create A New Profile

Advanced

Reprogram Makerbot Electronics?

Posted by Katai 
Reprogram Makerbot Electronics?
April 06, 2010 12:00AM
I just got a set of these:
[store.makerbot.com]

They say it's preprogrammed for the makerbot. Does that mean I need to reprogram them to work for a mendel?
Re: Reprogram Makerbot Electronics?
April 06, 2010 02:33AM
Yes. The MakerBot FW is a different fork of the software.


Bob Morrison
W├Ârth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Reprogram Makerbot Electronics?
April 18, 2010 08:10PM
I'm having trouble programming my makerbot motherboard. These boards should have a bootloader preloaded, right? I have my USBtoTTL cable plugged in, but there doesn't seem to be any power LEDs on. Do I need to ATX power supply for this?

When I try to upload the software, I get "not in sync" as the error. I have no idea what this means, but I suspect that it doesn't see my motherboard at all.
Re: Reprogram Makerbot Electronics?
April 18, 2010 10:00PM
There's supposed to be a switch that selects how the cpu is powered, from the usb cable or powersupply.
Re: Reprogram Makerbot Electronics?
April 19, 2010 01:51PM
I don't see anything of the sort. There's an on/off switch, but that's pretty much it.
Re: Reprogram Makerbot Electronics?
April 19, 2010 03:50PM
For makerbot electronics, you have to get the timing right. I ran into the same problem you see above.

Step 1. Press the reset button on the makerbot motherboard.
Step 2. Click the button to upload the firmware.

You must perform step 2 within a few seconds of step 1 (1-3 seconds, if I recall)


I did not have this problem with a Arduino Mega -- I suspect that one of the serial pins, in combination with timing, allows autoprogramming without pressing the reset button manually.
Re: Reprogram Makerbot Electronics?
April 26, 2010 09:05PM
I'm still not having any luck.

I think it's because the black and green wires on my ATX power supply aren't connected. Do you need to do this on a Makerbot board? I was under the impression that Makerbot made the board so that no modifications were needed when you use the ATX power port. I can turn on the board by shorting the black and green wires, but I don't know if this is the proper way of turning it on.

So I got the power running. All the lights are running green. I hit the reset button before I hit upload. I hit the reset button after I hit upload. I hit reset 10 seconds before, 10 seconds after. I've mashed the button, I've left it alone, I've connected the two contacts that say "AutoReset" on it. I'm getting the same error. The bootloader is on the thing, right? Makerbot ships them with their own software, don't they?

Is the LED supposed to flicker when you press reset? Because my board isn't doing that.

Edited 3 time(s). Last edit at 04/27/2010 03:28AM by Katai.
Re: Reprogram Makerbot Electronics?
April 27, 2010 05:27AM
maybe it has makerbot firmware but no bootloader? if that's the case, you'll need an SPI programmer like this or this


-----------------------------------------------
Wooden Mendel
Teacup Firmware
Re: Reprogram Makerbot Electronics?
April 28, 2010 09:48PM
The board is supposed to come with firmware and the bootloader (I don't imagine you can upload any firmware without a bootloader). I guess I'll be RMA-ing these boards back.
Re: Reprogram Makerbot Electronics?
May 11, 2010 02:22AM
just wanted to add, the arduino auto-reset is on a special pin on the cable. According to the sparkfun USB to serial thing for programming arduinos, their prebuilt cables don't have the pin connected, but their circuit board does.(I think)smiling smiley
Sorry, only registered users may post in this forum.

Click here to login