Welcome! Log In Create A New Profile


Extruder board problems

Posted by steveo290 
Extruder board problems
June 16, 2010 10:27PM
Hey guys me again,
I am now trying to get my extruder stepper working. I connect it as I have seen all over the place but when I put power to it I hear a loud whine for a few seconds and then the motor starts jumping around on the table, the shaft not moving at all. This is with out the reprap host software being turned on as well. My heater wire will heat up as soon as I power the extruder board, with no reprap host software started. I figured this was not the proper behavior, to start trying to turn the motor and heat the wire as soon as the board gets power (someone please confirm?) Edit: Electronics are TechZone remix.

I decided to try and reinstall the firmware since I have a better understanding of everything now. I get the dreaded "not in sync" message. I try all the usual tricks and no dice. Everything is disconnected, except the usb stuff. Tried a million different times resetting as I am uploading, different timings as well, and nothing.

Is it possible that I blew something on the board? I still get green led's when I power the board. I do not have access to any kind of physical bootloader burner either. How do I tell if I blew one of the chips up? Does the TZ remix extruder board come with a led on pin 13? because only one led lights up and does not blink when the reset is pressed.

Edited 3 time(s). Last edit at 06/17/2010 09:09AM by steveo290.
Re: Extruder board problems
June 26, 2010 05:04AM
i dont Know this TechZone Elektronic. But the most error the People make ist to frorget 2 Wires...

Look at the Schema under (18) the Wires... without only DC Motor works.

Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Extruder board problems
June 28, 2010 03:45PM
I contacted TZ and worked with Lambert on this issue. Either the extruder did not have the proper boot loader on it or I screwed something up, I ended up sending it back and having a new one sent to me. Waiting on that to arrive by snail mail and when it does I will attempt to try this again and update everyone.
Re: Extruder board problems
June 28, 2010 08:25PM
steveo290 Wrote:
> I contacted TZ and worked with Lambert on this
> issue. Either the extruder did not have the proper
> boot loader on it or I screwed something up, I
> ended up sending it back and having a new one sent
> to me. Waiting on that to arrive by snail mail and
> when it does I will attempt to try this again and
> update everyone.

If everything works well... in couple of years he would e-mail you the design and you would print it out... smiling smiley
Re: Extruder board problems
June 30, 2010 02:38PM
I got the same issue. If it works out can you give us a shout?
Re: Extruder board problems
July 07, 2010 04:30PM
There is only 1 LED on the Extruder board when powered through the USB port. Also note that USB connector needs to be connected the other way around from the motherboard when programming the firmware.

Personally from a testing point of view, I have taken the approach this approach for testing.

(Assuming firmware programmed on the boards and the boards are not DOAs)

(1) Check motherboard turns on and works. - Get I get a response to G-CODE M105 (Should be 0)
(2) Connect the Extruder, RS485. -- DO not power on, should still get 0 for the M105 requests.
(3) Power on the extruder board (nothing else connected to the moment). M105 should now return something different (bogus but not zero value).

Power everything off.

(4) Connect the Direction and Step leads.
(5) Connect the stepper motor

Power on everything

Send the G-Code G92 E300, the stepper motor should turn and stop.

Reasons it doesn't

PWM drive current either to high or to low. -- Adjust the Pot on the extruder, or send G-Codes to change the current delivered to the PWM chips. -- This can be done but putting a test firmware on the extruder board which just exercises the stepper motor (you should see flashing leds when the motor is suppose to be turning), and then turning the Pot until the motor actually turns nicely. The Pot is now at the perfect position. (You then need to put the extruder firmware back on the extruder board.)

The directions cables are not connected correctly. This needs to be double checked.

I would then introduce the heater and the thermistor lines (I have to do this bit yet), but so far everything else is working.

Re: Extruder board problems
July 12, 2010 02:01PM
I finally got my extruder replacement board back from Tech Zone after 2 weeks of waiting. I hooked up the usb to 12 pin connector and was able to upload the program on the first try. I hooked up the other parts of the board and tried to heat/extrude but was getting a lot of errors in the console window of reprap host software. As well as the extruder tab portion of the host software, no temp reading and weird heating results from pressing the buttons.

I did some research and found that I was using the most recent extruder and motherboard firmware. I then decided to use the stable versions of both found in the reprap host software download. This did the trick. The extruder board lights up like a Christmas tree when I try to extrude and heat. Things look to be working properly except that my heating element is not wound correctly and looks to be shorting and burning up. I am going to post another thread.

Also, I found that some of my wire -> connector connections were giving me flaky results. I bought a soldering iron and some solder, soldered them up and now all connections are working great. Would really recommend everyone doing this if you are using the connectors where you press the wire into the connector and it cuts the wire coating to make a connection. Mine worked fine until I had to take things apart more then once.
Re: Extruder board problems
July 12, 2010 09:53PM
I agree with the comment about the wire->connector connections. As my cable has gone from working to iffu to failed with the press through connectors. (And you appear to only be able to remake the cable a few times before the connectors just fail.) I have orders some better connectors (I hope), and am waiting for them to arrive

Sorry, only registered users may post in this forum.

Click here to login