heatbed not working
September 07, 2015 03:06PM
So I've been trying to find the answer to this for days and I'm lost. I cannot get my heat bed to turn on. My hot end, fan and all other hardware are working perfectly. I am using Marlin and have attached my configuration file. The most obvious answers are my motherboard is type 33 or BOARD_RAMPS_13_EFB. I also have my temp_sensorbed set to type 1. My hot end gives a temp and will turn on. The heatbed give a temp of 0 (like it's disabled) and won't turn on. I also don't get any errors. I can do a print just without a hotbed. To force pins I put this at the end of my pins.h file:

#define HEATER_0_PIN 10 // Extruder
#define HEATER_1_PIN -1
#define HEATER_2_PIN -1
#define HEATER_BED_PIN 8 // Bed
#define FAN_PIN 9 // Fan

#define TEMP_1_PIN -1 // 1
#define TEMP_2_PIN -1 // 2
#define TEMP_BED_PIN 15 // 1,2 or I2C


Now I thought well there's no real firmware difference between the heatbed and hotend so without any hardware changes I swapped the temp and pin assignments for the hotend and the heatbed.Magically the heatbed works perfectly and the hotend says 0 degrees and won't turn on. That makes me believe it has to be firmware but can't figure it out. Any ideas?

Thanks, konkop
open | download - Configuration.h (25.9 KB)
Re: heatbed not working
September 07, 2015 06:18PM
Maybe the mosfet is broken? Does the ledturn on when heating the bed? Pin D8 is correct for ramps. You can try measuring d8 with a volt meter and see if it's changing when you turn on the heater.

Also make sure you've got power on the 11Amps input. You can connect a fan on the heater output to check if it's working. If so the heated bed may be faulty or not wired correctly.

ramps schematic

Uarduino mega 2560 schematic
Re: heatbed not working
September 07, 2015 06:39PM
But I can assign D8 to HEATER_0_PIN and when I send the gcode to heat the extruder the heatbed heats up and holds the temperature. And when I assign D8 to the extruder the LED does turn on when it is assigned to the heatbed it does not ever turn on.
Re: heatbed not working
September 08, 2015 04:14AM
The temp sensor needs to work in order for the bed to heat up. There are safety checks in the firmware to prevent the bed from overheating and cause fire.
Re: heatbed not working
September 08, 2015 02:36PM
It doesn't work if it is assigned to TEMP_BED_PIN but it works perfectly (with no hardware changes) when it is assigned to TEMP_0_PIN. The hardware works perfectly when assigned to the Extruder pins but acts disabled when assigned to the bed pins. The bed has to be disabled some how but I can't find anything that would be disabling it :-(.
Re: heatbed not working
September 08, 2015 02:52PM
What is the the resistance between the two wires pluged in to the Temp sensor pins for the heated bed on the Ramps board?

Make sure you check them at plug end to make sure there isn't a bad connection someplace between the board and the sensor.
Re: heatbed not working
September 08, 2015 04:52PM
I'll check when I get home. Would I get an error if the temperature registered too low? I am not getting any errors and am able to do a print, I just can't activate the heatbed causing problems with my print.
Re: heatbed not working
September 08, 2015 06:36PM
Yes it works because the firmware thinks the temp sensor of the hotend and the hot end are one system. You are basically fooling it to circumvent the safety precautions.

It's only sensible to power a heater if it is being monitored by a sensor. You risk a fire if you don't.

You can assign the hot end temp sensor as the heated bed sensor, but again you're only fooling the firmware and you'll not get a properly working 3d printer. Get a thermistor for the heated bed and it should complete the heated bed build.
Re: heatbed not working
September 08, 2015 11:55PM
No you misunderstand. I assigned both the heatbed thermistor and heatbed to the extruder and it worked. As the heatbed heated the temp went up appropriately. The resistance on the heatbed thermistor at the plug end was 98.6k at room temp. I held my finger on it and the resistance went down. But once i assign them back to the heatbed i get nothing. Sorry I haven't been very clear.
Re: heatbed not working
September 09, 2015 04:00AM
I just realized you're using repetier firmware, I'm not familiar with it unfortunately. But if the hardware works, it's a matter of properly configuringthe firmware. You can also try marlin firmware and see if that works. It sounds like repetier is configuring the analog input as a digital one, that would explain the readings you get. I think you need to find the proper board configuration so it will setup the ports correctly. Maybe it's configured without heated bed like two extruders and a fan. The configuration file is not documented so I can't help you there.
Re: heatbed not working
September 09, 2015 08:34AM
Oh man, I can't believe I mixed that up. I at one time used repetier but I am now using merlin and here is the attached configuration for merlin. I agree it has to be firmware and I can't see anything at all that is disabling the heatbed.
open | download - Configuration.h (35.1 KB)
open | download - pins.h (79.6 KB)
Re: heatbed not working
September 09, 2015 02:42PM
It seems to me that the pins.h maps pin 14 to the heated bed, see line 730. You can try plugging the heated bed thermistor into the second connector and see if it has a correct readout.

I'm not sure how the compiler handles #defines that has already been defined. If you want to play it safe, you can first #undef the define and then make your #define to replace it.

The second thermistor connector is assigned to the bed according to this schematic. Frankly I forgot where I connected mine winking smiley

Re: heatbed not working
September 09, 2015 06:38PM
I think first I would verify that the resisters are reading correctly with a meter. I use only 100k ones so I will check my hotend one and make sure that is is close to the same as by heated bed.

Then to verify they are plugged in to correct locations you can remove one and see if the value goes to 0 in the software it generates an error and you will have to reset it to get it working again, but seems to be a fool proof way to know if you have them swapped.

I looked at the files you uploaded not sure what version of Marlin you are using, you have your board set to 33 which is the old Marlin naming, but then the there is the newer style naming convention commented out right next to it.

#define MOTHERBOARD 33

If you are using the newer Marlin firmware the file that controls the pins is the one specifc to the board your using like "pins_RAMPS_13.h" for the RAMPS boards.

Edited 2 time(s). Last edit at 09/09/2015 06:39PM by AquaticsLive.
Re: heatbed not working - SOLVED!!
September 09, 2015 10:38PM
I am using the latest firmware from here: https://github.com/MarlinFirmware/Marlin/tree/Release/Marlin And I couldn't find a pins_Ramps_13.h. But either way I went back in and downloaded the latest firmware again. Changed the board type to BOARD_RAMPS_13_EFB. Changed the E1 and Bed sensors to 1. hooked everything up per imqqmi's suggestion and it WORKED!!! Comparing the two files side by side I found the problem. It was the temp bed pin assignment.

I had inadvertently deleted the underscore from the following line:
"#define TEMP_SENSOR_BED 1" so it looked like "#define TEMP_SENSORBED 1".

Sorry guys I should have tried re-downloading the firmware it before.
Re: heatbed not working
September 09, 2015 11:31PM
The newer version got moved to only the Dev branch instead of both and they rolled back to an older version in the release branch. Figured it was worth mentioning just noticed that after you said the pins_Ramps_13.h was missing from the realease folder of the firmware you downloaded. If you have yours working probably not worth moving to the newer version.
Re: heatbed not working
September 10, 2015 01:06AM
Good to hear it worked out!
Sorry, only registered users may post in this forum.

Click here to login